Jump to content

Recommended Posts

Bonjour,

je vais essayer d'être clair et compréhensible, j'espère que vous pourrez m'aider dans mes deux problèmes. Je travaille avec presta 1.6.1.11 - PHP 7.1

---> J'ai un problème de page blanche lorsque je cliques sur le module Mise à jour en un clic (v4.7.0)  pour initialiser la procédure d'une une mise à jour.

Sur cette page blanche la console m'indique:

2
HTML1300: Une navigation s’est produite.
index.php (1,1)
CSS3121: La requête de média -ms-viewport est déconseillée.
3
HTML1402: Il manque un point-virgule final (;) dans la référence de caractère.
index.php (66,136)
HTML1300: Une navigation s’est produite.
index.php (1,1)
CSS3121: La requête de média -ms-viewport est déconseillée.
5
HTML1402: Il manque un point-virgule final (;) dans la référence de caractère.
index.php (1985,1)
HTML1300: Une navigation s’est produite.
index.php (1,1)
CSS3121: La requête de média -ms-viewport est déconseillée.
5
HTML1402: Il manque un point-virgule final (;) dans la référence de caractère.
index.php (1913,1)
2
HTML1300: Une navigation s’est produite.
index.php (1,1)
HTTP503: SERVICE NON DISPONIBLE. Le service connaît une surcharge temporaire. GET - http://XXXX/adminXXXX/index.php?tab=AdminSelfUpgrade&token=e1a831c8c2d6b0468c3a8acecf69c615
HTML1527: DOCTYPE attendu. Ajoutez plutôt un doctype HTML5 valide : « !DOCTYPE html> ».
index.php (1,2)

 
J'ai changé le nom de mon site avec XXX

---> Sur la page Tableau de bord le rafraichissement ne s'arrête pas et je n'ai donc aucunes données...

Sur cette page la console indique:

HTML1300: Une navigation s’est produite.
index.php (1,1)
CSS3121: La requête de média -ms-viewport est déconseillée.
4
SCRIPT5002: SCRIPT5002: The value of the property '0' is not a Function object
dashboard.js (52,7)

 
Merci pour votre aide

Raph

Share this post


Link to post
Share on other sites

Ben le problème vient de là: 

HTTP503: SERVICE NON DISPONIBLE. Le service connaît une surcharge temporaire. GET - http://XXXX/adminXXXX/index.php?tab=AdminSelfUpgrade&token=e1a831c8c2d6b0468c3a8acecf69c615

A voir avec votre hébergeur et/ou consulter le fichier error.log

A priori le souci vient de votre version PHP 7 qui n'est pas compatible avec votre version 1.6

Share this post


Link to post
Share on other sites

Merci je vais voir avec lui. Je croyais pourtant avoir lu que la version presta 1.6 supportait le php 7.1 et vis versa.

Share this post


Link to post
Share on other sites

A partir de la 1.6.1.20 (avant on croit que ça fonctionne mais pas sur tout, la preuve)

Share this post


Link to post
Share on other sites

ben non, repassez en 5.6 le temps de l'upgrade

Share this post


Link to post
Share on other sites

Y-a-t-il possibilité de faire une mise à jour vers la dernière version 1.6 sans passer par le module mise à jour en un clic ? 

L'assistance de mon hébergeur n'est plus disponible et il ne travaille plus qu'avec les versions php 7.1, 7.2, 7.3.... 

Share this post


Link to post
Share on other sites

Super hébergeur...

Oui c'est possible, il faut écraser les fichiers cœur avec ceux de la dernière version 1.6.1.24 et exécuter le fichier /install/upgrade/upgrade.php

ensuite vider les caches.

Share this post


Link to post
Share on other sites

En fait il faut lancer install/upgrade/upgrade.php pour mettre à jour la base de données

Share this post


Link to post
Share on other sites

Là ça devient chaud pour moi :) écraser les fichiers cœurs. Je risque fortement de me retrouver avec une boutique bancale .

Ne serait=il pas préférable que je passe sur la 1.7 ? via le module de migration ?  

Share this post


Link to post
Share on other sites
Posted (edited)

Je vous laisse seul juge de votre décision alors... 

Quitter une boutique fonctionnelle pour aller vers une version non aboutie et plus complexe et plus lourde, c'est votre choix^^ 

Edited by Eolia
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Il ne serait pas préférable de changer d'hébergeur?

Car là tu dis mon concessionnaire n'a plus que des outils en mesures impériales alors ne devrais-je pas remplacer ma voiture par un scooter

Edited by doekia
  • Haha 1

Share this post


Link to post
Share on other sites
Posted (edited)

Je suis content de mon hébergeur (one.com) d'une manière générale, je travaille avec lui depuis 2005 et jamais aucuns soucis sur mes huits domaines mais là ça coince.  Je cherche la simplicité technique en rapport avec mes connaissances en la matière… et là ça coince également...

Merci pour vos conseils, je réfléchis à tout cela.

Edited by Raphael1312

Share this post


Link to post
Share on other sites

Je viens d'essayer en php 7.2 comme conseillé par dylan1252 mais le problème persiste.

Share this post


Link to post
Share on other sites

Comme on vous l'a déjà dit plus haut, PHP 7.1 ne fonctionne qu'à partir de 1.6.1.20 ! De plus, PHP 7.2 ne fonctionne pas avec Prestashop 1.6, n'écoutez pas @dylan1252 il raconte n'importe quoi : https://devdocs.prestashop.com/1.7/basics/installation/system-requirements/

Le problème c'est que votre hébergement n'est pas assez puissant pour utiliser le module de mise à jour automatique :

HTTP503: SERVICE NON DISPONIBLE. Le service connaît une surcharge temporaire. GET - http://XXXX/adminXXXX/index.php?tab=AdminSelfUpgrade&token=e1a831c8c2d6b0468c3a8acecf69c615

Cette erreur indique que votre serveur ne peut pas traiter votre demande.

Je vous recommande de faire la mise à jour en local : https://www.prestashop.com/forums/topic/519979-tutorial-comment-transférer-mon-site-local-distant-ou-linverse/

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More