Jump to content

Recommended Posts

Bonjour à tous,
Bonjour J'ai un site marchand, 
et il y a quelques jour mon hébergeur m'a proposé de me faire une mise à jour de mes sites,
car il étaient en PHP "Obsolète" ceci pour de raisons de sécurité.
Afin de fournir le meilleur service à nos clients et d'éviter que des utilisateurs fassent tourner leurs sites sur des versions de PHP obsolètes,
nous avons récemment mis à jour les versions de PHP de tous les sites sur serveur mutualisé. "

Toutefois une fois cette mise à jour réalisée mes sites ne fonctionnaient plus.
Nouvelle intervention, tout est rentré en ordre de fonctionnement,  sauf que 
Nous avons repassé vos sites auto-constructeur.com et preprod.cheminox.fr sur une version antérieure de PHP, le temps que vous puissiez mettre à jour vos scripts.
Nous souhaitons stopper cette rétrocompatibilité dès que possible et vous invitons donc à agir rapidement pour que vos sites supportent une version de PHP à jour."
Je dois donc apparemment mettre mon PHP à jour, est-ce que ceci se fait sur Prestashop ,??
Et dans ce cas où, quelle est la procédure ? Merci de votre aide.

DW 

Edited by DWAlsace (see edit history)

Share this post


Link to post
Share on other sites

Bonjour, les versions de prestashop évoluent en même temps que les versions de php. Vous devez donc probablement faire évoluer votre prestashop vers une version récente (1.6.1.23 ou 1.7.5.1) pour qu'il soit compatible avec les dernières versions de php. Voyez le détail dans ce graphique: https://devdocs.prestashop.com/1.7/basics/installation/system-requirements/

Attention: cela concerne également les modules, le thème et les éventuels bout de code customisés que vous avez ajouté ou fait ajouter. Eux aussi sont peut-être compatibles uniquement avec la version de php que vous avez et ont besoin d'une mise à niveau.

Considérez l'option de faire appel à un freelance pour cela, il vous fera tout ça bien et sans risque ;) 

  • Like 1

Share this post


Link to post
Share on other sites

Merci pour réponse, surtout aussi rapide..

Merci pour réponse, surtout aussi rapide, et précise.

Auriez vous les coordonnées de l'un ou l'autre Freelance.
merci d'avance

Denis

Share this post


Link to post
Share on other sites

Hélas je suis pas freelance ^^ mais dans ce forum vous devriez en trouver plein de compétents !

Share this post


Link to post
Share on other sites

Dernière petite question,
d'après vous combien de temps peux mettre la migration de 1.6 à 1.7.
après avoir fait le point sur ce que j'ai besoin (ou plus) comme modules

Share this post


Link to post
Share on other sites

Il faut que vous regardez:
- pour chaque module, est-il compatible 1.6 et 1.7 (si oui, normalement rien à faire, si non il faut trouver un remplaçant)
- pareil pour le thème: si pas compatible 1.7 vous devrez en prendre un nouveau 1.7 ou bien rendre votre thème compatible (vous ou un freelance)

Du coup selon la quantité de modules et la complexité du thème ça peut varier 😕et puis il faut trouver un freelance et attendre qu'il soit dispo (il a peut-être déjà des contrats en cours). Vous avez peur que le temps soit trop long et votre hébergeur vous force la main ?

Share this post


Link to post
Share on other sites

Bonjour Ksaan, 
Tout d'abord merci pour toutes ces informations, et le suivi que vous en assurez.
Je vais m'assurer dans la journée de la compatibilité

  • du thême   J'en profiterai pour en changer 
    car le choix qui avait été fait par le Free Lance de l'époque ne me convient pas. (langue anglais)
  • J'en ferai de même avec les modules utilisés

Concernant l'hébergeur, je ne pense pas qu'il essaie de me forcer la main,
il a en tout cas toujours été disponible, surtout quand c'est moi qui faisait une "GROSSE Bétise"

Merci encore à vous 
Denis

 

Edited by DWAlsace (see edit history)

Share this post


Link to post
Share on other sites

Bonjour Ksaan, 
Tout d'abord merci pour toutes ces informations, et le suivi que vous en assurez.
Je vais m'assurer dans la journée de la compatibilité

  • du thême   J'en profiterai pour en changer 
    car le choix qui avait été fait par le Free Lance de l'époque ne me convient pas. (langue anglais)
  • J'en ferai de même avec les modules utilisés

Concernant l'hébergeur, je ne pense pas qu'il essaie de me forcer la main,
il a en tout cas toujours été disponible, surtout quand c'est moi qui faisait une "GROSSE Bétise"

Merci encore à vous 
Denis

Share this post


Link to post
Share on other sites
8 minutes ago, DWAlsace said:

il a en tout cas toujours été disponible, surtout quand c'est moi qui faisait une "GROSSE Bétise"

 

Eh ben gardez-le alors ^^ tous les hébergeurs ne sont pas aussi sympas ou prévenants.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More