Jump to content
superskyman100

Impossible de réécrire les URLs

Recommended Posts

Bonjour,

 

Quelqu'un aurait-il une idée du pourquoi du coment il m'est impossible de réécrire les URLs ?

 

image.thumb.png.bc5a932c260b64e27c5c948a9278f906.png

 

Ici le message affiché....

 

Merci de votre aide 

Share this post


Link to post
Share on other sites

Bonjour,

Vérifiez dans vos pages si les URL rewrite sont bien en place, et attention à ne rien mettre dans "index" (j'ai déjà croisé ça). Comme votre site est multilingue, vérifiez cela partout, pour toutes les langues.

Vérifiez ensuite si vos paramètres d'URL sont propres, et vérifiez également si votre serveur dispose bien du mod_rewrite (ce qui est majoritairement le cas).

 

Share this post


Link to post
Share on other sites
Posted (edited)

bonjour cysoo, merci pour ton/votre aide mais pas de gant magique de l'infini aujourd'hui, juste des moufles ;)

je suis pas trop sûr pour "Vérifiez dans vos pages si les URL rewrite sont bien en place" .... Je vois pas d'option très claire à ce sujet, j'ai fouiné un peu partout je sais pas trop....

Je ne sais pas non plus où se trouve le truc 'index' je ne crois de ttes manières jamais avoir touché à ça, mais par acquis de conscience....

 

image.thumb.png.42113d05d9d5fb03fd442a96e89342d4.png

 

image.thumb.png.9effb08ea7b1ddc1db4bf7af3db8a5d3.png

 

 

 

 

Edited by superskyman100

Share this post


Link to post
Share on other sites

Dans la liste de vos pages, vous pouvez éditer depuis le bouton sur la droite les paramètres SEO & URL, élément par élément, langue par langue, en cliquant sur le bouton "Edit".Vérifiez chaque élément pour chaque langue pour bien être sûr que l'URL rewrite soit bien en place.

Le souci peut également venir d'un module, auquel cas il suffira de le désactiver, puis activer l'URL rewrite, puis réactiver le module.

Pensez à mettre la redirection en 301 au lieu de 302, et il peut se révéler judicieux de retirer des paramètres d'URL des produits la variable {$category}, comme l'a si judicieusement précisé Olivier Clémence sur un de ses articles de blog => https://www.reussir-mon-ecommerce.fr/les-reglages-prestashop-qui-peuvent-tuer-vos-ventes/

 

Share this post


Link to post
Share on other sites

Ok pour les petits conseils, j'ai tout suivi ! ;)

 

Pour le reste, les URLs rewrite c'est bien ce qu'il ya là en copie d'écran ?? pk ça j'ai vérifié depuis longtemps, tout semble en ordre...

j'ai également demandé à l'admin du serveur de vérifier pour le mod_rewrite.....

 

Rewriteurl.thumb.jpg.7875f2663ec9cf9120f32d10d89e7495.jpg

 

 

je me demande si la langue ''Australien'' créée from scratch (pas de pack langue) ne pose pas ce problème... Avec cette langue je n'arrive pas à accéder aux traductions... (erreurs sereur 505 si j'essaie de traduire le theme de base ou les modules)... j'ai donc essayé de désactiver la langue, mais j'ai toujours l'erreur "property META_URL is not valid"....... 

 

image.png

Share this post


Link to post
Share on other sites

Je serais vous, je supprimerai carrément cette "langue". Votre sysadmin peut également vous fournir des logs pour voir ce qui se passe, mais je parierai sur la langue "au".

Pour l'URL rewrite, oui c'est ça, il faut toutes les recontrôler pour vérifier qu'elles soient toutes bien traduites, propres, cohérentes. Renseignez également les balises title et les attributs meta description pour chaque langue.

Désactiver une langue ne suffit pas dans votre cas. Il faut la supprimer si elle vous pose autant de problèmes.

Share this post


Link to post
Share on other sites

Vous avez aussi probablement des modules qui utilisent le link rewrite. Essayez de désactiver par exemple le module de blog, puis testez à nouveau.

Une personne a eu ce souci et en a parlé sur le forum là =>

 

Share this post


Link to post
Share on other sites

J'ai essayé de bien remplir proprement tous les champs, même ceux qui ne sont pas remplis 'de base', rien à faire, j'arrive pas à réécrire les URLs

Je viens de faire des tests sur les PF de test et dev, en fait j'ai le même problème partout, même en remettant le thme de base... 

A priori voir avec l'admin server, y'a peut-être un problème de ce côté là..... je te tiens au courant pour retour d'expérience....

Share this post


Link to post
Share on other sites

Bon mon admin systeme vient forcer l'activation du mod_rewrite (deja activé de base) et rien de changé, toujours ce maudit problème.... Je sais vraiment pas quoi faire...

 

Suis en train de chercher dans cette voie... 

....

 

Share this post


Link to post
Share on other sites
Posted (edited)

Salut Cysoo,

Chose promise chose dûe, petites news j'ai réussi à corriger le problème en nettoyant la base de données avec les tables  *_lang

54 tables * 38 langues....................

Voilà, maintenant ma base de données est propre et le rewrite URLs fonctionne à nouveau, l'erreur Property Meta-> Url_Rewrite Is not valid a disparu 

Merci encore pour ton aide !

@+

Aurélien

 

 

Edited by superskyman100
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More