Jump to content

Recommended Posts

Bonjour à tous,

 

Je suis sur Presta 1.7.5.1 avec une toute nouvelle monture hébergé chez OVH en mutu.

Tout fonctionne relativement normalement mais je galère avec ce filtre à facettes...!

J'ai créé des articles avec déclinaisons, des couleurs, des poids etc.

Le filtre apparaît bien avec le nombre de résultats qu'il contient mais quand je fais une sélection de couleur ou de poids, il ne retourne aucun article...! c'est rageant! 

J'ai testé avec le thème d'origine et mon thème acheté : sans succès.

 

Merci pour vos conseils

filtre.JPG

Edited by nixax
résolu (see edit history)

Share this post


Link to post
Share on other sites

Bonjour, 

Merci pour la réponse, j'ai effectivement bien réindexé les produits et les attributs. C'est très frustrant...

 

Une autre piste?

Share this post


Link to post
Share on other sites

En fait, je réalise que le filtre ne fonctionne pas avec les attributs créés. Par contre il renvoie bien un résultat avec les filtres natifs...

 

Capturep.PNG

Share this post


Link to post
Share on other sites

Pour ceux qui tomberaient sur ce post pour un problème similaire, voici la solution simple...

 

Pour que les produits soient filtrés par le module filtre à facettes avec les attributs, leur stock doit être supérieur à 0...

 

Et voilà. 

Edited by nixax (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More