Jump to content
Sign in to follow this  
Tramber

1.4... Faut il vraiment tester...

Recommended Posts

Bonjour à tous,
après plusieurs années de pratique prestashop, pas mal de Mise à jour hasardeuses (voir foireuses), je me pose la question de la MAJ.
Bon faut dire je suis pas un cador, mais heureusement j'ai fait suffisamment de conneries dans le passé qui m'ont permis d'apprendre.

Maintenant, je ne vois pour l'instant que des galères de MAJ pour la 1.4, hors le site que je gère en ce moment est en production, il y a des commandes tous les jours et j'hésite encore à me précipiter pour voir les nouvelles fonctionnalité de la 1.4.

Il y en a t-il pour lesquels la MAJ vers la 1.4 c'est bien passé ?

Je compte installer la 1.4 dans un autre dossier, pour installer petit à petit et améliorer mon thème, installer mes modules pour voir si tout fonctionne et basculer ensuite si tout va bien.
Ma question est-ce possible ou la BDD de la 1.4 est tellement différente que je ne pourrait pas procéder comme ça ?

Merci d'avance,
Tramber.

Share this post


Link to post
Share on other sites

Tu n'as qu'a faire ta MAJ sur un serveur de dev (en local par exemple), et tu veras bien.

1. Sauvegarde ta BDD et les fichiers (www)
2. Installe un serveur Apache/MySQL (XAMPP, ou autre) sur ton PC en local
3. Restaure ton site
4. Fais la mise à jour vers la 1.4

Regarde à présent le comportement de ton site.
Le plus galère va être si tu as développé des modules fait maison, et que la structure des tables à changer....à voir.

Je compte migrer une 1.3.3, vers une 1.4 avec des modules persos.

Je te tiens au courant si ça t'intéresse, mais comme chaque site et "unique", vaut mieux faire le test de ton côté aussi.

Bye. ;)

Share this post


Link to post
Share on other sites

Bonjour,

upgrader les versions c'est suivre l'évolution du produit, donc oui, il faut le faire, mais il faut le faire calmement et intelligemment, et ... sans risque.

Constitues toi en local et en hébergé un environnement de test.

Fais ta migration locale, testes ton site, fais évoluer ton thème, etc... et quand tu as validé l'ensemble de tes fonctionnalités, met ta boutique 1.4 sur ton environnement de test hébergé et refais.

Ensuite migres tranquillement ton environnement de prod.

Si c'est fait avec méthode, il n'y a aucune raison que tu rencontres des soucis.

Share this post


Link to post
Share on other sites

Ok, merci des conseils;
J'avais pas pensé à tester en local (bien que ça ne réagisse pas toujours pareil).

Au niveau des modules, rien de bidouillé, c'est surtout certains affichages, et le thème que j'ai modifié à ma sauce.
Mais ce qui m'inquiète le plus c'est le temps que cela va me prendre, surtout si j'ai des galères...
Le site tourne avec quelques 1800 produits sans compter les déclinaisons...

Je passerai d'une 1.3.6.0 vers la 1.4.
Tiens moi au courant, pour savoir si tout ce passe bien !

Tramber.

Share this post


Link to post
Share on other sites

bonjour,

le problème des mises à jour avec presta, c'est que même si ça se passe bien, c'est souvent relatif et que même après des tests en local avant migration, on ne voit apparaitre des bugs qu'à l'utilisation car bugs très vicieux (expérience vécue deux fois), par exemple : pb de chiffres dans les factures, problème de mails, pb de paiements, erreurs sur les prix en front, boutons ou cases à cocher invisibles en BO etc...

Tout ça rend le processus de mise à jour très dur pour les nerfs, et c'est dur de ne pas être parano même quand la mise à jour s'est faite "correctement"

Perso je choisis maintenant toujours la solution radicale : installe fraiche de la version souhaitée et réadaptation du code...

Share this post


Link to post
Share on other sites

Bonjour,

Pour ma part, je teste sur un sous-domaine avec un dossier et une base de données séparée (chez ovh). Ca permet d'être réellement dans les mêmes conditions (pas toujours évident avec xamp et autres). J'ai constaté par exemple que les problèmes de lenteur que certains ont remonté sur la 1.4 ne m'affectaient pas vraiment.
Par contre, plusieurs modules tel que blockfading ne fonctionnent pas encore bien sur mon installation... Je vais y aller tranquillement donc, attendre peut-être une nouvelle version. Le bug tracker donne une idée des soucis qu'on peut rencontrer mais je crois que beaucoup viennent des modules tiers. Les nouveaux utilisateurs vont forcément démarrer en 1.4 et vont rapidement tester cette mouture dans tous les sens.

Bon courage!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More