Jump to content
cycy

redirection vers l'index.php lors de la connexion au backoffice help help help

Recommended Posts

Bonjour, j'ai un site qui est amené à disparaître par la suite mais dont le responsable marketing doit pouvoir apporter quelques modif (site vitrine). Il a été réalisé sous prestashop 1.6.1 (une m.... si je peux me permettre). Je tente d'accéder au backoffice, on arrive sur la page de login (là aucun problèmes) puis une fois mot de passe validé, on est directement redirigé vers la page d'accueil (index.php) j'aimerais pouvoir trouver une solution pour être redirigée vers le backoffice mais pour le moment je n'y arrive pas. Quelqu'un pour me conseiller ??? Merci à vous :)

 

Share this post


Link to post
Share on other sites

souvent un tout petit bug lié à un module tiers ou un problème de RIJNDAEL

as-tu tenté après login de réentrer l'url du BO (sans login.php, sans rien)

Share this post


Link to post
Share on other sites

oui j'ai testé, soit il me renvoie vers le index.php de mon site ou alors quand j'efface les cookies du navigateur, il me demande login mdp et puis après validation au lieu de me diriger vers le backoffice, je suis redirigée toujours vers ce fameux index.php. Cela pourrait il être lié à la version du php ?? Chez l'hébergeur chez qui je suis, le site tournait sous php 5.6 je suis passée en 7.0. ça pourrait venir de là ?? j'ai mis en mode debug mais aucune erreur, j'ai effacé le cache manuellement mais rien. J'ai essayé aussi en mettant ps_cookie  à 0 au lieu de 1 et ça ne change rien aussi.

Share this post


Link to post
Share on other sites

Je m'explique mieux : je tape l'adresse de mon site : https://monsite.fr/admin/

il me demande mot de passe et login que j'entre je valide et je suis renvoyée vers : https://monsite.fr/

ça ne sert à rien de mettre le /admin juste après vu que je suis revenue à la page initiale ...

J'ai testé en remettant en php 5.6, ça ne change rien ...

Share this post


Link to post
Share on other sites

J'ai deviné ton numéro de version... 1.6.1.legume.

Dommage pamplemouse fonctionne

Share this post


Link to post
Share on other sites

rien à deviner vu que la version de prestashop je l'avais indiqué. Quelqu'un aurait une idée ?? car ce n'est pas un pamplemousse qui va m'aider malheureusement !!

Share this post


Link to post
Share on other sites

ha ha ... il y a juste ... 23 versions 1.6.1 !!!

Share this post


Link to post
Share on other sites
Posted (edited)

ok bref si c'est pour vous moquer de moi je me passerai de votre humour !!! ça ne me fait pas marrer je perd mon temps à tenter de récupérer mon backoffice, pas à être moquée !! merci !!

prestashop 1.6.1.17  ...

Edited by cycy (see edit history)

Share this post


Link to post
Share on other sites

Ca ne sert à rien de t'offusquer !

Il te demande juste la version exacte de ton Ps, car des 1.6.1, il y en a eu une vingtaine: 1.6.1.1, 1.6.1.2, 1.6.1.3, ..., 1.6.1.11,..., 1.6.1.19,..., 1.6.1.23

Share this post


Link to post
Share on other sites

merci pour le message !! je demande juste si quelqu'un peut m'aider ou si je perd mon temps sur ce forum ???? Alors pilou ton commentaire ne m'est d'aucune utilité !!!!

Share this post


Link to post
Share on other sites

Bonjour,

Vous demandez de l'aide.

@doekia prends le temps d'intervenir, vous demande 2 choses :

  1. la version exacte de votre installation PrestaShop, car, comme il le précise, il en a eu 23 différentes sur la seule information que vous communiquez
  2. d'effectuer une action que vous refusez d'effectuer car vous dites que cela ne sert à rien.

Donc il est logique que la motivation de venir bénévolement vous assister dans la résolution de votre problème en prenne un coup.

Comment pourrions nous vous aider si vous refusez obstinément de répondre à 2 questions toutes simples ?

Share this post


Link to post
Share on other sites

bonjour, j'ai répondu aux solutions proposées, la version prestashop et la 1.6.1.17 et pour l'url de backoffice c'est testé aussi cependant je suis à chaque fois redirigée vers index.php. J'ai de l'humour mais pas quand on se moque, si vous lisez bien les com ne sont pas plaisants.

Je n'ai pas refusé vu que j'ai essayé, seulement arrivé un moment c'est énervant de tourner en rond.

 

Share this post


Link to post
Share on other sites
Il y a 21 heures, cycy a dit :

ça ne sert à rien de mettre le /admin juste après vu que je suis revenue à la page initiale ...

Pourtant, en lisant cette réponse vous ne semblez pas avoir essayé de remettre simplement l'url du backoffice.

Après vous pouvez aussi vider les cookies de votre navigateur.

Nous indiquer la version PHP utilisée.

Nous donner la configuration du cache serveur si vous en avez activé un tout en bas de la page Performances.

Votre soucis est complexe et sans accès à votre site il est très difficile de vous aiguiller.

Share this post


Link to post
Share on other sites

Donc 90% de chance que ton problème soit RIJNDAEL

Active le debug pour confirmer (config/defines.inc.php => _PS_MODE_DEV_ true)

Pour résoudre ajouter les 2 lignes fournies par ce générateur

https://shop.devcustom.net/gen.php

Share this post


Link to post
Share on other sites

Bonjour doekia, je suis en mode debug déjà, 'PS_MOD_DEV' activé mais je n'ai pas de message d'erreur, je vais ajouter les deux lignes pour voir, merci beaucoup pour les solutions proposées. j'ai donc changé les deux lignes du site avec celles là mais je suis toujours redirigée vers la homepage :( .

Je vais me pencher sur ce problème éventuel de clé. pour le php, sur le serveur de notre hébergeur, j'ai trois solutions, j'ai testé avec le 5.6 (php initial) et le 7.0 mais pas de différence hélàs. Quand je teste, je vide manuellement le cache et je vide les cookies du navigateur également.

Share this post


Link to post
Share on other sites

j'ai même tenté de mettre en mode profiling mais rien n'y fait je n'arrive pas à voir où ça coince

 

Share this post


Link to post
Share on other sites

_PS_MODE_DEV_ hein ... pas PS_MOD_DEV

PHP5.6 ça marche toujours

Le cache n'est pas utilisé par le BO

 

Après il ne reste plus qu'a venir voir sous le capot

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More