Jump to content
BVince

DEVFOREVER - Menu MegaDrown Evolution

Recommended Posts

Bonjour à tous,

Je viens d'installer la version 1.4 de Prestashop et je voudrais largement féliciter les développeurs ayant participés à la sortie de cette nouvelle version. Comme vous le savez sûrement tous, DevForEver essaie au maximum de vous faire profiter de modules performants, de répondre à vos questions et aussi de vous aider dans la mise en place de certaines fonctionnalités en réalisant parfois même des modifications totalement gratuites. Pour toujours permettre à la communauté de vivre ainsi, nous avons décidé de rendre le menu MegaDrown Evolution gratuit, la version fournie dans ce post est destinée à Prestashop 1.4, je vous joints également la documentation du module afin de vous aider au paramétrage.

@ bientôt à tous et encore merci aux développeurs pour l'avancée de ce CMS e-commerce...

MegaDrown Evolution.pdf

navmegadrownevo [Prestashop 1.4].zip

Share this post


Link to post
Share on other sites

Merci beaucoup Bvince
si je ne me trompe pas c'est bien un module qui etait a 39euro
ayant acheter ce module et actuellement sur mon site ,je le conseille vivement
un magnifique module!
merci encore Bvince.

Share this post


Link to post
Share on other sites

Bonjour BVince, joli don !
Je pousse un peu votre générosité: autorisez-vous l'utilisation de votre module dans des templates destinés à la revente ?
Si votre réponse est OUI cela ravira beaucoup d'agences !
Si vous réponse est NON de toute façon elles l'utiliseront quand même...
Merci,
Fél.

Share this post


Link to post
Share on other sites
Bonjour BVince, joli don !
Je pousse un peu votre générosité: autorisez-vous l'utilisation de votre module dans des templates destinés à la revente ?
Si votre réponse est OUI cela ravira beaucoup d'agences !
Si vous réponse est NON de toute façon elles l'utiliseront quand même...
Merci,
Fél.


Et oui, comme tu dis si je dis NON il sera quand même utilisé alors pourquoi refuser ?
Le module a été offert pour la communauté, alors n'hésitez pas à l'utiliser, je ne demanderais qu'une chose : essayez de faire en sorte que vos clients sachent d'où vient ce module ;-) .....

Share this post


Link to post
Share on other sites
Si votre réponse est OUI cela ravira beaucoup d’agences !
Si vous réponse est NON de toute façon elles l’utiliseront quand même…


Effectivement vous poussez un peu.... :gulp:

Share this post


Link to post
Share on other sites

Je viens de migrer en 1.4.
Avant j'étais en 1.2 et j'utilisais la version antérieure du module (c'est à moi que vous venez de répondre par mail ;o)

Share this post


Link to post
Share on other sites

D'accord, je viens de m'apercevoir que j'avais laissé du code de dubugage utilisant une classe que j'ai créé, je viens de remettre le module à jour...
Download it
Install it
Enjoy....

Share this post


Link to post
Share on other sites

Voila, l'install est refait, ça fonctionne maintenant.
A part 2 petits soucis :

1) Je pense qu'on a perdu en route les icones de mise en page (éditeur de texte) pour la config des textes de colonnes et ligne haut.
2) chez moi, seul le menu de la première catégorie se déroule lors du survol, les autres catégories sont inaccessibles...

voili voilou

Share this post


Link to post
Share on other sites

Je viens d'installer la 1.4.0.17 (en local sous Xampp), j'ai installé le module MegaDrown Evolution, j'ai fait quelques modifications pour le rendre compatible puis j'ai fait un ZIP pour le fournir sur le Forum... Je ne vois pas de dis-fonctionnement particulier du module...

Share this post


Link to post
Share on other sites

J'avais pas vu mais il y a une version plus récente de Jquery dans la 1.4 de Prestashop, je viens donc de remettre en ligne une version modifiée du module MegaDrown Evolution...

Share this post


Link to post
Share on other sites

Ca va mieux !
Avec cette version, on a bien retrouvé l'éditeur de text ainsi que la possibilité de glisser / déplacer les catégories.

Par contre pour le moment, j'ai toujours en front office uniquement la première catégorie qui se déroule. Les autre non...

Share this post


Link to post
Share on other sites

Petite précision, ça n'est pas lié à la catégorie elle même mais bien à sa position.
Si j'inverse la position de 2 catégories, c'est toujours bien la première qui se déroule et pas les suivantes...
Je ne sais pas si ça peut aider...

Share this post


Link to post
Share on other sites

Mais comme vous travaillez en local, je ne peux pas faire grand chose, je viens de tester en désinstallant le module (aussi en local), en supprimant les tables (en local), puis en réinstallant le module et tout fonctionne, 3 boutons avec 3 sous-menus....

Share this post


Link to post
Share on other sites

Bonjour, je viens de migrer sous 1.4 et j'ai exactement le même problème.

Je peux laisser l'url ici : http://prestashop.adiserve.fr

Je laisse la boutique ouverte pour l'après midi pour les personnes qui souhaitent débug, enfin surtout pour BVince pour qu'il puisse voir d'ou vient le problème.

Vous verrez que le menu se décale sur la gauche sur les trois premières cases, et puis plus rien..

Pour info, j'ai désactivé le module, j'ai supprimé tous les dossiers et fichiers sauf les dossiers images, j'ai pris l'archive sur l'accueil de ce pot et ai envoyé les nouveaux fichiers sur le serveur, puis j'ai réactivé le module.

Auris-je dû procéder autrement ?

Share this post


Link to post
Share on other sites

Je pense également à un soucis de fonctionnement en local, car j'ai testé sous IE7, IE8, FireFox et maintenant Safari et je ne rencontre aucun problème, la combinaison MAMP, Mac et FireFox le tout en local semble poser problème...

Share this post


Link to post
Share on other sites
Bonjour, je viens de migrer sous 1.4 et j'ai exactement le même problème.

Je peux laisser l'url ici : http://prestashop.adiserve.fr

Je laisse la boutique ouverte pour l'après midi pour les personnes qui souhaitent débug, enfin surtout pour BVince pour qu'il puisse voir d'ou vient le problème.

Vous verrez que le menu se décale sur la gauche sur les trois premières cases, et puis plus rien..

Pour info, j'ai désactivé le module, j'ai supprimé tous les dossiers et fichiers sauf les dossiers images, j'ai pris l'archive sur l'accueil de ce pot et ai envoyé les nouveaux fichiers sur le serveur, puis j'ai réactivé le module.

Auris-je dû procéder autrement ?


Bonjour,

Je viens d'aller sur votre site, pour moi tout fonctionne, mais je vois une erreur javascript concernant le EASING, cette erreur vient d'un autre module qui empêche le fonctionnement du menu...

Cette ligne :
jQuery.easing['jswing'] = jQuery.easing['swing']; 



a-t-elle réellement intérêt dans votre fichier js/jquery/jquery.easing.1.3.js ?

car l'erreur détectée par le navigateur vient de là.

Share this post


Link to post
Share on other sites

Merci pour cette info.

Je vais regarder quel module utilise cette version de Jquery. Je pense qu'il s'agit du bandeau animé de page d'accueil. Cette nouvelle migration ne se passe pas sans douleur, certaines pages sont blanches, mes catégories ni mes produits ou cms ne se voient...

Il y a de nouveaux appels à des feuilles css qui n'existaient pas dans ma version 1.3.6 :(

Share this post


Link to post
Share on other sites
bon, j'ai retiré le easing, mais sur mes autres pages, le menu ne fonctionne plus.


Quelles autres pages, tu as des exemples ?
Je viens de jeter un œil et plusieurs pages contiennent des erreur JS, donc le menu ne peut plus fonctionner...

Share this post


Link to post
Share on other sites

ben, il suffit de cliquer sur l'un des liens de la page d'accueil, une catégorie, un produit, pour voir que ma page est déstructurée et que le menu ne réagit plus...

Share this post


Link to post
Share on other sites

oui, firefox me donne une erreur avec le fichier Jquery-1.4.4.min.js. Vu que je ne l'appel pas sur mon header, comment faire pour savoir quel module appel ce script?

Share this post


Link to post
Share on other sites

De base, c'est prestashop qui utilise le 1.4 de jquery, il va falloir chercher ailleurs, le mieux est de désactiver tous les modules 1 par 1 pour voir si le problème persiste....

Share this post


Link to post
Share on other sites

Dommage j'ai acheté le module il y a peu... :cheese:

Pour la version 1.4: le module est prévu de s'installer dans la catégorie "Blocks" ($this->tab = 'Blocks';) hors cette catégorie n'existe plus avec PS1.4 et il se retrouve donc par défaut dans "Autres modules".

Autre petit bug que j'ai noté en utilisant la version pour 1.3 et que je retrouve en 1.4:
Le bouton "enregistrer" du menu "general" ne fonctionne pas avec le navigateur Chrome.

Share this post


Link to post
Share on other sites

How would I go about implementing a transparent background for the 'General Colour' and 'Button Color & background sub-menu' as I am looking to use images with corner radius!

Regards,

Rob

Share this post


Link to post
Share on other sites
Dommage j'ai acheté le module il y a peu... :cheese:

Pour la version 1.4: le module est prévu de s'installer dans la catégorie "Blocks" ($this->tab = 'Blocks';) hors cette catégorie n'existe plus avec PS1.4 et il se retrouve donc par défaut dans "Autres modules".

Autre petit bug que j'ai noté en utilisant la version pour 1.3 et que je retrouve en 1.4:
Le bouton "enregistrer" du menu "general" ne fonctionne pas avec le navigateur Chrome.


Bonjour,

J'ai corrigé la position du module dans la bonne catégorie mais pour le bug sous chrome, je sèche pour le moment...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×