Jump to content
Sign in to follow this  
maher

passage vers prestashop 1.4 mais le site est tres tres lents

Recommended Posts

bonjour

je viens de passer en prestashop 1.4 , et le site est lent , de quoi ca peut venir a votre avis svp ???

merci de votre aide

Share this post


Link to post
Share on other sites

Bonjour,

avez vous refait votre htaccess ?

avez vous activé les optimisations ?
avez vous configuré le cache et les optimisation de contenu ?

Share this post


Link to post
Share on other sites
Bonjour,

avez vous refait votre htaccess ?

avez vous activé les optimisations ?
avez vous configuré le cache et les optimisation de contenu ?


bonsoir
merci de m avoir repondu
je suis tres neuviste , peux tu me dire comme réaliser ces manipulations ?.

Share this post


Link to post
Share on other sites

Vérifier qu'il en manque pas de fichier, depuis la 1.4 la gestion de page css à changé ! donc vous avez surement des appels à plein de fichier css qui n'existe pas après votre migration et donc peuvent provoquer des lenteurs.

Cdt

Share this post


Link to post
Share on other sites

Bonjour,
alors si on parle bien de la même chose, la lenteur du front office.
Il faut aller dans le back office, préférences, performance, et cocher non sur forcer la compilation.
Par contre si vous modifier des .tpl de votre thème n'oublier pas de le réactiver sous peine de ne pas voir vos modifications
Cdlt

Share this post


Link to post
Share on other sites
Bonjour,

avez vous refait votre htaccess ?

avez vous activé les optimisations ?
avez vous configuré le cache et les optimisation de contenu ?


bonsoir
merci de m avoir repondu
je suis tres neuviste , peux tu me dire comme réaliser ces manipulations ?.



bonjour,

je rencontre le même problème sur mon site je le trouve très lent depuis la mise à jour

Avez-vous trouver une solution

merci d'avance

Cordialement

brian
http://www.soniya.fr

Share this post


Link to post
Share on other sites

même problème en ayant fait toutes les optimisations dans le back-office sauf memcahe

Share this post


Link to post
Share on other sites

même problème en ayant fait toutes les optimisations dans le back-office et changer les droit 777 sur compil . + de 20 secondes pour le sitmap ! LA kaka

Share this post


Link to post
Share on other sites

salut
j'avais le même problème
j'ai fait ceci et cà va mieux
Dans votre FTP
Dans config : le fichier smarty.config.inc.php

passer false à la place de true
$smarty->force_compile =false; // to pass "false" when put into production

voilà pour moi çà a fonctionné.
www.musclenaturel.com

Share this post


Link to post
Share on other sites

$smarty->force_compile = (bool)Configuration::get('PS_SMARTY_FORCE_COMPILE');

voici ma ligne qui est différante. Peux tu me dire se que je dois remplacer ?

Merci

Share this post


Link to post
Share on other sites

$smarty->force_compile = (bool)Configuration::get('PS_SMARTY_FORCE_COMPILE');
$smarty->compile_check = false;

voilà ce que j'ai

j'ai mal expliqué , c'est la ligne en dessous qu'il faut mettre false

a+

Share this post


Link to post
Share on other sites

Merci Musclenaturel . Mon code est deja comme ceci. : ( donc je suppose que c est fini pr moi :( )

global $smarty;
$smarty = new Smarty();
$smarty->template_dir = _PS_THEME_DIR_.'tpl';
$smarty->compile_dir = _PS_SMARTY_DIR_.'compile';
$smarty->cache_dir = _PS_SMARTY_DIR_.'cache';
$smarty->config_dir = _PS_SMARTY_DIR_.'configs';
$smarty->caching = false;
$smarty->force_compile = (bool)Configuration::get('PS_SMARTY_FORCE_COMPILE');
$smarty->compile_check = false;

if (Configuration::get('PS_FORCE_SMARTY_2'))

Share this post


Link to post
Share on other sites

Cela ne dépend pas de la connexion vu que c'est la page en elle-même qui est longue.

Je dirais que ça doit être une requête faite sur le MySQL qui doit être horrible. Je vous conseille déjà de désactiver tous les modules de stats, de voir déjà le résultat.

Sinon, ça doit être un module qui indexe les produits ou une option dans ce sens.

Share this post


Link to post
Share on other sites

Bjr vincent. J'ai désinstallé l'ensemble des modules Stats. Tj pas de changement. 15 000 familles et 200 articles. Je dois importer 50 000 articles ... je doute fort de presta ... J'ai fais le teste avec 1.3.7 mais il y a un nombre max de 3000 sous catégorie alors je cherche avec 1.4.1 qui fonctionne bien mais très très lentement.

Share this post


Link to post
Share on other sites
Merci Musclenaturel . Mon code est deja comme ceci. : ( donc je suppose que c est fini pr moi :( )

global $smarty;
$smarty = new Smarty();
$smarty->template_dir = _PS_THEME_DIR_.'tpl';
$smarty->compile_dir = _PS_SMARTY_DIR_.'compile';
$smarty->cache_dir = _PS_SMARTY_DIR_.'cache';
$smarty->config_dir = _PS_SMARTY_DIR_.'configs';
$smarty->caching = false;
$smarty->force_compile = (bool)Configuration::get('PS_SMARTY_FORCE_COMPILE');
$smarty->compile_check = false;

if (Configuration::get('PS_FORCE_SMARTY_2'))



bonjour,

Tu as pu trouver une solution à ton problème car je rencontre la même difficulté

merci de ta réponse

brian
http://www.soniya.fr

Share this post


Link to post
Share on other sites

Oui j'ai abandonné mes 30 000 familles et 50 000 articles.

J'ai réalisé 2 site internet pour couper la BDD. ( Presta est uen application lourd qui prend bcp de ressources et qui n'est pas faite pr ls gros sites. d'ailleurs j'ai demandé à Prestashop (charmantes jeunes femmes au téléphone tj souriante) un exemple de site avec + de 25 000 articles ... jamais reçu !

(test effectué avec un core2Duo puissant, 4Ggiga de mémoire et un ssd , Tout fonctionne avec 30 000 famille et 200 articles mais cela consomme + de 70% de ma machine en ressource cpu en local). Je pense que le problème vient du nombre de famille mais pas des articles.


J’en ai gardées 6000 et 20 000 articles et ca fonctionne +- vite.

Share this post


Link to post
Share on other sites

salut

oui j'ai ceci ( j'ai mis false )
$smarty->caching = false;
$smarty->force_compile = (bool)Configuration::get(‘PS_SMARTY_FORCE_COMPILE’);
$smarty->compile_check = false;

ensuite dans le back office , préférences, performances , smarty : et cocher non à " forcer la compilation " et non à "cache "
et tout en bas utiliser le cache j'ai cocher non.
voilà pour moi cela a fonctionner
a+

Share this post


Link to post
Share on other sites

Tu as + de 20 000 articles ? car moi sans rien changer ( tout par default) c'est vraiment rapide avec 5000 articles. ovh pro mutualisé.

Share this post


Link to post
Share on other sites

Bonjour,

Nous avons effectivement des boutiques qui aujourd'hui tournent avec + de 25 000 références. L'une d'entre elle est : http://www.home-boulevard.com/. Ces boutiques sont en effet souvent sujet à des optimisations assez légères mais qu'il faut connaitre. Il n'y a normalement pas de problème pour ces volumes.
Nous avons nous même une boutique de 1 millions de produits et plus de 1 000 catégories de produits. Nous avons il est vrai une machine en conséquence.( :), un peu plus grosse qu'un core 2 duo)

Nous pouvons auditer vos sitse. Ce processus est payant mais si tu me donnes leurs adresses, je peux déjà regarder ce qui peut éventuellement contribuer à les ralentir.

Fabien

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More