Jump to content
lolyspoon

1.4 client arrive sur page blanche quand il veut faire mise a jour adresse

Recommended Posts

bonjour,
je viens de passer en 1.4 a l'instant, le hic plein de bugs de partout, le premier les clientes ne peuvent pas modifier leur adresse!!!
on arrive sur une page blanche!
Quelqu'un a rencontrer ce soucis? pouvez vous me donner un coup de main?
merci davance

40534_uWKIo3qV1FzSuO0RuwO6_t

Share this post


Link to post
Share on other sites

Idem.

Je pense que globalement il faut retravailler le HTACCESS et les adresses quand le url rewritting est activé.

Share this post


Link to post
Share on other sites

perso moi j'ai abandonner jsuis revenue en 1.3.7, cest dingue on est plein a avoir se soucis et personne de presta ne viens nous eclairer :(

Share this post


Link to post
Share on other sites

Je viens de creer un utilisateur sur la 1.4 en local, et quand je clique sur "mettre à jours" ça ouvre bien le formulaire. La validation ce fait sans problème. Url rewrite activée ou non.

Version : PrestaShop™ 1.4.0.17

Share this post


Link to post
Share on other sites

Bonjour
De mon côté, en 1.4.0.17 également. Que ce soit en local ou sur le serveur en prod, sur un client existant ou sur un nouveau, j'ai moi aussi cette page blanche....

J'ai essayé de supprimer l'url rewrite (suppression de la ligne address.php dans le BO / Préférences / SEO) mais ça n'a rien donné. C'est l'attaque de address.php qui pose problème, donc un pb de PHP, car l'url boutique/address.php?id_address=XXX devrait fonctionner...

J'ai posté un bug report : http://www.prestashop.com/bug_tracker/view/8629/

Share this post


Link to post
Share on other sites

bonjour

Hier j'ai eu le meme probleme que vous tous.

J'ai fais un essais en mettant smarty 3 et là miracle cela fonctionne.

j'attire l'attention que certain ancien module qui fonctionnaient en 1.3 bloque la 1.4 (non compatible).

Et je n'arrive pas non plus a faire apparaitre le bloc mon compte en permanence comme dans la version 1.3

par contre de mon coté j'ai un pb sur les factures, le détail tva en bas de facture affiche uniquement la détail produit mais pas la TVA transport alors que mes transporteur sont en TVA.

EDIT pour ajout:

Je viens de charger la SVN 1.4 je suis stupéfaits du nombre de correction (+ de 100 correction) pour bug depuis la sortie de la version 1.4 le 16 Mars
Encore une version pleine de bug apparemment cela ne fera jamais que 2 fois avec les problèmes de la 1.3 et les arrondies de factures de la 1.3.
Je ne comprends plus la démarche de presta a sortir des versions avec bugs en pagaille.

a bientot a tous

Share this post


Link to post
Share on other sites

@ Jp77 : salut merci pour ces précisions. Tout le monde a l'air de se "plaindre" de SMARTY. Peux tu nous en dire plus sur ?

Share this post


Link to post
Share on other sites

bonjour petitbiston

Non pas vraiment plus pour le moment.
Par contre ras le bol, cela fait 2 jours que je bosse a remttre mon theme en page avec les couleurs etc.. et quand je vois que deja + de 100 correction depuis la sortie de la 1.4.0.17 cela ne me dis rien qui aille !
A quand la version 1.4.0.18 ? et la 19 et les suivantes ?
cela vas encore faire comme la 1.3 des corrections a n'en plus finir.

Ce que je ne comprends plus, c'est que l'on nous annonce une version stable alors qu'en réalité elle n'y est pas, puisque des corrections continue.

Je ne comprends plus rien a cette course contre la montre du Team de prestashop, et encore moins l'interet.

De plus au Barcamp il parle de la 1.5 !!!!!!!!!

cela deveint tres tres dur a suivre
A bientot

Share this post


Link to post
Share on other sites
couleurs etc.. et quand je vois que deja + de 100 correction depuis la sortie de la 1.4.0.17 cela ne me dis rien qui aille !


C'est plutôt logique... Un logiciel open source et gratuit avec une grosse équipe derrière ne cesse d'évoluer.

A quand la version 1.4.0.18 ? et la 19 et les suivantes ?


Bientot

cela vas encore faire comme la 1.3 des corrections a n'en plus finir.


C'est logique.

Ce que je ne comprends plus, c'est que l'on nous annonce une version stable alors qu'en réalité elle n'y est pas, puisque des corrections continue.


Stable n'est qu'un mot... Ca veut dire " vous pouvez l'utilisez, mais faut quand même tester avant, et il y a des bug. Si il y avait pas de bugg, on en serait encore à la 1.0.

Je ne comprends plus rien a cette course contre la montre du Team de prestashop, et encore moins l'interet.


L'évolution !

De plus au Barcamp il parle de la 1.5 !!!!!!!!!


C'est normal

cela deveint tres tres dur a suivre


Qui à dit que le web était "simple" ?

Share this post


Link to post
Share on other sites

bonjour

Que cela soit des fichiers SVN ou pas cela ne changeras rien si il y a des erreurs elles seront aussi dans les SVN.

cordialement

Share this post


Link to post
Share on other sites
Hier j’ai eu le meme probleme que vous tous.

J’ai fais un essais en mettant smarty 3 et là miracle cela fonctionne.


Bonjour,

Même souci pour moi : les anciens clients ne peuvent plus commander, je dois effacer et recréer leur compte manuellement !

Que veux dire "mettre Smarty 3" et est ce que cela marche pour tous ?

Merci,

Eric

Share this post


Link to post
Share on other sites

je viens d'avoir le même souci avec un nouveau client cette fois ci, il ne peut pas modifier son adresse...
C'est de pire en pire,

Eric

Share this post


Link to post
Share on other sites

Le problème touche aussi les nouveaux clients uniquement si l'adresse de livraison est différente de l'adresse de facturation. Pour Smarty c'est dans preference > Performance > Smarty si quelqu'un résout le problème avec ça je veux bien savoir ce qui est choisi exactement.

Share this post


Link to post
Share on other sites

bonjour passicol

dans l'option :
Utiliser Smarty 2 au lieu de Smarty 3 Oui Non
A activer si votre thème n'est pas compatible avec Smarty 3 (pensez à le mettre à jour, Smarty 2 sera supprimé en version 1.5 de Prestashop)

mettre non et cela fonctionne.
Par contre en smarty 3 certains modules externe ne fonctionne plus.

A+

Share this post


Link to post
Share on other sites

En effet dans "preference" tout en bas (dernier paramètre), il y a utilisé Smarty 2 au lieu de 3 cocher non et les adresses sont modifiables. Chez moi ça marche aussi.

Share this post


Link to post
Share on other sites

moi ça ne fonctionne pas en utilisant smarty 3, je suis obligé de passer par le 2 pour afficher le formulaire des adresses

Share this post


Link to post
Share on other sites

Bonjour, j'ai un souci impossible de mettre à,jour une adresse ni d'en rajouté une même en admin j'obtient error fatal que faire j'ai déjà tester tout se qui a été dit en forum

Share this post


Link to post
Share on other sites

Bonjour,

 

Ce bug a l'air de revenir avec la version 1.4.9

Un fatal error arrive lorsqu'un client veut modifier son adresse?

Et là le smarty 2 ou 3 ne marche plus?

 

Que faire?

 

Merci de votre aide

Share this post


Link to post
Share on other sites

M

Bonjour,

 

Ce bug a l'air de revenir avec la version 1.4.9

Un fatal error arrive lorsqu'un client veut modifier son adresse?

Et là le smarty 2 ou 3 ne marche plus?

 

Que faire?

 

Merci de votre aide

 

 

Même problème que j'ai partiellement résolu, car maintenant le changement d'adresse ne propose qu'un seul pays comme choix (l'italie)

 

Dans mon theme sur la 1.4.9

Fichier addresses.tpl

J'ai modifié ses deux lignes de mon thème en les remplaçants par celle du theme de base de prestashop

<li class="address_update"><a href="{$link->getPageLink('address', true, NULL, "id_address={$address.object.id|intval}")}" title="{l s='Update'}">{l s='Update'}</a></li>  <li class="address_delete"><a href="{$link->getPageLink('address', true, NULL, "id_address={$address.object.id|intval}&delete")}" onclick="return confirm('{l s='Are you sure?'}');" title="{l s='Delete'}">{l s='Delete'}</a></li>

 

 

par

 

 

<li class="address_update"><a href="{$link->getPageLink('address.php', true)}?id_address={$address.object.id|intval}" title="{l s='Update'}">{l s='Update'}</a></li>		<li class="address_delete"><a href="{$link->getPageLink('address.php', true)}?id_address={$address.object.id|intval}&delete" onclick="return confirm('{l s='Are you sure?'}');" title="{l s='Delete'}">{l s='Delete'}</a></li>

 

 

Edit :

Problème résolu de mon côté avec la démarche ci dessus.

Ensuite pour résoudre le problème de choix de pays bloqué sur l'italie, j'ai remplacé le fichier AddressController.php de la 1.4.9 dans le dossier controllers par celui de la 1.4.8.2 et tout est rentré dans l'ordre.

Edited by Nérim (see edit history)

Share this post


Link to post
Share on other sites

Je sais pas si c'est toujours d'actualité tout ça mais j'ai le même problème pour modifier l'adresse d'un client.

Seulement quand dons Préférences j'essaie de coacher Utiliser Smarty 2 au lieu de Smarty 3, là carrément j'ai plus rien qui s'affiche sur ma boutique, page blanche partout........

Une idée ? Merci.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More