Jump to content
djmasterv

PHP PER PS 17 QUALE VERSIONE UTILIZZARE

Recommended Posts

Salve a tutti,

sto provando a migrare il mio e-commerce su PS17 e quindi mi chiedevo quale fosse la configurazione più performate per la versione PS 1.7.5.1. a partire dalla versione del PHP a tutto quello che concerne il DB.

Attendo suggerimenti.

 

Ciao

Share this post


Link to post
Share on other sites
On 14/1/2019 at 5:59 PM, WASATO dice:

Hi

There was no link or image, if you are using the latest PS version, you need as well to update the module to the latest version. Only the default template structure of the Template is supported to display the extra icecat data, if you are using a third-party template, you can only use the default data that is displayed by PS, in that case you have to disable to render the extra data from the module.

 

 

it is the latest version of the Icecat module that creates the problem of displaying the technical data sheet twice

Share this post


Link to post
Share on other sites

only the minimum required configuration is indicated in the documentation and not the optimal one

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/13/2019 at 10:08 AM, djmasterv said:

sto provando a migrare il mio e-commerce su PS17 e quindi mi chiedevo quale fosse la configurazione più performate per la versione PS 1.7.5.1. a partire dalla versione del PHP a tutto quello che concerne il DB.

Attendo suggerimenti.

Quello che trovi sul sito sono i requisiti minimi diciamo per farci un giro di prova.

Ma quando si tratta di fare sul serio questi sono requisiti, da sistemista, che consiglio dovresti avere:

per la versione 1.7.5.1:

1. PHP 7.1 consigliata 7.2

2. Componenti PHP Richiesti

CGI

PDO_Mysql

GD

XML

mbstring

zip

Intl 62.2 o superiore, ho riscontri molto positivi con la 63.1

3.My SQL 5.7

Configurazioni per il php.ini consigliate e testate:

repath_cache : 5M

max_input_vars: 2500

Memoria : 512 MB consiglio 1000MB dopo i 30.000 articoli o multishop

Consigliano l'utilizzao di apache come web server ma anche IIS funziona bene, quest'ultimo richiede molta esperienza in sistemi di questo tipo.

Funzione URL REWRITE abilitata.

Per usare sotto hosting prestashop fino ai 2.000 articoli, dopo i 2.000 Consiglio vivamente un VPS fino ai 40.000, 20+20 in multishop e un server dedicato dopo i 55.000

Ci sono anche altre operazioni e configurazioni per renderlo performante anche in presenza di tanti articoli, ma queste preferisco tenerle per me :)

Se vuoi una configurazione professionale senza pasticci contattami in privato.

 

 

Edited by hardware-store (see edit history)

Share this post


Link to post
Share on other sites

Grazie

2 ore fa, hardware-store dice:

Quello che trovi sul sito sono i requisiti minimi diciamo per farci un giro di prova.

Ma quando si tratta di fare sul serio questi sono requisiti, da sistemista, che consiglio dovresti avere:

per la versione 1.7.5.1:

1. PHP 7.1 consigliata 7.2

2. Componenti PHP Richiesti

CGI

PDO_Mysql

GD

XML

mbstring

zip

Intl 62.2 o superiore, ho riscontri molto positivi con la 63.1

3.My SQL 5.7

Configurazioni per il php.ini consigliate e testate:

repath_cache : 5M

max_input_vars: 2500

Memoria : 512 MB consiglio 1000MB dopo i 30.000 articoli o multishop

Consigliano l'utilizzao di apache come web server ma anche IIS funziona bene, quest'ultimo richiede molta esperienza in sistemi di questo tipo.

Funzione URL REWRITE abilitata.

Per usare sotto hosting prestashop fino ai 2.000 articoli, dopo i 2.000 Consiglio vivamente un VPS fino ai 40.000, 20+20 in multishop e un server dedicato dopo i 55.000

Ci sono anche altre operazioni e configurazioni per renderlo performante anche in presenza di tanti articoli, ma queste preferisco tenerle per me :)

Se vuoi una configurazione professionale senza pasticci contattami in privato.

 

 

a tuo avviso la ver. 17 di PS è matura per andare in produzione?

Grazie per le informazioni precedenti.

 

ciao

Share this post


Link to post
Share on other sites
Posted (edited)

la maturazione la lascio alla frutta.

la maggior parte dei problemi sono da  attribuire ad installazioni errate,con hosting scadenti.

Con la 1.7.5.1 fino adesso non ho avuto particolari problemi.

Bisogna rispettare anche le release dei temi.

Se lo sviluppatore del tema o del modulo ti dice che è compatibile con la 1.7.4 per esempio e sconsigliato aggiornare.

 symfony non tollera molto i maniaci degli aggiornamenti

Edited by hardware-store (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More