Jump to content
DARKF3D3

Avviso XX€ pagato al posto di XX€ su PS1.7.4.2

Recommended Posts

È da quando ho aggiornato da PS1.6 a PS1.7 che alcuni ordini vengono creati con importi sbagliati.

Ordini che  hanno raggiunto l'importo per la spedizione gratuita, mostrano invece i costi di spedizioni e ordini che non dovrebbero avere la spedizione gratuita vengono salvati con senza costi di spedizione.
La cosa strana è che il cliente al momento dell'ordine vede tutto correttamente e anche il pagamento viene fatto dell'importo corretto, però una volta salvato l'ordine si creano queste incongruenze.

- Non sembrerebbe relativo ad un metodo di pagamento in particolare, infatti questo problema è capitato sia con paypal, carta di credito che contrassegno;
- Nell'error log non trovo errori o avvisi nel'orario in cui viene inserito l'ordine problematico
- Sembra capitare a random solamente su alcuni ordini. A volte a distanza di una settimana, altre volte capita 2 volte nello stesso giorno.

La cosa ancora più strana è che andando a modificare l'ordine è praticamente impossibile impostare l'importo corretto, anzi, la situazione a volte peggiora.
Infatti se per esempio, su un ordine che avrebbe dovuto avere la spedizione gratuita vado ad aggiungere uno sconto pari al costo di spedizione, dopo averlo aggiunto viene, oltre ad aggiungere lo sconto viene anche tolta la spedizione, con il risultato che prima l'importo era più alto di quanto pagato e dopo più basso.
E più si va a cercare di "sistemare" i prezzi e più si sballano.

Spero che qualcuno possa aiutarmi a risolvere...

Share this post


Link to post
Share on other sites

Ciao DARKF3D3,

ho lo stesso tuo problema, puoi aiutarmi? hai risolto o capito da cosa dipende?

Ho prestashop 1.7.6.0, non ho paypal ma nexi come metodo di pagamento con carta, quindi deduco che non dipenda dal modulo del pagamento, visto che tu hai riscontrato l'errore con paypal!?

Nel mio caso sembra tutto corretto fino alla cassa, anzi al gateway di NEXI, articoli e spese di trasporto comprese nel totale ordine, ma alla conferma d'ordine via email e al B/O di prestashop, le spese di trasporto sono azzerate, ma l'importo pagato è corretto con l'avviso che l'importo è superiore all'ordine (mancano giusto le spese del corriere).

Se qualcuno ha riscontrato lo stesso errore e/o l'ha risolto ci informi grazie!

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More