Jump to content
stempelgarten

Bundesland auswählen

Recommended Posts

Wenn sich ein Kunde mit einer Adresse in Deutschland registriert, verlangt der Shop die Auswahl des "Bundeslandes". Doch diese Auswahl wird gar nicht angezeigt. Je nach Browser (Firwfox) wird sie wohl dennoch ganz kurz angezeigt.

Kann ich das beheben? Oder kann ich die Pflicht zur Auswahl des Bundeslandes aufheben?

 

Share this post


Link to post
Share on other sites

Also jetzt habe ich in den Ländern einfach bei Deutschland "Bundesländer" auf "nein" gestellt. Klar, jetzt klappt es. Aber das soll nicht die Lösung sein, dass ich bei allen verfügbaren Ländern mit Bundesländern die Option auf "nein" stelle.

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb stempelgarten:

Aber das soll nicht die Lösung sein, dass ich bei allen verfügbaren Ländern mit Bundesländern die Option auf "nein" stelle.

Und warum nicht? Es gibt Länder da sind die "Bundesländer" notwendig, bei anderen nicht zwingend aber vereinfachend.
Wenn du in andere Länder lieferst musst du halt schauen ob du die brauchst oder nicht, PrestaShop kann das ja nicht wissen.

Share this post


Link to post
Share on other sites

In Europa wüßte ich kein Land, wo dies steuerlich relevant wäre, und bei den Versandunternehmen auch nicht. Ind wenn man z.B. Italien nimmt mit allen seinen Provinzen, dann wird jemand aus der Provinz Triest ziemlich weit runterscrollen müssen (beim Handy dann lästig)....

Share this post


Link to post
Share on other sites

Da die Welt aber nicht nur aus Europa besteht gibt es halt die "Bundesländer" Auswahl und genauso die Möglichkeit diese zu deaktivieren wenn man es nicht braucht.
Wobei mir da gerade einfällt dass wenn ich mich recht erinnere, bei mir nach der Installation die "Bundesländer" nicht aktiviert waren. Ich habe nur dort wo es für den Versand erforderlich, bzw. hilfreich ist diese aktiviert. Also genau andersrum als bei "stempelgarten"

Share this post


Link to post
Share on other sites

Bei mir funktioniert dieses Feature aber nicht. Erstelle ich als Admin eine Adresse mit Bundesland, habe ich diese Auswahl nicht. Wenn ich als Admin den Warenkorb fülle und dazu die Adresse für den Kunden neu erfassen will, wird die Auswahl der Bundesländer zuerst auch nicht angezeigt. Dann kommt ebenfalls die Meldung, ich soll doch bitte das Bundesland auswählen. Klicke ich die Meldung weg, erscheint das Auswahlfeld. Doch auswählen kann ich dort nichts, weil es selber wieder verschwindet.

 

 

Share this post


Link to post
Share on other sites

Ich kann dir grad nicht ganz folgen. Hast du bei den Ländereinstellungen für das Land die "Bundesländer" deaktiviert? Dann sollte ja die Auswahl gar nicht mehr kommen.

Share this post


Link to post
Share on other sites

Habe es deaktiviert. Wobei es doch ok wäre, wenn es aktiviert funktionieren würde. Standardmässig war es aktiviert.

Share this post


Link to post
Share on other sites

Wenn ich dich jetzt richtig verstehe, du hast es deaktiviert und keine Probleme, aber wenn du es aktivierst dann funktioniert es nicht?

Share this post


Link to post
Share on other sites

Wenn ich es aktiviere, wie es standarmässig war, funktioniert es nicht. Genau.

Es ist auch egal in welchem Browser ich es probiere.

Share this post


Link to post
Share on other sites

Ich blicke jetzt gar nicht mehr durch, geht es um die Erstellung der Adresse durch den Kunden (im Shop) oder durch den Shopbetreiber (normalerweise im BackOffice)?

Man kann auch in den Ländereinstellungen konfigurieren, aus welchen Feldern die Adresse bestehen soll und teilweise auch, welche Felder Pflichtfelder sein sollen.

Generell würde ich davon ausgehen, daß Prestashop weiß, welches Land Bundesländer benötigt und die Voreinstellungen entsprechend gesetzt sind.

Share this post


Link to post
Share on other sites

Eben. Prestashop weiss, Deutschland hat Bundesländer. Und bei der Erfassung kann ich Strasse, Ort, Land etc. eingeben. Dann kommt die Fehlermeldung dass man das Bundesland auswählen müsse. Doch diese Auswahl ist ja nicht vorhanden. Oder je nachdem vorhanden und verschwindet nach Anklicken wieder, wie in Beitrag 7 geschrieben.

 

Share this post


Link to post
Share on other sites

Ihr redet hier sowas von aneinander vorbei 😄 Am besten noch mal alles auf Rest und den ersten Beitrag genau durchlesen...

Evtl. ist eine Erlärung dieses Problems aber auch ganz einfach folgende: Es gibt keine Bundesländer 😉

KLicke ich im BO (1.7er Shop) auf "International -> Länder & Gebiete -> Bundesländer", dann sehe ich hier in all meinen angelegten 1.7er Shop nur Bundesländer der Länder "Argentinien, Australien, Indonesien, Italien, Japan, Kanada, Mexico und Vereinigte Staaten". NICHTS aus Deutschland!

Diese müssten dann im Bedarfsfall erst mal angelegt werden. Und dann werden Sie auch vorne angezeigt bei aktivierten Bundesländern.

Share this post


Link to post
Share on other sites

Das sollte man so nicht verallgemeinern. Für den Einen sind sie wichtig für den Anderen halt nicht. Kommt ja u.U. auch auf das Produktportfolio an.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More