Jump to content
Sign in to follow this  
Glimpy

Payson returnerar inte till rätt URL.

Recommended Posts

Tjabba!
Har fått problem med Payson som efter godkänt köp inte returnerar kunder till rätt sida.

Efter att köp är slutfört hos Payson och kunden ska bli vidareskickad tillbaka till webshoppen så hamnar dom
på: https://www.payson.se/History/Receipt/QuickAgent/?PurchaseId=4554xxx

Ordern skapas som den ska och "Betalning godkänd", både jag och kund får kvitto på godkänt köp.

Gissar på att nån "callback" url.. eller "OkURL" inte fungerar som den ska och skickas med till Paysons API.

EDIT: Har kollat att informationen skickas till rätt adress (paysons merchant/default.aspx) samt att OkURL är rätt (det gömda fältet i formen, rätt URL till shoppen är det också) men likt förbenat så fastnar den på Paysons sista sida innan returen och riktar sig till URLen i början av tråden.

Nån som vet vart jag ska börja leta? Eller ligger felet hos Payson?

Detta uppkom efter lite theme uppdateringar.

Mvh

Share this post


Link to post
Share on other sites

Hej,

Standard är att kunden kommer till vår kvittosido efter en genomförd betalning. På denna sida finns det en knapp som heter tillbaka till butik. Om kunden trycker på denna knapp så skickas de via browsern till OkURL.

Om du vill att kunden ska skickas tillbaka till OkURL direkt så ska du sätta parametern CustomReceipt till true i anropet till oss. Då skickar vi kunden till dig direkt efter genomförd betalning.

Hoppas detta hjälper dig.

Trevlig helg,
Pouria

Share this post


Link to post
Share on other sites

Har ett litet problem med Payson modulen på 1.4.0.17
den skickar inte tillbaka att betalningen har blivit godkänd jag får kvitto på att en betalning har genomförts
pengarna syns på Payson kontot men i prestashop står det att ingen betalning mottagits
samt att statusen står som payment error.

några ideer?

Share this post


Link to post
Share on other sites
Har ett litet problem med Payson modulen på 1.4.0.17
den skickar inte tillbaka att betalningen har blivit godkänd jag får kvitto på att en betalning har genomförts
pengarna syns på Payson kontot men i prestashop står det att ingen betalning mottagits
samt att statusen står som payment error.

några ideer?


Tyvärr ingen aning om vad som kan vara fel. Har du varit i kontakt med de som gjort modulen? För vår modul stödjer ju inte 1.4 ännu.

Share this post


Link to post
Share on other sites
Har ett litet problem med Payson modulen på 1.4.0.17
den skickar inte tillbaka att betalningen har blivit godkänd jag får kvitto på att en betalning har genomförts
pengarna syns på Payson kontot men i prestashop står det att ingen betalning mottagits
samt att statusen står som payment error.

några ideer?


Tyvärr ingen aning om vad som kan vara fel. Har du varit i kontakt med de som gjort modulen? För vår modul stödjer ju inte 1.4 ännu.


Vi har exakt samma problem, och vår webshop är Prestashop 1.3.2

Vi får betalningen till Payson men i Prestashop står det att ingen betalningen är mottagen, detta är inte så bra då kunden får ett mail där det står "Payment error" och vi måste gå in manuellt och ändra till Payment accepted. Är det någon som har en fix på detta?

Tack för att ni finns.

/TKTK

Share this post


Link to post
Share on other sites

Jag får felmeddelandet Fatal error (Order -> conversion_rate is empty) när jag försöker genomföra en payson beställning. Själva beställningen går igenom men får detta felmeddelandet.

Nån som har en aning om vad det kan bero på?

Tack för svar!

Share this post


Link to post
Share on other sites
Jag får felmeddelandet Fatal error (Order -> conversion_rate is empty) när jag försöker genomföra en payson beställning. Själva beställningen går igenom men får detta felmeddelandet.

Nån som har en aning om vad det kan bero på?

Tack för svar!


Har för mig man kan få det om det är något problem med valutorna, minns inte exakt vad felet var, men kan vara en bra idé att kolla att valutorna är korrekta och även spara om SEK (SEK som standard ska ju ha 1 som växelkurs).

Share this post


Link to post
Share on other sites
Har ett litet problem med Payson modulen på 1.4.0.17
den skickar inte tillbaka att betalningen har blivit godkänd jag får kvitto på att en betalning har genomförts
pengarna syns på Payson kontot men i prestashop står det att ingen betalning mottagits
samt att statusen står som payment error.

några ideer?


Tyvärr ingen aning om vad som kan vara fel. Har du varit i kontakt med de som gjort modulen? För vår modul stödjer ju inte 1.4 ännu.


Vi har exakt samma problem, och vår webshop är Prestashop 1.3.2

Vi får betalningen till Payson men i Prestashop står det att ingen betalningen är mottagen, detta är inte så bra då kunden får ett mail där det står "Payment error" och vi måste gå in manuellt och ändra till Payment accepted. Är det någon som har en fix på detta?

Tack för att ni finns.

/TKTK


Samma problem här! Kör 1.3.1.1 och paysonsmodul (version 1.4).

Nån som kommit på en lösning på problemet?

Tacksam för svar! =)

/Andreas

Share this post


Link to post
Share on other sites

Samma problem här, köparen får payment error även fast ordern är bekräftad på mitt paysonkonto.
Version 1.3.2.3 - kör senaste version av paysonfaktura.

Help!

Share this post


Link to post
Share on other sites

Hmm, var säker på att dessa fel var ur världen nu. Bara för att vara på den säkra sidan. Är det Paysons modul för faktura eller Prestaworks modul för faktura ni använder. :)

/Pouria

Share this post


Link to post
Share on other sites
Hmm, var säker på att dessa fel var ur världen nu. Bara för att vara på den säkra sidan. Är det Paysons modul för faktura eller Prestaworks modul för faktura ni använder. :)

/Pouria


Använder er egna modul, ej prestaworks. :)

Share this post


Link to post
Share on other sites

Ok, då går vi vidare. Om du går in på den ordern, vad står det under Messages då?

/Pouria

Share this post


Link to post
Share on other sites
Ok, då går vi vidare. Om du går in på den ordern, vad står det under Messages då?

/Pouria


Det står:

At 2011-05-17 16:34:39 from Private:

Paysonköpet kunde EJ verifieras

Share this post


Link to post
Share on other sites

Tror vi hittat felet. (håller tummarna)

Ett tips till alla som installerar modulen för hand. Det ligger en fil som heter ipn_payson.php i zip-filen och denna måste ligga i modules-katalogen. Om den inte finns där så fungerar inte vår återrapportering och därmed nekas betalningar i shopen.

Bästa sättet är att installera via Admin genom att ladda upp zip-filen.

/Pouria, CTO Payson AB

Share this post


Link to post
Share on other sites

Ja förhoppningsvis var det skit bakom spakarna... :D
Får se om det går smidigare på nästa köp.

Share this post


Link to post
Share on other sites

Löste sig för mig. Jag hade glömt att jag var i underhållsläget i shoppen :P Så nu funkar det bra =)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More