Jump to content
frency

IMMAGINI E COMBINAZIONI PRODOTTI SPARITE NEL BACKEND

Recommended Posts

Ciao a tutti,
da ieri il mio PrestaShop da alcuni problemi che non riesco proprio a risolvere.

–—––––
LATO BACKEND
Nella sezione prodotti visualizzo correttamente tutti i prodotti con l'anteprima ma quando entro dentro al singolo prodotto sono sparite tutte le foto (pur essendo visibile nel frontend) e anche le combinazioni. È una cosa strana perchè nel frontend è rimasto tutto invariato. 
––––––
LATO FRONTEND
Nei prodotti in cui ho impostato dei "prodotti correlati" alla scelta della combinazione la pagina si aggiorna su uno dei prodotti correlati. Se al prodotto elimino i prodotti correlati il sistema funziona correttamente.
––––––

Sapete darmi una spiegazione e un consiglio di come potrei aggiornare e ripristinare il corretto funzionamento del sistema? 
Grazie mille

 

Note tecniche:
Tema "The Style" con licenza acquistata
Versione PrestaShop 1.7.5.1

Share this post


Link to post
Share on other sites

Ciao, ho risolto ed ora è tutto visibile ma ho nuovo e fastidiosissimo problema che devo assolutamente risolvere:

Quando visualizza sul sito un prodotto con combinazioni e prodotti correlati cliccando sul colore della combinazione differente mi apre un altro prodotto. C'è un modo per fixaere questo problema? È una cosa stranissima

Share this post


Link to post
Share on other sites

Ogni combinazione ha un immagine da settare.. Hai verificato?

Share this post


Link to post
Share on other sites

Certo, ma il problema persiste ma si comporta in modo strano. Quando entro dentro al prodotto e clicco sulle combinazioni colore mi "sbalza" su un altro prodotto non modificandomi però la url del prodotto. Sembra un errore strano. Non vorrei fosse qualche errore del "core" di PrestaShop e volevo provare a ripristinare i file originali della versione di prestashop. C'è una cartella specifica che posso ripristinare? 

Share this post


Link to post
Share on other sites

Potresti linkarci la pagina di uno dei prodotti col problema?

Share this post


Link to post
Share on other sites

Ciao, stesso problema che ha avuto un altro utente..

Dovresti impostare per ogni combinazione un riferimento diverso fittizio!

Fai una prova, dovrebbe risolversi

Share this post


Link to post
Share on other sites

Impostare un riferimento diverso fittizio in che senso? 

Share this post


Link to post
Share on other sites

Nel frattempo ho impostato per ogni combinazione un riferimento differente ma il problema persiste. Se provi a vedere vedi che continua a darmi lo stesso problema. Che soluzione potremmo trovare mannaggia che non ne vengo fuori

Share this post


Link to post
Share on other sites
24 minutes ago, frency said:

Nel frattempo ho impostato per ogni combinazione un riferimento differente ma il problema persiste. Se provi a vedere vedi che continua a darmi lo stesso problema. Che soluzione potremmo trovare mannaggia che non ne vengo fuori

Ii nel frattempo continuo a ricevere errori sul riferimento dalla console:

image.png.9dbb4e3616c621b8ded051c17d820b4d.png

Basta un solo riferimento identico per avere problemi.. Anche quello del prodotto principale deve essere differente

Share this post


Link to post
Share on other sites

Ho verificato ma non ci sono riferimenti uguali. Un prodotto è E041 l'altro è E0416. Come potrei fare diversamente?

Share this post


Link to post
Share on other sites
Posted (edited)
12 minutes ago, frency said:

Ho verificato ma non ci sono riferimenti uguali. Un prodotto è E041 l'altro è E0416. Come potrei fare diversamente?

 

Io vedo che per tutte le combinazioni è specificato come riferimento "XL grigio"..

Quote

Uncaught ReferenceError: jQuery is not defined
    at 224-727-t-shirt-sky-sport-collo-tricolore.html:901

 

Edited by Idroclic (see edit history)

Share this post


Link to post
Share on other sites

In realtà ogni combinazione sul BO ha il suo codice univoco differente. Il problema è che lato utente al momento del cambio colore il sistema modifica le combinazioni colori e le foto facendo apparire quelle di un altro prodotto. Non c'è una logica sembra un bel bug di qualche errore sul codice :( non esiste un modo per re-installare dei file di prestashop andando in sostituzione senza combinare guai?

Share this post


Link to post
Share on other sites

Quindi per ogni combinazione di colore cosa hai inserito? Se puoi mandare uno screen per scrupolo...

Share this post


Link to post
Share on other sites

Per ogni combinazione ho inserito "taglia colore" per avere la certezza che fossero riferimenti univoci ma il problema secondo me sta proprio sui "prodotti correlati". In tutti quei prodotti in cui inserisco i prodotti correlati nasce questo problema. Hai idee di come potrei intervenire? :(

Schermata 2019-04-04 alle 13.43.07.png

Schermata 2019-04-04 alle 13.42.59.png

Share this post


Link to post
Share on other sites

Prima che ripristinassi mi funzionava però, ora che hai reimpostato il backup (da quel che ho capito) ho l'errore.. 

Share this post


Link to post
Share on other sites

A dire il vero non è mai funzionato. Mi ha sempre fatto lo stesso errore. C'è qualcosa che fa conflitto e non mi fa cambiare le combinazioni correttamente (questo però avviene solo quando inserisco dei prodotti correlati). Ho provato a impostare un altro tema per vedere se il problema poteva essere quello ma anche con il tema default classico da lo stesso problema quindi escludo questa ipotesi (anche perchè è un tema prestashop acquistato con licenza). Suppongo sia qualcosa sul core ma non riesco a capire come potrei intervenire

Share this post


Link to post
Share on other sites

Mi verrebbe di dirti di rimuovere a questo punto i correlati e inserirli tramite un altro modulo ma ovviamente senza provare non posso dirti che potrebbe essere una soluzione.. Cmq hai provato a sentire lo sviluppatore del tema?

Share this post


Link to post
Share on other sites

Se anche sento lo sviluppatore penso di risolvere poco dato che il problema me lo da anche con il tema default. Tu sai come potrei re-installare prestashop sostituendo i file core a quelli esistenti? Quali cartelle magari dovrei andare a sostituire?

Share this post


Link to post
Share on other sites

Anche sul link che mi hai dato tu ho problemi cambiando le combinazioni di colore, il problema è che se elimino i prodotti correlati lo switch delle combinazioni funziona correttamente. Quindi dovrebbe esserci qualche errore nei "prodotti correlati"

Share this post


Link to post
Share on other sites
On 4/3/2019 at 3:53 PM, frency said:

Ciao, ho risolto ed ora è tutto visibile ma ho nuovo e fastidiosissimo problema che devo assolutamente risolvere:

Quando visualizza sul sito un prodotto con combinazioni e prodotti correlati cliccando sul colore della combinazione differente mi apre un altro prodotto. C'è un modo per fixaere questo problema? È una cosa stranissima

Ciao posso chiederti come hai risolto? Quando associo più immagini a più combinazioni lato utente mi spunta una sola immagine 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More