Jump to content
Mateusz

Problem z usługami offers,review

Recommended Posts

Witam,

Aktualnie bawię się z konsolą google i sprawdzam swoją stronę pod kątem pozycjonowania. Wyskakują mi pewne błędy związane z produktami. Strony są indeksowane, ale nie są wrzucane do wyszukiwarki. Należy określić usługę „offers”, „review” lub „aggregateRating” taki o to błąd wyskakuje w trakcie sprawdzenia adresu URL. Pytanie jak mogę to zmienić modułami ? Raczej wątpię, pewnie w kodzie, ale gdzie do licha coś dopisać i w którym .tpl ? Proszę o pomoc bo już 24h szukam rozwiązania tego problemu 

Share this post


Link to post
Share on other sites

Problem opisany tu

Mój developer mam jeszcze wsparcie dla szablonu podsłał poprawkę. kilka katalogów z kilkunastoma plikami w tym modyfikacja SQL. Ciężko to samemu ogarnąć. Presta robi się kombajnem który niedługo przerośnie samych twórców.

Share this post


Link to post
Share on other sites

odświeżam temat - czy udało się komuś rozwiązać problem ... ??

Share this post


Link to post
Share on other sites

Jestem właśnie na etapie naprawiania tego na dwóch sklepach
W szablonie folder templates -> catalog -> produkt.tpl i /templates/catalog/_partials/miniatures -> produkt.tpl (i w moim przypadku na jednym sklepie moduł w szablonie od nowych produktów)
zamieniłem itemscope itemtype="http://schema.org/Product"> na {* itemscope itemtype="http://schema.org/Product" *}> (tzn. wyłączyłem ten punkt)

może nie jest to najlepsze rozwiązanie ale poprawki przechodzą właśnie czekam na weryfikacje

Share this post


Link to post
Share on other sites

dołączam się do tematu

udało się znaleźć na to rozwiązanie?

dodatkowo mam jeszcze takie info z search consol

  • Brak identyfikatora produktu
  • Brakujące pole „brand”
  • Brakujące pole „sku”
  • Brakujące pole „image”
  • Brakujące pole „description”

 

 

Share this post


Link to post
Share on other sites

Mi pomógł support szablonu w ramach kilkumiesięcznej opieki po zakupie. Ale i tak część produktów była widziana przez G jako błędne, dopiero po 1,5 miesiąca G raczyło usunąć błędy ze swoich stanów. Mam za to "produkty prawidłowo z ostrzeżeniami". Walić to. Nie widzę wpływu na pozycje.

Share this post


Link to post
Share on other sites

A jak masz deafultowy szablon to co? 🙂

ja nie był bym takim optymistą jak ty gdyż Google już zapowiedziało że część z wymienionych parametrów może stać się błędami co wtedy wpłynie na widoczość i pozycję strony. Tym bardzkiej że przechodzą na indexowanie mobilne stron...

Share this post


Link to post
Share on other sites

Nikt ci kolego tu pewnie nie pomoże presta ma problem ze schema.org  aktualnie zostaje albo rezygnacja ze schema.org co opisałem wyżej albo naprawa we własnym zakresie budowy całych szablonów lub nie robienie nic i czekanie na aktualizacje

Share this post


Link to post
Share on other sites

niestety muszę przyznać ci rację...

chodź po cichu liczyłem że jestem guła :-) i jest to do ustawienia gdzieś ...

 

Share this post


Link to post
Share on other sites

moje zdziwienie nie znało granic gdy przetestowałem jeden ze sklepów który mam na PS 1.6.1.24

okazało się że tam znaczniki są i Google się nie czepia

a w PS1.7.5.2 nie ma i mam ostrzeżenia i błędy przy produktach...

w obu przypadkach deafultowy szablon...

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More