Jump to content
Anibal

Your .zip name is already used in an other module

Recommended Posts

Hi,

I'm trying to upload my very first module. I've already double checked it with the validator and everything seems to be OK.

However, when I try to upload it: Your .zip name is already used in an other module

I've already tried to rename the filename to several variations, including the sha256 checksum of the file. So, the same .zip name is out of the possible causes.

Any idea what could be the issue? It this a bug in the module uploader?

Help will be greatly appreciated.

 

Best Regards

Share this post


Link to post
Share on other sites

I think the problem is not with the zipname itself but with your module name.

Share this post


Link to post
Share on other sites

I've been able to solve the issue with the help of the support team.

For future reference, the problem wasn't the file name. It was the module structure.

The module structure was working OK on PS16 and PS17, and the validator was accepting it. However, the uploader didn't accept it.

The recommendation has been to follow the classic structure: http://devdocs.prestashop.com/1.7/modules/  

 

.... and now, the module is accepted by the uploader!

 

Thanks for your help,

Anibal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More