Jump to content
siteuye

Lokalde Sorunsuz Çalışan Modül Sitede Neden Çalışmaz(Çözüldü)

Recommended Posts

Posted (edited)

Arkadaşlar merhabalar;
SlidersEverywhere1.6.41 isimli şu adresteki modülü siteye kurmaya çalışıyorum.
Lokalde hiç bir sorun olmadan kurabildigim ve ayarlarını yapabildiğim halde gerçek siteye kurmaya çalıştığımda aşağıdaki hataları alıyorum.Lokalde de gerçek sitede de prestashopun aynı sürümünü kurulu. Aynı tema kurulu. A'dan Z'ye aynı özelliklere sahip. Ama lokalde sorunsuz kurulan ve çalışan modül sitede çalışmıyor. Oluşan hata raporunu ekte bulabilirsiniz. İlk hatadan anladığım
primary_key boş bırakılamaz diyor. Ama lokalde sorunsuz kuruluyor. Nedeni hakkında fikir veya öneri verebilecek arkadaşlardan yardım rica ediyorum. Şimdiden teşekkür ederim.

 

 

Hata.jpg

Edited by siteuye (see edit history)

Share this post


Link to post
Share on other sites

mysql versiyon farklılığı var sanırım, localdeki mysql ve sunucudaki mysql versiyon karışalştırın

Share this post


Link to post
Share on other sites
1 hour ago, safa said:

mysql versiyon farklılığı var sanırım, localdeki mysql ve sunucudaki mysql versiyon karışalştırın

Üstad merhabalar;
Evet şimdi tavsiyen doğrultusunda iki veritabanı özelliklerine baktım da şu şekilde görünüyor.

Lokalde: 

MySQL version 5.1.37-community-log, 

 MySQL engine InnoDB

olarak görünüyor.

Sunucuda ise:

MySQL versiyonu 5.7.24-0ubuntu0.16.04.1

 MySQL motoru InnoDB, 

MySQL driver: DbPDO

Yani iki MySQL versiyonu farklı. Sunucudaki MySQL versiyonunu değiştirmek istesem buna değer mi ve  değiştirebilir miyim ve daha önemlisi site sağlıklı çalışır mı? Bahsettiğim modül benim açımdan çok önemli. Sitedeki MySQL versiyonu lokaldeki EasyPHP ile gelen veritabanından daha yüksek bir versiyon. Siteyi senin de burada sık sık denk geldiğin ve yardımına başvurduğum şekilde güç bela düzgün çalışır hale getirebilmişken daha kötü hale getirmekte istemem. Yani kaş yapayım derken göz çıkartmak istemem. Senin tavsiyen modülü mü gözden çıkartayım yoksa veritabanı sürümünü mü uyarlamaya çalışayım? Tavsiyeni alabilirsem çok sevinirim.

Share this post


Link to post
Share on other sites

Kardeşim MySQL version 5.1 çok geride kalmış, hosting şirketin versiyon düşürme yapmaz zaten.

modulden vazgeç , yada sql kodlarını düzelttir.

mysql 5.7 iyidir şuan.

Share this post


Link to post
Share on other sites
23 hours ago, safa said:

Kardeşim MySQL version 5.1 çok geride kalmış, hosting şirketin versiyon düşürme yapmaz zaten.

modulden vazgeç , yada sql kodlarını düzelttir.

mysql 5.7 iyidir şuan.

Üstad merhabalar.
Nasıl oldu ben de anlamadım ama MYSQL'de kendim tabloları oluşturduktan sonra modül çalışmaya başladı. Yani tablonun var olmuş olması sorunu çözdü. Teşekkür ederim ilgilendiğin için.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More