Jump to content

Recommended Posts

Posted (edited)

O módulo de transferência bancaria  quando executado dá erro 500, podem me ajudar?

Ah, estou usando o Prestashop 7.3.3

Edited by simoes
faltou informação

Share this post


Link to post
Share on other sites

Tente ativar o Modo de descoberta de erros (debug) que fica em  Parâmetros avançados > Desempenho.

Isso deve fazer com que o erro mude para algo mais detalhado. Diga o que aparece, ou envie o print.

Share this post


Link to post
Share on other sites

Errei esqueci de salva quando liguei o debug:

 

Captura de tela de 2019-03-09 11-40-33.png

Share this post


Link to post
Share on other sites

O Log acredito que não vai ajudar. Envie o print do erro que aparece ao tentar executar o módulo de transferência bancária, depois de ativar o modo debug.

Share this post


Link to post
Share on other sites

Quando habilito "Pagar por transferência bancária" a concordância com os temos e finalmente o botão "encomenda com pagamento obrigatório"!

Captura de tela de 2019-03-09 11-52-11.png

Share this post


Link to post
Share on other sites
Posted (edited)

Pode enviar um print dos seus estados de encomendas?

Parâmetros da loja > Definições de encomendas > Estados de encomendas

Edited by rblaurin

Share this post


Link to post
Share on other sites

isso são 25 começando pelo id 30

 

Share this post


Link to post
Share on other sites

Tem como fazer isso no prestashop?

Share this post


Link to post
Share on other sites

dei o comando direto no db e agora em lugar do erro 500 aparece isso

Captura de tela de 2019-03-09 12-32-05.png

Share this post


Link to post
Share on other sites

Ok, deu certo, desliguei o debug e agora está normal, muito obrigado

Share this post


Link to post
Share on other sites
Posted (edited)

Seu host desabilitou uma função do php que é usada pelo Prestashop. Se você tem acesso ao ftp ou cpanel, procure em seu arquivo php.ini por disable_functions

Remova daí a palavra escapeshellarg e salve.

Se não tiver acesso você terá que entrar em contato com seu servidor e pedir para habilitarem a função escapeshellarg.

Edited by rblaurin

Share this post


Link to post
Share on other sites

Sim tenho acesso, vou fazer isso e obrigado de novo!

 

Share this post


Link to post
Share on other sites

Só um detalhe: seu cliente vai receber o e-mail padrão do módulo pagseguro de "aguardando pagamento".

Não sei como é este e-mail, se você quiser mudar crie um novo status, o status padrão do prestashop foi apagado.

Share this post


Link to post
Share on other sites

Me desculpe encher de novo mas o arquivo php.ini está vazio como faço para habilitar a função escapeshellar?

escapeshellarg=on;?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More