Jump to content
peter_lang

[gelöst] v1.7.5 Versandkosten bei Variablen im Warenkorb, Einstellungsfehler?

Recommended Posts

Posted (edited)

Hallo zusammen,

ich ahbe im 1.6 damals das lebige Problem lösen können, hier im 1.7 will er nicht so ganz.
Der Kunde kauf Nüsse,, er kann wählen zwischen DHL (DE  und EU) und Abholung am Stand, hier dann kein Versand berechnet.

Ich habe Deutschland als eigenes Gebiet eingetragen mit Zone Deutschland. Alle anderen sind in EU Gebiet drin.

Mein Problem ist komisch, ich glaube das Versandmodul berechnet keine Gewichtsvarianten bzw ignoriert sie, denn der Warenkorb liegt immer auf bis 2 kg mit 4,50 .. oder wenn ich mal über 5 kg gehe, dann springt er auf kostenlos. Hab ich von einem Artikel 5kg gelauft (5 x 1 kg), dann wird immer nur der erste Preis angezeigt, als wenn 1 x 1kg drin is im WK

Kennt jemand das Problem?

warenkorb.png

Voreinstellungen.png

versandtabelle.png

Edited by peter_lang (see edit history)

Share this post


Link to post
Share on other sites

Gelöst.
Wie immer, liegt der Fehler im Detail.

Alle settings für variablen sind soweit richtig. Allerdings muss in der einzelnen Variable die " Auswirkungen auf das Gewicht " eingetragen werden, da der Grundartikel 0 kg  hat.
Das heisst also bei der 400g Variante 0,4 und bei der 1000g Variante 1

Dann werden die Variablen Gewichte addiert und die Preisspannen greifen.

Vielen Dank an #clausiocool für den goldenen Tipp

Share this post


Link to post
Share on other sites

Dass man Prestashop die Gewichte auch mitteilen muß und dass x mal 0 eben 0 ergibt hättest du aber auch vorher feststellen können ...

Share this post


Link to post
Share on other sites

Gewichte hatte ich bei den Variablen hinzugefügt .. jedes hatte eins.. nur eben nicht im Feld " Auswirkungen auf das Gewicht ".

Hab es nun gelernt :)

Share this post


Link to post
Share on other sites

Das ist an vielen Stellen bei Presta so.... man muss manchmal die Programmiererlogik verstehen 

Share this post


Link to post
Share on other sites
vor 1 Stunde schrieb peter_lang:

Gewichte hatte ich bei den Variablen hinzugefügt .. jedes hatte eins.. nur eben nicht im Feld " Auswirkungen auf das Gewicht ".

Ich verstehe nur noch nicht, in welchem Feld statt dessen du denn die Gewichte eingetragen hast, ich finde keins ...

Share this post


Link to post
Share on other sites

Da hab ich gar nicht geschaut, mir fiel nur das leere Auswirkungsfeld bezüglich des Gewichtes ins Auge, und da die Grundvariante kein Gewicht hatte, war klar, dass es da nichts zu wiegen gab ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More