Jump to content
tinoguti

Installation problems (Intl extension is not loaded)

Recommended Posts

Hello, 

I am trying to install prestashop on my server with no success. 

I am getting the following message in the System compatibility section of the installation wizard:

  • Parámetros PHP requeridos

  • Intl extension is not loaded

  • Parámetros PHP recomendados

  • Install and enable the intl extension (used for validators).

I've been researching online and trying different things, updating the php version, trying to install the intl extension but nothing seems to work.

What is the solution to fix this problem?

I am running a CentOS Linux 7.6.1810 Virtualmin server with PHP 7.0.27

 

Any help will be appreciated. Thank you  

 

Screenshot_1.jpg

  • Like 1

Share this post


Link to post
Share on other sites
On 3/3/2019 at 12:44 PM, Jarjona said:

Hello, did you find the solution?

hello. no i did not. do you have the same problem? any ideas?

hopefully someone knows something about it and is kind enough to share the solution with the community?

Share this post


Link to post
Share on other sites
3 minutes ago, tinoguti said:

hello. no i did not. do you have the same problem? any ideas?

hopefully someone knows something about it and is kind enough to share the solution with the community?

 


 

Yes, I have the same problem. I have no idea. I have tried everything but I have not found any solution :(

Share this post


Link to post
Share on other sites

Activate intl extension for PHP on your webhosting. Sometimes this can be done in a configuration panel such a Plesk or cPanel, in other cases you can put a customized php.ini on your FTP server.

Share this post


Link to post
Share on other sites

I solved it.

Add the next line to php.ini file:

extension=intl

  • Like 1

Share this post


Link to post
Share on other sites

Hi guys, if you are still looking for a solution, you should read this :

 

Quote

I would like to point out a problem that occured when I wanted to enable the Intl extension. Here is the use case:

Un-comment the extension=php_intl.dll from the php.ini file.

Restart the Apache server

Notice that the dedicated section in the phpinfo() is not here and that the exention is not loaded (my script does not work)

Fortunately, I found the following workaround with some help from the internet 😉 :

Copy the icu*.dll files from the php directory to the apache/bin directory

Restart the Apache server

It worked for me,

 

✌️✌️✌️

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More