Jump to content
8659design

.htaccess problem(?)

Recommended Posts

Hi!

I try to verified ssl-certificate. My webhost has a good solution for this but i got an problem.

I got this message when I try to verify the certificate(its first time verification).
Certificate for www.mydomain.se cannot be requested, receives 301 redirect. If you want to issue a certificate for a domain like 301s, you must add it to your .htaccess under RewriteEngine On (or under RewriteBase) RewriteRule ^ .well-known (. *) $ - [L, NC]

So of cource I add
RewriteRule ^ .well-known (. *) $ - [L, NC] under RewriteEngine On but its not worrking, I still got the 201 redirect message.

Is there maybe some setting I have missed thats override .htaccess?

More information from my host about ths problem
https://translate.google.com/translate?hl=en&sl=auto&tl=en&u=https%3A%2F%2Flopnet.zendesk.com%2Fhc%2Fsv%2Farticles%2F360002971891-letsencrypt-hos-lopnet

Share this post


Link to post
Share on other sites

did you enable ssl in your prestashop back office?  recommend enabling all pages.  PS will then auto generate the correct .htaccess and there should be no need for your to add anything to your htaccess file.

Share this post


Link to post
Share on other sites

Hi thanks for anser. Yes i did that but it was not solving my problem.

But the solution was simple when I got on it. I made an .htaccess in the folder "well-known" thats override Prestashops htaccess.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More