Jump to content

Recommended Posts

Habe Prestashop 1.6.1.11 und nach dem heutigen einloggen kamen folgende Fehlermeldungen:

26 Fehler

  1. Error found : Opening and ending tag mismatch: link line 11 and head in country_module_list.xml file.
  2. Error found : Opening and ending tag mismatch: img line 19 and a in country_module_list.xml file.
  3. Error found : Opening and ending tag mismatch: a line 19 and div in country_module_list.xml file.
  4. Error found : Opening and ending tag mismatch: div line 15 and body in country_module_list.xml file.
  5. Error found : Opening and ending tag mismatch: body line 13 and html in country_module_list.xml file.
  6. Error found : Premature end of data in tag link line 10 in country_module_list.xml file.
  7. Error found : Premature end of data in tag meta line 9 in country_module_list.xml file.
  8. Error found : Premature end of data in tag meta line 8 in country_module_list.xml file.
  9. Error found : Premature end of data in tag meta line 7 in country_module_list.xml file.
  10. Error found : Premature end of data in tag meta line 6 in country_module_list.xml file.
  11. Error found : Premature end of data in tag meta line 5 in country_module_list.xml file.
  12. Error found : Premature end of data in tag head line 3 in country_module_list.xml file.
  13. Error found : Premature end of data in tag html line 2 in country_module_list.xml file.
  14. Error found : Opening and ending tag mismatch: link line 11 and head in must_have_module_list.xml file.
  15. Error found : Opening and ending tag mismatch: img line 19 and a in must_have_module_list.xml file.
  16. Error found : Opening and ending tag mismatch: a line 19 and div in must_have_module_list.xml file.
  17. Error found : Opening and ending tag mismatch: div line 15 and body in must_have_module_list.xml file.
  18. Error found : Opening and ending tag mismatch: body line 13 and html in must_have_module_list.xml file.
  19. Error found : Premature end of data in tag link line 10 in must_have_module_list.xml file.
  20. Error found : Premature end of data in tag meta line 9 in must_have_module_list.xml file.
  21. Error found : Premature end of data in tag meta line 8 in must_have_module_list.xml file.
  22. Error found : Premature end of data in tag meta line 7 in must_have_module_list.xml file.
  23. Error found : Premature end of data in tag meta line 6 in must_have_module_list.xml file.
  24. Error found : Premature end of data in tag meta line 5 in must_have_module_list.xml file.
  25. Error found : Premature end of data in tag head line 3 in must_have_module_list.xml file.
  26. Error found : Premature end of data in tag html line 2 in must_have_module_list.xml file.

 

Kann mir jemand sagen wo die herkommen. Der Shop läuft normalerweise problemlos. Habe nur vorgestern das Modul "Wishlist buy later" installiert.

Habe es wieder deaktiviert, aber die Fehlermeldungen sind immer noch da.

Share this post


Link to post
Share on other sites

Hallo bweller,

lösche mal die Datei:

default_country_modules_list.xml

im Ordner

/config/xml/

Anschließend noch den Cache löschen im BO

-->Erweiterte Einstellungen -->Leistungen

Und prüfe mal ob dann alles wieder läuft.

Grüsse
Whiley

Share this post


Link to post
Share on other sites

Das Problem ist nur, dass der Fehler immer wieder auftritt. Ich lösche dann wieder die Dateien auf dem Server. Lösche den Cache. Problem behoben. 2 Wochen später wieder das gleiche Problem.

Die Datei ist wieder auf dem Server.

 

Share this post


Link to post
Share on other sites

Versuch mal folgendes:

  1.  Lösche Modul Handelserfolg (gamification) 
  2. Lösche Modul Cron Task Manager
  3. Lösche die Datei default_country_modules_list.xml im Verzeichnis config.xml
  4. Setze in classes/Tools.php die Variable von true auf false: 
    protected static $is_addons_up = true;

Share this post


Link to post
Share on other sites

Danke, alles gemacht..  Mal abwarten ob es funktioniert.

Share this post


Link to post
Share on other sites
Posted (edited)

Ich habe zu spät gemerkt,  dass du ja 1.6.1.11 hast und nicht 1.7. Da wäre (Punkt 4.) ein Override der entsprechenden Funktion in der Tools.php fällig mit folgendem Inhalt:

<?php

class Tools extends ToolsCore {

    public static function addonsRequest($request, $params = array())
    {
        return false;
    }
}

Denn hier ist es die Funktion addonsRequest. (Als Override bezeichnet man eine Datei mit gleichem Namen und gleichem Dateipfad im Unterverzeichnis override.) Danach muss der Cache einmal gelöscht werden. Die Löschung der beiden Module trägt ursächlich übrigens nichts bei, aber verhindert,  dass das Back Office weiter ausgebremst wird oder es gelegentlich zu unerwarteten Fehlermeldungen kommt.

Edited by Wuschel (see edit history)

Share this post


Link to post
Share on other sites

Sorry, bin in der Beziehung Laie...

das heisst ich kopiere das obere direkt in die tools.php.

Gleich am Anfang unter ?php

 

Share this post


Link to post
Share on other sites

Nein, natürlich nicht! Lies doch einfach, was ich geschrieben habe und mach dich in der Dokumentation zu 1.6 schlau, was ein Override ist. Wenn du dir das nicht zutraust, musst du halt einen Profi beauftragen, die Änderungen durchzuführen. Prestashop ist leider zu komplex für Laien. Andererseits: Die meisten von uns haben als Laien angefangen. 😊

21 hours ago, Wuschel said:

Als Override bezeichnet man eine Datei mit gleichem Namen und gleichem Dateipfad im Unterverzeichnis override.

 

Share this post


Link to post
Share on other sites

Danke,, ich denke ich habe es hinbekommen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More