Jump to content
David57

Message avec une commande 1.7

Recommended Posts

Bonjour à tous , 

Je suis sur prestashop 1.7.1.2 thème Classic, y a t'il une fonction qui permette au client de la boutique de laisser un message au moment de passer commande?

Cette possibilité existe bien depuis "historique des commandes" dans le détail de la commande, mais d'après le retour client ce n'est pas clair, et il aurait préféré l'avoir à la commande.....

Comme sur les précédentes versions? Je trouve nulle part réponse à cette question, ce doit être au bout de mon nez ^^

Merci pour vos lumières 🙂

David

Share this post


Link to post
Share on other sites

Merci pour ta réponse rapide, je n'ai pas pensé à aller vérifier une version de base.

J'ai un module de livraison, il doit y avoir une surcharge sur cette partie, je vais creuser sur cette piste !

Merci!

Je fais suite quand j'ai la solution

Share this post


Link to post
Share on other sites

J'ai avancé sur mon problème.

Tout simplement il n'y a pas cette fonction sur la 1.7.1.2.

Sur le ficher /themes/classic/templates/checkout/_partials/steps/shipping.tpl

il n'y a pas le champs 

<div id="delivery">
              <label for="delivery_message">{l s='If you would like to add a comment about your order, please write it in the field below.' d='Shop.Theme.Checkout'}</label>
              <textarea rows="2" cols="120" id="delivery_message" name="delivery_message">{$delivery_message}</textarea>
            </div>

Si je le copie directement dans mon prestashop, l'interface du message est bien présent lors des étapes de commandes FO mais ne fonctionne pas. Etant donné que la mise en forme n'y ait pas, j'en déduis qu'il manque également la partie qui fait fonctionner le tout.

Quelqu'un pour me donner une piste pour ajouter cette fonction à mon thème? 

Quels sont les fichiers concernés? Il me suffit peut etre de rajouter tous les codes manquants à partir des fichiers de la 1.7.4.2, mais je n'arrive pas encore à intégrer tous les mécanismes....

Merci par avance

David

Share this post


Link to post
Share on other sites

Bonjour David,

Je rencontre actuellement le meme soucis sur un Prestashop 1.7.6.3., as-tu réussi à résoudre ton problème?

Cordialement Yoan.

Share this post


Link to post
Share on other sites

Ca fonctionne sur la démo Prestashop 1.7.6.2

Tu as regardé les tpl du thème ?

Les modules carrier installé ? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More