Jump to content
Sign in to follow this  
fabien.

Les photos sur la page Catalogue du back office ne se mettent pas à jour

Recommended Posts

Bonjour,

J'utilise la version finale de prestashop 1.1 qui marche à merveille.
Jusqu'à présent tout fonctionne bien sauf un léger bug sur la page Catalogue du back office.
Au bas de cette page il y a la liste des mes produits avec les photos en miniature.
Lorsque je change la photo d'un produit tout fonctionne correctement, le front office est mis à jour par contre :
La photo miniature au bas de la page Catalogue n'est pas mise à jour, c'est toujours l'ancienne qui apparaît.

Est-ce que quelqu'un a déjà recontré ce bug ?
Est-ce qu'une solution à ce bug existe aujourd'hui ?

Merci.

Share this post


Link to post
Share on other sites

J'ai aussi ce bug avec la v1.1 pour les petites miniatures du BO qui ne sont pas mises à jour lors du changement de photo.

Share this post


Link to post
Share on other sites

j'ai le meme probleme j'ai fait un sujet dessus!!!!!!!!!!!!

et prestaclient ça peux aider ????????,

Share this post


Link to post
Share on other sites

Ouaip j'ai constaté ce problème aussi, mais bon c'est pas super génant vu que c'est dans le back office. Mais c'est vrai que ca serait sympa que ce soit corrigé dans une future version !

Share this post


Link to post
Share on other sites

le probleme c'est que l'on ne peut reconaitre l'objet en back office qu'avec l'image ou le nom, ce serai bien d'avoir la référence de l'objet en backoffice. Si l'image ne bouge pas, il faut rentrer à nouveau le produit et effacer l'Ancien. C'est ce que je fais: Pas pratique.

Share this post


Link to post
Share on other sites

J'ai essayé de regénérer les miniatures mais le problème persiste.
Je trouve que c'est gênant comme bug, ça induit en erreur et c'est pas propre.
J'ai remarqué le même problème avec les versions précédentes, en tout cas la 1.0
Je vais essayer de fouiller dans le code pour identifier le problème mais je ne garantis rien.
Est-ce que quelqu'un aurait déjà créé un patch par hasard ?

Merci
a+++

Share this post


Link to post
Share on other sites

pareil ici. je viens d'installer la 1.1 et itou.
c'est gênant. si quelqu'un de chez presta pouvait résoudre ça...

Share this post


Link to post
Share on other sites
pareil ici. je viens d'installer la 1.1 et itou.
c'est gênant. si quelqu'un de chez presta pouvait résoudre ça...


Je confirme même problème sur 1.1.0.5. C'est effectivement très gênant !!

Share this post


Link to post
Share on other sites

oui ce bug est genant pour reconaitre les produits et oblige à refaire la fiche, par contre si on duplique le produit avec l'image , la petite image en BO est bien la bonne si on a modifié l'image du produit.

Que pensez vous de l'ajout de la reference produit dans le listing du BO, pour moi qui travaille avec les references produits, ce serai indispensable!

Share this post


Link to post
Share on other sites

+1 pour la réf produit.

et moins 1 pour le big bogue non résolu... (connu depuis belle lurette) ;-)

Share this post


Link to post
Share on other sites
Que pensez vous de l'ajout de la reference produit dans le listing du BO


Tu l'as demandé dans le Feature Request ? Ou appuyé si déjà demandé ?

Share this post


Link to post
Share on other sites

no. pas pensé. tu t'en charges ? :-) suis à la bourre là. tks ;-)

Share this post


Link to post
Share on other sites

oui, avant la sortie de la v1.1

http://www.prestashop.com/bug_tracker/view/675/


il y a un autre truc qui est genant dans le listing du back office: (ajouté au bug tracker)

si on a plusieurs pages de produits dans une categorie, si on clique sur le bouton acti/non actif on est renvoyé à la premiere page du listing au lieu de reter sur la page courrante!
avez vous remarqué ce bug?
ca fait perdre beaucoup de temps a revenir a chaque fois sur la bonne page

Share this post


Link to post
Share on other sites

Dans le BO - Lorsque l'on cree un nouveau produit et que l'on telecharge la photo du produit : tout va bien.

Lorsqu'il faut mettre a jour la photo suite a des modifications ou ne serait-ce qu'en cas de mauvaise manipulation, l'ancienne vignette ne se rafraichit pas et ne se mets pas a jour.

On remarque que dans le decriptif du produit, la nouvelle photo est bien prise en compte mais pas la vignette que faire ?

Share this post


Link to post
Share on other sites

Bug déjà signalé à plusieurs reprises sur le forum ! c'est en effet plutot génant. Esperons que ce soit réparé dans les prochaines versions.

Share this post


Link to post
Share on other sites

N'y a t'il pas un programmeur qui puisse corriger cela tres rapidement car en production ce n'est pas gerable surtout lorsque l'on doit l'expliquer le fonctioennement de l'appliction a du personel ou tout simplement pour montrer un projet a un client ... cela ne fait pas serieux et malheureusement le client doute sur la fiabilite du systeme... Il y a tres certainement sur ce forum de bons programmeurs qui puissent corriger cela (meme moyennant retribution) : je suis preneur ...

Share this post


Link to post
Share on other sites

J'ai fait des demandes répétées de fix pour ce genre de bug pour la V1.1 ou la sortie d'une V1.1 debuguée mais rien à faire, la team s'en balance..... seule solution proposée: attendre la prochaine version et se taper toute la réadaptation de sa boutique, il y en a qui galerent a passer de la V1 à la V1.1 et bien ils galereront encore pour passer de la V1.1 à la V1.2. Alors que l'on peut tres bien etre en production avec une V1.1.
Sans remettre an cause la qualité du projet, de ce coté là on peut dire que Prestashop n'assure pas du tout.

La V1 n'est jamais sortie debuguée, la V1.1 non plus, il n'y a donc jamais eu de version de Prestashop sans bug genant.....simple constat.

Il y a de nombreux bugs en cours de correction, il me semble qu'il serai bon de publier des fix pour le bugs les plus genants comme l'impossibilité d'effacer un accessoire ou l'image miniature du listing qui ne change pas.

voir http://www.prestashop.com/forums/viewthread/10212/discussion_generale/sondage_souhaitez_vous_une_version_v1_dot_1_finale_sans_bugs

Share this post


Link to post
Share on other sites

@didier-25 : bug déjà posté, j'ai fusionné ton topic avec celui existant.

Share this post


Link to post
Share on other sites

ben voilà... tu fusionnes et moi j'arrive plus null part... :-) normal le topic est mort.

sinon, oui, en effet, ce bogue a déjà été maintes fois posté. merci de lire les posts avant d'envoyer.

Share this post


Link to post
Share on other sites
J'ai fait des demandes répétées de fix pour ce genre de bug pour la V1.1 ou la sortie d'une V1.1 debuguée mais rien à faire, la team s'en balance..... seule solution proposée: attendre la prochaine version et se taper toute la réadaptation de sa boutique, il y en a qui galerent a passer de la V1 à la V1.1 et bien ils galereront encore pour passer de la V1.1 à la V1.2. Alors que l'on peut tres bien etre en production avec une V1.1.
Sans remettre an cause la qualité du projet, de ce coté là on peut dire que Prestashop n'assure pas du tout.

La V1 n'est jamais sortie debuguée, la V1.1 non plus, il n'y a donc jamais eu de version de Prestashop sans bug genant.....simple constat.

Il y a de nombreux bugs en cours de correction, il me semble qu'il serai bon de publier des fix pour le bugs les plus genants comme l'impossibilité d'effacer un accessoire ou l'image miniature du listing qui ne change pas.

voir http://www.prestashop.com/forums/viewthread/10212/discussion_generale/sondage_souhaitez_vous_une_version_v1_dot_1_finale_sans_bugs


oulà ! comme tu y va. t'es de mauvais poil ?
t'as pas fait crac-crac cette nuit ?
sinon c'est vrai que c'est chiant ce big bogue.
maintenant de là dire que rien ne va et que la team s'en fout... :-)

Share this post


Link to post
Share on other sites

sinon c'est vrai qu'une liste de fixs serait vraiment top. (bonne idée jolvil) et tant qu'à faire, indiquer les lignes des modules etc à remplacer. comme ça on pourrait upgrader sereinement.

Share this post


Link to post
Share on other sites

Restons calme ...

Je pense que pour les developpeurs de la solution ce ne doit pas etre facile car les journees sont courtes des que le temps joue contre nous ... Il est vrai qu'en tant qu'utilisateur pro je pense qu'il est important qu'un produit soit fiable avant de pouvoir etre mis en production et il est vrai aussi que ce n'est pas rentable si a chaque mise a jour il faut tout refaire ... Aucun client serieux ne s'engagera sur ce terrain.

Je suis persuade qu'il y a assez de bons pros en france pour developper et corriger ce type de faille qu'il faut bien evidemment et absolument solutionner ou malheureusement si belle soit la solution ...

Je me suis amuse a lire tous les post du forum en francais et je pense que l'equipe technique devrait porte un peu plus d'attention a ce forum et ne pas laisser se degrader les situations de bugs. Peut-etre devrait-elle mettre regulierement des correctifs en ligne sous forme de code modifie et non pas effectivements sortir la version xxx qui proposera de nouvelles fonctionalites qui apparemment comporteront d'autres failles ... la course en avant ... le jeu sans fin ...

Il faut savoir s'arreter avec les nouvelles fonctionnalites et assurer un produit stable mais je pense que l'equipe est bien consciente du probleme et sera suffisamment profesionnelle ... Attendons un peu et restons calme ...

Share this post


Link to post
Share on other sites

ben voilà !
c'est toi qui fout la merde et après il faut que l'on reste calme...



;-)

Share this post


Link to post
Share on other sites

Oui je suis assez râleur , surtout quand je dois me retaper une upgrade de boutique avec toutes les modifs que j'ai faite juste pour avoir la correction des bugs, et je ne suis pas seul dans ce cas.
Fabrice! Pour ce qui du crac crac, le coup est un peu bas mais t'es mal tombé ;-) , on dirait que cela me donne d'autant plus envie de râler.

Pour le probleme de l'accessoire que l'on ne peut pas effacer , il y aurai une solution ici http://www.prestashop.com/forums/viewthread/10492/#47978
mais voilà on est obligé de trouver des solutions ou de fix de bugs qui ne sont meme pas garantis de fonctionner, c'est bien dommage de ne pas avoir plus d'activité de ce coté là.

Share this post


Link to post
Share on other sites

moi non plus pas crac crac. ;-)
alors on est deux.
on va monter un club : ceux-qui-bossent-trop-sur-prestashop-pour-faire-crac-crac :-)
allez !! bises.

Share this post


Link to post
Share on other sites

et pour ce qui est de l'upgrade, je suis d'accord avec toi. c'est galère...
tu sais toi si on peut greffer un module comme ça sans refaire l'instal ? (dans le cas d'une correction de bogue par exemple)

Share this post


Link to post
Share on other sites

justement t'as mal compris j'ai eu mon content cette nuit, obligé de raconter sa vie.... ;-P

Share this post


Link to post
Share on other sites

pas bug crac-crac alors ? ohhhhh....
seulement prestashop ?! ahhhhhh.....

Share this post


Link to post
Share on other sites

Fabrice, le sais tu mais nous avons un partenaire en commun, on pourrai presque faire menage à trois

Share this post


Link to post
Share on other sites

on le fait à la marocaine alors ? ;-) avec des chameaux ?
allez... on (2) bosses !.>..

Share this post


Link to post
Share on other sites

LOL,

En lisant l'autre post, je croyais que c'était un bogue de la mort qui tue!!!!!

Ouf, je peux retourner dormir...

PS : Pour éviter ce désagrément, je fais soit avec ou je supprime l'article pour le recréer...
Mais le plus important, je ne me trompe pas d'image au moment de l'insertion :)

V++

Atch

Share this post


Link to post
Share on other sites

Bonjour,

[EDIT]
Il me semble que c'est un problème de cache navigateur, en tout cas sur mon poste sur FF1, Opera et IE, F5 ou Actualiser du navigateur re affiche la bonne image, donc pas la peine de recréer l'enregistrement.

Pour les accessoires, c'est aussi un bug navigateur, les console.log oubliés par les devs font bugger certains navigateurs, pas FF2 en tout cas mais FF3 oui. Il faut donc bien retirer comme proposé sur l'autre post, tous les console.log des javascripts. On a eu le problème sur des sites clients la même semaine que le bug track. Outre les accessoires, ça faisait planter d'autre scripts javascript alors que bon...normalement les console.log sont justement pour le debug. ;-)
[/EDIT]

Alors que l'on peut très bien être en production avec une V1.1.
Sans remettre an cause la qualité du projet, de ce coté là on peut dire que Prestashop n'assure pas du tout.

La V1 n'est jamais sortie debuguée, la V1.1 non plus, il n'y a donc jamais eu de version de Prestashop sans bug genant.....simple constat.


Jolvil, comme d'habitude vos remarques sont désobligeantes et fausses. Nous devrions reproduire l'exemple d'osc, tout le monde publie son petit fix dans son coin et plus personne ne peut faire de mise à jour du tout ?

Share this post


Link to post
Share on other sites

Gregory

Mes remarques sont surement desobligeantes, je n'en doute pas mais elles ne sont pas forcement fausses.

Il est tout à fait normal qu'il y ai des bugs, ce qui est enervant c'est qu'il n'y ai jamais de correctif ou de version débuguée alors que les solution dites finales se repandent internationalement, c'est tout à fait regretable.

Nous devrions reproduire l’exemple d’osc, tout le monde publie son petit fix dans son coin et plus personne ne peut faire de mise à jour du tout ?
C'est ce qui se passe actuellement faute de mieux. Raison de plus pour publier officielement!


Il est plus facile de corriger la version à la source que d'avoir 10000 personnes qui corrigent chacunes dans son coin, c'est juste une question de bon sens.

Désolé si je ne suis pas gentil!!!! :coolgrin:

Share this post


Link to post
Share on other sites


Il est plus facile de corriger la version à la source que d'avoir 10000 personnes qui corrigent chacunes dans son coin, c'est juste une question de bon sens.
:coolgrin:


Euh...c'est bien le propos (bien que hors sujet)....vous proposez l'inverse !

Nous en revenons toujours au même point décidément.

Nous faisons une beta pour identifier les bugs.
Le bug tracker est vidé de tout ce qui est bloquant.
Personne ne communique sur le bug en beta.
Nous publions une stable.
Le bug est identifié.
Une correction est apportée.
Nous mettons à nouveau en beta et la boucle est bouclée.

jamais de correctif ou de version débuguée


C'est faux. Si le bug n'est pas identifié en beta test, il n'est pas identifié, par personne ! Si le bug est identifié après la publication c'est trop tard, il faut attendre la prochaine version qui contiendra la correction.

Share this post


Link to post
Share on other sites
Si le bug est identifié après la publication c’est trop tard, il faut attendre la prochaine version qui contiendra la correction.


C'est bien là le probleme " c'est trop tard ", trop tard pour qui ?, pour quoi? Le train est passé, il faut attendre le prochain?

c'est trop tôt vous voulez dire,
La version finale est sortie trop tot
il y aurai du avoir une RC de plus apres les Beta

Donc je persiste et signe il n'y a pas de versions de Prestashop "finales" sans bugs genants ! :P

Et les milliers d'utilisateurs doivent tracker les solutions sur le forum pour corriger leurs versions "finales"

Share this post


Link to post
Share on other sites

Vous mélangez version RC (= beta) et stable et ne proposez pas de solution spécifique pour le bug évoqué ici.
Nous tombons donc en hors sujet.

Pour en finir j'espère avec ce point erroné :

Quand une stable sort, c'est qu'il n'y a plus de bug dans le bug tracker sur une beta pendant un laps de temps. Si deux mois après on trouve un bug, nous sommes deux mois après ! Prochain train !
Les utilisateurs attendent la prochaine mise à jour qui corrigera le bug. C'est le même fonctionnement pour tous les logiciels.

Share this post


Link to post
Share on other sites

En general les bugs apparaissent tres vite apres la sortie des versions, parfois dans les minutes qui suivent et pas 2 mois apres. Mais puisque vous avez raison sur tout, ne nous ecoutez pas et continuez comme vous faites sans vous soucier de vos utilisateurs puisque des centaines de personnes essayent de faire tourner Prestashop avec des versions dont vous ne fournissez aucunes corrections pour les bugs si ce n'est attendre la prochaine version buguée.... :coolmad:

Share this post


Link to post
Share on other sites

Le dernière fois vous me disiez qu'il restait plein de bugs sur une beta et sur svn. lol alors que le bug tracker ne faisait pas état de ce bugs et que vous n'aviez pas re installé votre version svn.

Si personne, ni de l'équipe, ni des beta testeurs ne se manifestent pendant les betas test et que le bug est identifié dans les minutes après publication d'une stable alors que pendant une semaine entière voir plus il n'y pas eu d'état de bug sur cette version à sortir...

Votre dernière remarque est encore désobligeante et fausse.

Share this post


Link to post
Share on other sites

tiens encore un des bugs de la V1.1 qui se manifeste http://www.prestashop.com/forums/viewthread/11413/#50430

et comme vous ne publiez pas de correctifs la communauté est obligé de s'entraider.

Le probleme c'est que c'est tres repetitif alors qu'une version corrigée serai un plus.


Si personne, ni de l‘équipe, ni des beta testeurs ne se manifestent pendant les betas test et que le bug est identifié dans les minutes après publication d’une stable alors que pendant une semaine entière voir plus il n’y pas eu d‘état de bug sur cette version à sortir…


Et alors qu'est qui empêche de sortir une version finale corrigée si des bugs ressortent?

Share this post


Link to post
Share on other sites

Nous pouvons continuer longtemps.

Oui une communauté s'entraide.

La prochaine version corrigera les bugs de la 1.1 non identifiés en beta mais identifiés apres release. Comme tout logiciel.

Share this post


Link to post
Share on other sites

oui mais il faudra readapter toutes le boutiques et c'est pas un mince travail quand on a adapté nombre de fichiers et que l'on est en production alors que quelques petits correctifs rendraient service à de nombreux utilisateurs. Mais là il faut vous supplier pour les avoir et encore on a rien du tout. >:(

Share this post


Link to post
Share on other sites

Ahhh enfin le fond du problème.

Vous ne souhaitez (pouvez) pas mettre à jour, car c'est une galère sur des versions modifiées ou corrigées par ci par là....

On publie des patchs pour vous et on repousse la sortie de la prochaine version pour les autres ? Sympa !

Share this post


Link to post
Share on other sites

Vous mettez du temps à comprendre alors que je ne fais que répeter la meme chose.

Share this post


Link to post
Share on other sites

Moi il me faut un rien de temps pour comprendre que ça part n'importe où et qu'il vaut mieux s'arrêter là.
En plus, on a la réponse à la question.

CTRL-F5 pour rafraichir le cache et virer les console.log pour les accessoires en attendant les corrections dans la prochaine version.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More