Jump to content
stempelgarten

PrestaShop 1.7.5.0 - Währung doppelt benannt

Recommended Posts

Ab zwei Währungen habe ich die Auswahl oben im Shop. Doch, bei CHF und EUR angeboten kommen "CHF CHF" und "EUR €". Aber nur "CHF" oder "EUR" würde reichen.

 

Bei weiteren Währungen vermutlich das selbe Phänomen.

Share this post


Link to post
Share on other sites

Da werden das Land / die Region und die Währung angezeigt, müßte sich in einer tpl-Datei des Währungsmoduls ändern lassen.

Share this post


Link to post
Share on other sites

Korrekt @rictools. Hier die exakte Position: modules\ps_currencyselector\ps_currencyselector.tpl.

Du kannst {$currency.sign} komplett entfernen oder abprüfen ob der Wert mit dem iso code übereinstimmt und nur in dem Fall entfernen (das erhält die EUR € falls gewünscht).

<div class="currency-selector">
  <span>{$current_currency.iso_code} {$current_currency.sign}</span>
  <ul>
    {foreach from=$currencies item=currency}
      <li {if $currency.current} class="current" {/if}>
        <a rel="nofollow" href="{$currency.url}">{$currency.iso_code} {$currency.sign}</a>
      </li>
    {/foreach}
  </ul>
</div>

Share this post


Link to post
Share on other sites

Selbst wenn ich beide {$currency.sign} lösche, bleibt die Anzeige so stehen. Habe die Datei unter angegebenem Pfad geändert.

Share this post


Link to post
Share on other sites

Caches gelöscht? Richtige Datei geändert (evtl. im Verzeichnis des Templates) und korrekt hochgeladen?

Share this post


Link to post
Share on other sites

also unter themes\classic\modules\ps_currencyselector ist es nicht und auch unter modules\ps_currencyselector\ ist es nicht die Datei. Selbst wenn ich dort alle currency.sign rausnehme, werden die noch angezeigt.

 

Cache vom Browser gelöscht und es geht trotzdem nicht.

Share this post


Link to post
Share on other sites

Hast du auch Prestashop-Caches gelöscht?

Es ist immer schwer, so etwas aus der Ferne zu beurteilen, mitunter ist es ein ganz blöder Fehler wie die Datei nach der Änderung in den falschen Ordner hochgeladen.

Share this post


Link to post
Share on other sites

Lasse den FTP-Client immer offen. Falsch raufgeladen kann nicht sein. Cache von Presta habe ich nicht gelöscht. Direkt über den Shop löschen oder aus dem Verzeichnis?

 

Im Shop sind die Cache nicht aktiviert.

Share this post


Link to post
Share on other sites

Ich empfehle /var/cache zu /var/cache_old umzubennen - dann hast du ein Backup falls was schief gehen sollte.

Bei mir funktioniert das auf jeden Fall bei Änderungen im theme Verzeichnis - hier mal text TEST hinzugefügt:

image.png.518d88728f5e2ae2cb5d7b9259debc38.png

Share this post


Link to post
Share on other sites

Cahceverzeichnis umbenannt. Jetzt hat es geklappt.

Aber im Admin kann man den Cache auch löschen? Wohl aber nur, wenn er auf "ein" gesetzt ist?

Share this post


Link to post
Share on other sites

Es gibt ja eine ganze Reihe unterschiedlicher Caches, vielleicht hast du nicht alle deaktiviert, die Einstellungen sind recht unübersichtlich. Es gibt übrigens auch Module zum leichteren Löschen der Cache-Dateien, zumindest für 1.6 auch kostenlos.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More