Jump to content
Sky

Presta 1.7.4.2 : Bug Groupes de clients et moteur de recherche interne

Recommended Posts

Bonjour à toutes et à tous,

Je suis confronté à un bug sur la boutique et ne trouve aucun moyen d'y remédier seul... Je fais donc appel à la communauté pour m'aider.

Le problème est simple (la résolution peut-être un peu moins ^^) :
Lorsque j'active dans le B.O. les groupes de clients (Paramètres avancés > Performances > Groupes de clients > Oui), le moteur de recherche de la boutique ne fonctionne plus du tout ! Toutes les recherches arrivent sur "
Il n'y a pas de produit correspondant à votre recherche.Effectuez une nouvelle recherche".
Idem sur les liens menant vers la page de "promotions" (qui n’étant pas une vrai catégorie, je suppose que cela passe par le moteur de recherche pour créer la page dynamiquement).

Suis-je le seul dans ce cas ? J'ai cherché sur tous les forums et n'ai rien trouvé de semblable ...
Avez vous une idée d’où cela pourrait provenir ?
Ai-je fait une bêtise dans les paramétrages ?

Comme vous l'aurez compris, j'ai moult besoins d'avoir les deux modules activés ^^

Merci pour vos réponses et votre aide.

Si besoin de plus de renseignements je suis là :D

Bonne fin de journée,

Seb

Share this post


Link to post
Share on other sites

Je me sens seuuuuuuulll !!!! 😕
Le problème n'est toujours pas résolu et je ne trouve pas de solution .... 😧😭

Share this post


Link to post
Share on other sites

pour la recherche produits avez vous Ajouter à l'index les produits manquants

dans : paramètre de la boutique/Rechercher

Share this post


Link to post
Share on other sites
Le 18/10/2019 à 10:38 AM, Farris27 a dit :

Bonjour, quel version de php ?  Avez-vous un lien url pour tester ? 

Bonjour Farris27,
La version de PHP actuellement utilisée est 7.0.33

Concernant le lien, pour le coup tu ne verras pas le résultat du bug puisque j'ai opté pour que le moteur de recherche fonctionne, je réactive les groupes de clients uniquement en fonction de la demande au coup par coup et ensuite je remet vite mon moteur de recherche fonctionnel pour ne pas perdre les clients.

Le 21/10/2019 à 6:14 PM, solsol69 a dit :

bonjour

quel version prestashop svp ?

Bonjour Solsol69,
La version de prestashop actuellement utilisée est la v.1.7.4.2.

Concernant les résultats de recherche, le problème n'est pas qu'il manque certains produits (je fait régulièrement la ré-indexation des produits) , c'est juste que TOUS les résultats de recherche tombe sur une 404 😕

Share this post


Link to post
Share on other sites

Concernant les erreur 404 lors de la recherche je ne l'ai pas constaté.

Share this post


Link to post
Share on other sites
il y a 26 minutes, solsol69 a dit :

Concernant les erreur 404 lors de la recherche je ne l'ai pas constaté.

C'est exactement ce que je disais dans ma précédente réponse à Farris27 :  Tu ne verras pas le résultat car j'ai actuellement désactivé les groupes de clients pour conserver un moteur de recherche fonctionnel ....

 

Share this post


Link to post
Share on other sites

Je n'arrive pas à comprendre le lien entre le groupe de clients et le moteur de recherche.

Share this post


Link to post
Share on other sites
il y a 23 minutes, solsol69 a dit :

Je n'arrive pas à comprendre le lien entre le groupe de clients et le moteur de recherche.

Et bien figure toi que moi non plus !! Et c'est d'ailleurs là le grand problème !
J'ai passé des heures incalculables à chercher un lien entre ces deux "modules", en vain.

Ça n'a absolument AUCUN sens logique 😕

Share this post


Link to post
Share on other sites

il n'y a pas une configuration du module de recherche ou peut etre le reinitialiser?

Share this post


Link to post
Share on other sites

C'est le module de recherche par défaut de Prestashop (barre de recherche classique) et il ne peut ni être configuré, ni ré-initialisé comme les autres modules ... 😕

Share this post


Link to post
Share on other sites

Fichtre, je ne l'avais pas vu ...
Je l'ai ré-initialisé, et cela ne change rien au résultat. Dès que les groupes de clients sont activés, pouf, plus de résultats ni de promos ... 😕

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More