Jump to content

Recommended Posts

Pessoal tenho a loja  versão 1.6 estava rodando legalzinho, até que *&¨%$#@ Zebrou tudo.

As imagens e anuncios na loja nao carregam, em frontend veja na imagem anexo, e na administração da loja tem esta mensagem.,

Consulta SQL errada
Expression #1 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'divulgan_pres576.a.id_customer_thread' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by

 

Agúem pode me auxiliar para corrigir isso? 

Desde ja eu agradeço!

prestashop.png

prestashoperror.png

Share this post


Link to post
Share on other sites

Vc. está usando um módulo que necessita adaptacao para correr ou entao php 7.x ou entao mysQL 5.6 acima.

Para contornar o erro por enquanto, mas nao é a solucao ! vc. vai no banco de dados através do phpmyadmin e corre este SQL:

SET GLOBAL sql_mode=(SELECT REPLACE(@@sql_mode,'ONLY_FULL_GROUP_BY',''));

Para resolver definitivamente o problema, vc. terá que adaptar o código do seu módulo em uso, que já nao mais vai com versoes php novas e/ou mysql acima de 5.6. pois aqui houve adaptacoes na arquitetura e full_group_by foi removido.

Share this post


Link to post
Share on other sites

Obrigado pela resposta!

Fui ate o php myadmin executei  o comando sugerido porém  saiu uma mensagem dizendo que nao tenho privilégios.

 

erroadmin.png

Share this post


Link to post
Share on other sites

Entao deverá contatar o provedor, ou entao pedir ao desenvolvedor do módulo para atualizar o código do mesmo para que este rode com versao ph 7.x e mysql 5.6. acima.

Outra opcao seria fazer um downgrade do seu servidor para versoes php iguais e inferiores à 5.6.30 e mysql 5.3. por ex. Veja aqui os requisititos necessários, cada versao do Prestashop necessita de mínimos e também máximos, pois a arquitetura muda à cada ano ou ao menos meio ano...

 

Share this post


Link to post
Share on other sites
Agora, selectshop.at disse:

Entao deverá contatar o provedor, ou entao pedir ao desenvolvedor do módulo para atualizar o código do mesmo para que este rode com versao ph 7.x e mysql 5.6. acima.

Outra opcao seria fazer um downgrade do seu servidor para versoes php iguais e inferiores à 5.6.30 e mysql 5.3. por ex. Veja aqui os requisititos necessários, cada versao do Prestashop necessita de mínimos e também máximos, pois a arquitetura muda à cada ano ou ao menos meio ano...

Obrigado pela resposta,  falei com o pessoal responsavél pela hospedagem e eis a resposta.

 

Obrigado pela resposta,  falei com o pessoal responsavél pela hospedagem e eis a resposta.

Olá Nilson,

 
Confirmação da equipe o seu comando de solicitação:
SET GLOBAL sql_mode = (SELECIONAR REPLACE (@@ sql_mode, 'ONLY_FULL_GROUP_BY', ''));
 
Não podemos fazer isso em um ambiente compartilhado. Você precisa ter um VPS para esse recurso.
 
________________________________
 
Fui até em  Cpanel  Multiphp e escoli a versão 5.4, 5.5, e 7.0 todas deu erro 500, somente a versão 5.6 roda parcialmente a pagina.
 
obrigado
 
 

 

 

Share this post


Link to post
Share on other sites

Troque de provedor. O Prestashop necessita na verdade de um ambiente próprio, ou se for compartilhado com poderes extras. Se o seu provedor nao fornece, entao contrate outro pacote que contenha estes requisitos ou entao mude de provedor. Neste caso infelizmente nao podemos ajudar. Provavelment por razoes de seguranca ele fez um upgrade do servidor com mysql mais recente que provoca o erro. Que na verdade nao é um erro, mas sim uma mudanca na arquitetura do banco de dados para mais consistencia e seguranca.

Na verdade o problema aqui é que vc. está usando o Prestashop 1.6.0. um template com código ultrapassado e módulos com código ultrapassado que nao mais correm com versoes php e versoes mysql atuais.

As opcoes que lhe restam seriam:

1) atualizar o seu Prestashop para PS 1.6.1. última para poder correr no espaco web aonde está e nao mais ter problemas por algum tempo, descartando neste caso todos os módulos e template que já nao mais funcionam,

2) OU atualizar a loja para 1.7. trocando tudo, inclusive os módulos extras que comprou,

3) OU fazendo um downgrade dos requisitos do servidor, (opcao difícil, pois algum dia também aqui o servidor deverá receber um upgrade),

4) OU contatar o desenvolvedor dos módulos extras que nao mais funcionam devido à nova arquitetura do banco dde dados para que o mesmo adapte o código do módulo para que sirvam. (Esta última opcao seria a mais viável e barata, no entanto também em tempo restrita, pois novas versoes do mysql e php continuarao indo pra frente...)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More