Jump to content
Jance

Checkout Editierfunktion funktioniert nicht !

Recommended Posts

Hallo zusammen,

kann mir ja jemand helfen bei meinem Problem im Checkout! Die Funktion der Adresse bzw. des Artikels.

Anbei mal zwei Bilder von dem Istzustand und dem Sollzustand. Rot umrandet zu sehen ´Mode_edit`anstatt dem ´Stift´ zum editieren. Auch der Link funktioniert nicht.

Installiert sind nur PS + DSGVO + Template, ansonsten sauber. Der Hersteller vom Template hat Fehler seinerseits schon ausgeschlossen.

Wie auf dem zweiten Bild sollte es ungefähr aussehen!

Jemand einen Tipp? Beste Grüße, Jan

 

5c60716524c41.thumb.jpg.2cace236ddc6610bd9dbf9ea2bf0d4c4.jpg 

 

1904288371_Europäische Vorschriften.thumb.jpg.48528e6e2fa417706d7c6f2923b40c95.jpg

 

 

5c60716524c41.jpg

Edited by Jance
ein Bild zuviel

Share this post


Link to post
Share on other sites

Hallo zusammen

Ich habe das gleiche Problem (Anzeige "mode_edit" anstelle der Bearbeiten-Icone), der Click-Event (/themes/core.js) wird zwar gestartet, dieser läuft aber ohne Fehlermeldung in's Leere ...
Ich verwende ein anderes Template,  (https://www.templatemonster.com/prestashop-themes/57832.html) und das angestossene Script ist ein PS-Core Script.

Ich warte zwar noch auf ein Feedback des Template-Entwicklers aber habt Ihr eventuell eine Idee woran das liegen kann ?

Der Hinweis "Da gibt es nur einen Tipp: Glaub dem Entwickler des Templates nicht!" von "elezar" ist da wenig hilfreich ...

Gruss an Alle

Anymore

Share this post


Link to post
Share on other sites
vor 45 Minuten schrieb Anymore:

Der Hinweis "Da gibt es nur einen Tipp: Glaub dem Entwickler des Templates nicht!" von "elezar" ist da wenig hilfreich ...

Das ändert aber nichts daran, dass es stimmt! Denn beim Standard-Template funktioniert es ja.

Es wäre übrigens hilfreich, du würdest uns Deine genaue Versionsnummer von 1.7 mitteilen. Denn schon daran kann die Template-Kompatibilität scheitern. Es wird immer noch an 1.7 herumgebastelt. Deshalb ist auch die Angabe bei Template-Monster, Dein Template sei kompatibel mit 1.7x wenig hilfreich. Wenn es mit 1.7.0 oder 1.7.1 kompatibel ist, muss es nämlich noch lange nicht mit 1.7.4 oder gar 1.7.5.1 kompatibel sein. Da PrestaShop 1.7 immer noch in der Entwicklungsphase steckt, kommen die Fremdanbieter oft nicht nach, weil sie die ständigen Änderungen gar nicht mitbekommen.

Übrigens wird im Bild oben nicht "mode_edit" angezeigt sondern "Mode_edit". Groß- und Kleinschreibung kann man nicht einfach beliebig variieren. Nur die kleingeschriebene Variante kommt korrekterweise vor.

Die oben angezeigte Gesamtübersicht im Checkout wird übrigens vom Modul ps_legalcompliance erzeugt und ist nicht PrestaShop-Standard. Das Modul dürfte Entwicklern außerhalb Europas, sofern sie sich da nicht genau auskennen, eh unbekannt sein.

Share this post


Link to post
Share on other sites

Hallo elezar

Danke für die schnelle Antwort. Du hast ja recht, wollte dir nicht an den Karren fahren, aber auf die schnelle sieht die Antwort eben schon nach "Laber, dass was gelabert ist" aus ...

Das einzige, was ich von dem Template weiss ist, "Updated auf 1.7.4.4 ", ich verwende 1.7.5.0. Das diese Versionsschritte schon so heikel sind, wusste ich nicht.
Überhaupt, ich hatte sechs Shops mit 1.6 erstellt und ich hatte nie solche Probleme. Das ist nun der erste 1.7 Shop und ehrlich gesagt, glücklich bin ich nicht unbedingt ...

Nur schon die nicht speicherbare Reihenfolge der Facetten-Filter, da ist der entsprechende BUG-Eintrag schon rund ein Dreiviertel-Jahr hängig und nichts läuft ... Ich weiss, es ist ein Open-Source Projekt und da darf man ruhig ein wenig geduldiger sein, dennoch sehen meine 20 Filter (muss leider sein) in der x-beliebigen Reihenfolge scheisse aus ...

Dein Hinweis mit dem ps_legalcompliance Modul ist genau das was ich wissen wollte. Bin hier zwar in der CH, aber ein Verkauf nach DEU setzt das dann eben schon wieder voraus.

Nochmals Danke für Deinen Hinweis und für Deine Mithilfe

Alles Gute wünscht

Marc

Share this post


Link to post
Share on other sites
vor 45 Minuten schrieb Anymore:

Überhaupt, ich hatte sechs Shops mit 1.6 erstellt und ich hatte nie solche Probleme.

Nimm's mir nicht übel, Marc, aber gerade in diesem Fall gilt die goldene Regel: Never change a running system. Du hättest vielleicht besser dabei bleiben sollen, denn 1,7 scheint sich zu einer never ending story zu entwickeln, was die Probleme anbelangt. Die Versionsnummer deutet nur ein Upgrade light an, de facto ist es aber eine völlige Neuentwicklung auf einem anderen Entwicklungssystem. Oder besser: sollte es mal werden, aber im Moment ist es noch ein Hybrid.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More