Jump to content

[RESOLU]URL Rewriting ne fonctionne pas sur Debian Etch


Recommended Posts

bonjour,

j'ai un probleme avec l'url rewriting

Ma config (herbergement perso) :
Debian + apache + ....

le site fonctionne a merveille mais quand j'active les "url simplifiees" et que je refraichis la
page d'accueil, dès lors les liens ne marchent plus

exemple :

jai une categorie "Autres"
si je survole le lien avec la souris cela m'indique : http://nomdusite/20-autres
si je clic sur le lien, j'obtiens ca :
Not Found
The requested URL /20-autres was not found on this server.

quelques infos supplementaires :
- le htaccess a la racine du site est le htaccess fourni d'origine
- mod rewrite est bien evidemment activé dans Apache
- j'ai modifié le "site-available" pour que, par défaut, on arrive directement dans le répertoire du site
- j'heberge mon site parce que je suis administrateur Debian (donc j'ai quelques connaissances dans le domaine)
- j'essaye de mon cote de comprendre le probleme mais si quelqu'un avait une piste sur le pourquoi du
comment, cela me ferait gagner un temps précieux
- dans le log Apache du site, j'ai ca :
file does not exist /var/www/monsite/20-autres, referer http://monsite


toute aide est donc la bienvenue :red:

Share this post


Link to post
Share on other sites

Peut etre serait-il possible de savoir le principe de fonctionnement de l'url rewrting au niveau de Prestashop ?

Par defaut, une categorie va executer un fichier phpp avec des parametres pour (j'ai l'impression) interroger la base et ensuite afficher le resultat

Si on active les "url simplifiees" cela signifie donc que le site prestashop dispose de sa propre gestion de ces url sinon on se conterait de tout gérer dans le htaccess donc la question serait alors "comment fonctionne prestashop des lors qu'on a activé les url simplifiées" ?

Share this post


Link to post
Share on other sites

bon ben ca avance ....

Maintenant le probleme que j'ai :
je n'ai plus l'erreur 404 quand je sélectionne une catégorie, par contre j'obtiens une nouvelle erreur :

Page introuvable

Erreur La page que vous avez demandée n'existe plus
Pour rechercher un produit, renseignez son nom dans le champ ci-dessous

NB: pour info, le probleme que j'avais etait au niveau de la directive Allowoverride du default

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More