Jump to content
sebastien

Changer version PHP sans risque

Recommended Posts

Bonjour,

J'ai vu que prestashop nous invite à passer à une version PHP 7, je suis actuellement en version prestashop 1.6.1.18 avec PHP 5.4.9.4 et thème par défaut.

Ma question : j'ai trouvé où changer la version PHP sur mon hébergeur online.net, est ce que le fait de changer la version PHP va impacter le fonctionnement de mon site ? autres paramètres à modifier ?

(aujourd'hui tout fonctionne correctement, je souhaite changer la version PHP car ensuite je dois passer le site en version prestashop 1.7)

Merci d'avance, je suis novice :)

Share this post


Link to post
Share on other sites
7 minutes ago, sebastien said:

Ma question : j'ai trouvé où changer la version PHP sur mon hébergeur online.net, est ce que le fait de changer la version PHP va impacter le fonctionnement de mon site ? autres paramètres à modifier ?

 

Oui, vérifiez bien que votre shop 1.6.1.18 est compatible PHP 7 . Attention il y a plusieurs versions php 7 : php 7.0 php 7.1 php 7.2 ... vérifiez bien les compatibilités.

Le mieux serait de faire un test sur une copie de votre shop pour être 100% sur parce que en plus si vous avez des modules, un thème, des overrides ceux là aussi il faut vérifier la compatibilité.

Share this post


Link to post
Share on other sites

Merci pour la réponse, c'est a priori ok si je me base sur la doc presta (tableau ci-dessous)

Au pire si ça marche pas en changeant je peux remettre la vieille version de php ? retour en arrière possible ?

Compatibilité PrestaShop x PHP

Versions PrestaShop Versions PHP compatibles
1.5.x ~ 1.6.0 5.2 - 5.5
1.6.1.x 5.2 - 7.1
1.7.0 ~ 1.7.3 5.4 - 7.1
1.7.4 5.6 - 7.1
1.7.5 5.6 - 7.2

 

 

 

Share this post


Link to post
Share on other sites

D'après le message reçu aujourd'hui par prestashop, c'est un peu du chinois pour moi mais il me semble que ça va devenir obligatoire avec la fin du support de version 1.6 ?

Depuis fin 2018, les versions de PHP antérieures à la 5.6 ne sont plus supportées par la communauté. De ce fait, il sera de plus en plus compliqué et risqué d'utiliser une telle version de PHP pour faire fonctionner votre boutique. Qu’est-ce que cela signifie pour vous et quelles sont les solutions ?

 

Conçue en 2013, la v1.6 de PrestaShop a depuis été mise à jour pour être compatible avec PHP 7.1. La maintenance de PrestaShop 1.6 prend fin en juin 2019 et  PHP7.1 ne sera plus supporté après décembre 2019 : il n’y aura pas de nouvelle version de PrestaShop 1.6 compatible avec PHP au delà de la version 7.1.

De même, conçue en 2016, PrestaShop 1.7 a été mise à jour pour être compatible avec PHP7, version de PHP qui apportait de meilleures performances. PrestaShop 1.7 est la version actuellement supportée de PrestaShop et sera mise à jour pour rester compatible avec les dernières versions de PHP.

PrestaShop 1.7, c’est aussi l’introduction du framework Symfony pour rendre la solution plus efficace, stable et robuste. Cette version comprend de nouvelles fonctionnalités à tous niveaux : back-office, front-office, navigation mobile, parcours utilisateur, etc. pour une navigation simplifiée tant côté administrateur que pour les utilisateurs de votre boutique.

Share this post


Link to post
Share on other sites

Pour moi ce message ne vise qu'a pousser les commerçants à passer sous 1.7 en leur faisant peur mais vu la stabilité de cette version je préfère mon bon vieux 1.6, il ne sera plus Mise à jour, très bien au moins  pas de risque de tout planter et d'avoir de nouveaux bug comme presque à chaque mise à jour que j'ai du faire.....

Sauf besoin d’évolution majeure, mon site fonctionne, je ne touche plus à rien.

 

bonne soirée

  • Like 1

Share this post


Link to post
Share on other sites

Comment vont faire les utilisateurs de la 1.6 après décembre si le php7.1 n'est plus supporté après?

Share this post


Link to post
Share on other sites

Et resteront donc sur une version de php non maintenue, s'exposant donc à des failles de sécurité non corrigées.

Il y a un grand débat sur ce forum (vous trouverez facilement les topics en cherchant un peu) sur "est-ce que utiliser php5 c'est dangereux en 2019", moi je prone la réponse "oui" pour la raison très simple que désormais PHP 5 n'est plus supporté ce qui signifie que si une faille de sécurité est découverte, elle ne sera pas corrigée par l'équipe PHP officielle ce qui vous laissera, si vous êtes dans le scope de cette faille, vulnérable. Vous avez envie qu'on vous vole vos données ^^ ?


Et comme je m'attends à une levée de boucliers "non mais faut pas être alarmiste", "y'a pas encore de failles trouvées donc tout va bien" je vous invite à lire tous ces articles qui vont dans ce sens:

- https://dev.to/david_j_eddy/php-5-end-of-life-is-upon-us-why-you-should-care-3gpk
- https://kinsta.com/blog/php-versions/
- https://www.liquidweb.com/kb/upgrade_php/
- https://www.wordfence.com/blog/2018/10/php5-dangerous/

Et même wordpress, qui pourtant a toujours supporté des versions trèèèèès vieilles de php, va arrêter de supporter php5 d'ici la fin 2019: https://www.reddit.com/r/PHP/comments/a4gp5z/wordpress_will_require_php7_by_the_end_of_2019/?


Par contre je n'ai pas encore trouvé d'article en-dehors de ce forum qui dise "tout va bien restez sur php5" :)
 

Share this post


Link to post
Share on other sites
il y a 9 minutes, ksaan a dit :

Par contre je n'ai pas encore trouvé d'article en-dehors de ce forum qui dise "tout va bien restez sur php5" :)

On a pas trouvé non plus d'article expliquant dans le menu comment des sites PrestaShop furent piratés du fait de failles sur PHP.

Tous les documents que l'on trouve son des incitation à passer en PHP7 du fait des réels avantages au niveau des performances que nous avons tous constaté.

Dans tous les cas, La bascule doit être testé avant de le faire sur le site de production afin d'identifier les quelques lignes de code dans le coeur ou les modules tiers qui doivent être adaptées.

Mais, franchement, s'amuser à faire peur aux utilisateurs novice en sortant toujours la même rengaine est détestable.

Passer en PHP7 est bénéfique, rester en PHP5.6 ne présente pas réellement de risque majeur dans l'utilisation de PrestaShop.

Il y a plus de risque d'avoir une installation Wordpress sur le même serveur que de rester en PHP5.6.

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, Mediacom87 said:

Tous les documents que l'on trouve son des incitation à passer en PHP7 du fait des réels avantages au niveau des performances que nous avons tous constaté.

 

J'ai posté 4 liens.

1er lien: https://dev.to/david_j_eddy/php-5-end-of-life-is-upon-us-why-you-should-care-3gpk
"Not to sound like a fear monger but if you have an application running PHP 5 and you do not have an upgrade path to completion in the next 6 months; start planning to have a data breach, bad press, a damaged reputation, lose customers, and possible lawsuit due to legnagance. It is not a matter of IF you will be breached; but WHEN. Do you really want to be one of the companies listed on https://haveibeenpwned.com/ due to a data breach?"

2e lien: https://kinsta.com/blog/php-versions/

"One of the most important reasons to update PHP is to ensure you are running on a version that is fully supported and patched regularly for security vulnerabilities. PHP 5.4 has not been patched since 2015. And PHP 5.5 has not been patched since 2016. It is important to note though, that some operating system vendors still update older versions of PHP if they included it.

According to CVE Details, 2016 was one of the worst years for PHP security vulnerabilities, with over 100 issues reported. These included DoS, code execution, overflow, memory corruption, XSS, directory traversal, bypass, and gain information types. 2017 was the third-worst year since 2,000, with over 40 vulnerabilities."

3e lien: https://www.liquidweb.com/kb/upgrade_php/

"While the last of PHP 5 closes out with PHP 5.6, this will inevitably leave websites utilizing PHP 5 vulnerable to attacks as well as poor performance. It has substantially reached its infamous End of Life (EOL) title. Switching to the newer PHP 7 versions is not only good for the security"

4e lien: https://www.wordfence.com/blog/2018/10/php5-dangerous/

"Security vulnerabilities are continuously reported in PHP. Some of these are serious. Viewing this page on CVEDetails.com will give you an idea of the volume and severity of PHP vulnerabilities that have recently been reported.

Many of the vulnerabilities reported in PHP were discovered this year. Many more will be discovered in PHP version 5 next year, after security support for all versions of PHP 5 have ended. That is why it is critically important that you upgrade to a version of PHP 7 that is supported and is receiving security updates."

Ces articles sont complets donc du coup ils n'oublient de mentionner également les gains de performance de php7. Mais désolé si vous lisez vous verrez que ce ne sont pas des incitations. Ce sont des énoncés sur le fait que c'est dangereux. Le 4e lien s'appelle quand même "Using PHP 5 becomes dangerous" ^^

Je n'aime pas faire l'alarmiste mais quand je vois quelqu'un en danger je lui dis. Je vais pas lui dire "non mais tout va bien" pour ne pas le paniquer ^^ à un moment il faut qu'il soit conscient de la situation. Et pour moi ainsi que pour les auteurs de ces articles, et pour Wordpress, et pour beaucoup de hosting providers, et pour l'équipe officielle php, php5 ce n'est pas pas sécurisé de l'utiliser en 2019.

J'invite sebastien à se faire sa propre idée (puisque nous on reste sur nos positions) en interrogeant des développeurs autour de lui, son hébergeur, éventuellement en se renseignant de lui-même avec quelques bonnes recherches google.

Share this post


Link to post
Share on other sites

Mais as tu été toi même témoin d'une attaque sur un site du fait d'une vulnérabilité dans une version de PHP ?

Personnellement, jamais depuis que PHP existe.

Share this post


Link to post
Share on other sites

Moi ? Non, mais j'ai toujours fait en sorte de ne justement pas être vulnérable. De même dans mon entourage les développeurs que je connais.

J'ai donc cherché sur Google un exemple, ce qui n'est pas facile car je pense que peu d'entreprises ont envie de dire publiquement qu'ils se sont fait hackés parce que leur version de php était trop vieille ^^

J'ai trouvé ceci: https://nakedsecurity.sophos.com/2015/10/30/webhosting-company-loses-13m-plaintext-passwords/

"A hacker used an exploit in old PHP version to upload some files, gaining access to our systems. Although the whole database has been compromised, we are mostly concerned about the leaked client information."

L'argument "je n'ai jamais eu de souci à faire X, donc faire X n'est pas dangereux" est très malléable. Je pourrai vous dire "je n'ai jamais eu de souci en roulant sans ceinture de sécurité, donc rouler sans ceinture de sécurité n'est pas dangereux", "je n'ai jamais eu de souci en ayant pas d'assurance habitation, donc ne pas avoir d'assurance habitation n'est pas dangereux" voire - plus récent - "je n'ai jamais eu de souci avec mon entreprise bien qu'on ne respecte pas le RGPD donc ne pas respecter le RGPD n'est pas dangereux".

Maintenant tout ceci ce sont des recommandations. Vous, vous faites comme vous voulez. Moi je vais suivre les recommandations de l'équipe PHP, de Wordpress, de PrestaShop, et de tout un tas d'entreprises et d'organisations reconnues et qui gèrent des milliers de clients / utilisateurs / sites internet.
Par contre ne m'en voulez pas de faire ces recommandations que je crois importantes et pertinentes aux lecteurs sur ce forum. Vous faites vos recommandations, je fais les miennes. Les gens choisissent après en ayant tous les éléments en main. Ca me parait bien, non ? On expose nos pour et contre, les gens sur ce forum peuvent lire de par et d'autres, vérifier également ce que vous et moi on avance, et enfin prendre la décision qui leur paraît pertinente.
 

  • Like 1

Share this post


Link to post
Share on other sites
il y a 5 minutes, ksaan a dit :

"A hacker used an exploit in old PHP version to upload some files, gaining access to our systems. Although the whole database has been compromised, we are mostly concerned about the leaked client information."

J'accepte cet exemple mais quid de l'information donnée qui ne comporte rien comme information. Ainsi une version ancienne de PHP c'est quoi ? Une 2, une 5.1 ...

Il existera toujours des brèches partout et PHP7.0 ou 7.1 doit en contenir plus que la 5.6 du fait même que des développement important furent fait dessus.

Le débat est complexe et la responsabilité des hébergeur peuvent être engagées, même si ils ne sont pas à l'origine de PHP. Donc tout le monde se couvrent au cas où.

Le fait est que chaque professionnel doit aussi prendre ses responsabilité et le risque zéro n'existant pas, il faut posséder des copies de ses hébergements au cas où.

Le piratage par faille de PHP sera réalisé sur l'ensemble d'un serveur, pas envers un site spécifique (votre exemple le prouve) et même si vous vous faite la démarche de basculer sur un version plus récente de PHP, l'ancienne sera toujours présente sur le serveur ce qui peut ouvrir des portes aussi.

Donc la seule parade c’est SAUVEGARDEZ VOS DONNÉES. Je le cri haut est fort, c'est la seule réelle parade pour pouvoir redémarrer son activité rapidement sur un autre hébergement.

Share this post


Link to post
Share on other sites

l'ancienne version ne sera pas forcément présente sur le serveur, heureusement que non...

mais oui, la sauvegarde, c'est la clé

Share this post


Link to post
Share on other sites

bonjour, j'ai un site sur 1&1 en prestashop 1.4.1.1, il m'oblige a syrfacturé pour conserver la version de php 5.6...

j'ai testé le php 7.2 recommandé et mon site fonctionne plus.

y a t(il possibilité de le rendre compatible en php 7.2 en touchant au php.ini?

MERCI DE VOTRE AIDE

Share this post


Link to post
Share on other sites

Ce n'est pas spécialement un problème de configuration mais plutôt la génération de la 1.4: elle a été conçue pour fonctionner avec des vieilles versions de PHP, et donc des parties de son code et probablement aussi les modules ne fonctionnent pas bien avec PHP 7 et plus. 

Il y a sur le forum des experts des vieilles versions de PrestaShop, peut-être pourront-ils t'aider. Comme ta question concerne un problème un peu différent de celui qui a ouvert cette discussion, peux-tu s'il te plait créer une nouvelle discussion sur le forum, en mettant un titre du genre "Faire fonctionner PrestaShop 1.4.1 avec PHP 7.2 ??"

Share this post


Link to post
Share on other sites

j avais un prestashop version 1.6.1.23 en ligne depuis presque 3 ans chez 1&1

j'ai vu dans plusieurs forum que ma version etait compatible avevc php 7.1.

j ai donc changer la version site en erreur je suis revenu a la version php 5.6 proposer par 1&1 et plus rien ne fonctionne j avais sauvegarde de on site et ma base de registre fichier sql.

ayant tout perdu et quand je vois toutes les personnes qui galere avec mise a jour prestashop .

si quelqun a une solution a me proposer. merci

Share this post


Link to post
Share on other sites
34 minutes ago, hary59240 said:

j avais un prestashop version 1.6.1.23 en ligne depuis presque 3 ans chez 1&1

j'ai vu dans plusieurs forum que ma version etait compatible avevc php 7.1.

j ai donc changer la version site en erreur je suis revenu a la version php 5.6 proposer par 1&1 et plus rien ne fonctionne j avais sauvegarde de on site et ma base de registre fichier sql.

ayant tout perdu et quand je vois toutes les personnes qui galere avec mise a jour prestashop .

si quelqun a une solution a me proposer. merci

Vous avez une version PrestaShop 1.6.1.23, vous avez changer la version PHP de votre hébergement pour utiliser PHP 7.1 et vous obtenez des erreurs ? Lesquelles ?

La version 1.6.1.23 est bien compatible avec PHP 7.1 en revanche vos modules ne le sont probablement pas...

Share this post


Link to post
Share on other sites
il y a 42 minutes, hary59240 a dit :

j avais un prestashop version 1.6.1.23 en ligne depuis presque 3 ans chez 1&1

j'ai vu dans plusieurs forum que ma version etait compatible avevc php 7.1.

j ai donc changer la version site en erreur je suis revenu a la version php 5.6 proposer par 1&1 et plus rien ne fonctionne j avais sauvegarde de on site et ma base de registre fichier sql.

ayant tout perdu et quand je vois toutes les personnes qui galere avec mise a jour prestashop .

si quelqun a une solution a me proposer. merci

Si le passage de php7.1 à php5.6 bloque votre site c'est soit un bug de cache soit un soucis d'hébergement.

Il n'y a pas de raison que cela ne fonctionne pas.

Pour les soucis de php7.1 encore faudrait il connaitre l'erreur retourné.

Perso je quitterais rapidement cet hébergeur qui a beaucoup de pratiques commerciales douteuses.

Share this post


Link to post
Share on other sites

C'est souvent un souci de modules ou de "bidouille" dans le core. Certains modules, notamment un peu vieux, sont conçus pour PHP 5.6 seulement. 

Pensez à vérifier que tout est bien à jour, pas que le core. Et effectivement ça peut valoir le coup de vider le cache.

D'autre part, une bonne pratique avant de faire ce genre de manipulation sur une boutique en production, c'est de prendre le temps de tester sur une copie de test (par exemple, sur un sous domaine avec les mêmes plugins, le même catalogue, etc.). Pareil pour faire une mise à jour de Prestashop, d'ailleurs 🙂

Et bien sûr de sauvegarder la base de données, et les fichiers.

Share this post


Link to post
Share on other sites
On 4/3/2019 at 2:08 PM, Janett said:

Vous avez une version PrestaShop 1.6.1.23, vous avez changer la version PHP de votre hébergement pour utiliser PHP 7.1 et vous obtenez des erreurs ? Lesquelles ?

La version 1.6.1.23 est bien compatible avec PHP 7.1 en revanche vos modules ne le sont probablement pas...

comment je peut savoir si un ou plusieurs modules ne sont aps compatible php 7.1 . comment je peut faire car mon site ne s affiche plus du tout

 

Share this post


Link to post
Share on other sites

Là c'est plus compliqué car généralement l'information n'est pas disponible.

Vous pouvez demander aux développeurs des modules concernés si vous les avez acheté sur Addons ou si vous êtes suffisament à l'aise, vous pouvez regarder les logs de votre serveur et corriger vous même le code incompatible.

En général, les modules fournis par PrestaShop sont compatibles dans leur version la plus récente, mais pas tous...

Bref changer sa version de PHP ne doit être fait qu'en cas de nécessité, PHP 5.6 fonctionne encore très bien

Share this post


Link to post
Share on other sites

le mieux est de dupliquer sa boutique sur un hébergement similaire (sous-domaine, autre répertoire) pour ne pas utiliser celle en production pour tester. et ensuite, sur la copie, il faut désactiver les modules, changer la version de PHP, puis de les remettre un par un. Attention, ça peut aussi être la faute du thème s'il inclut des fonctionnalités issues de modules.

Share this post


Link to post
Share on other sites

merci de votre aide mais je me retrouve avec sauvegarde prestashop et base de donnée.

mais j ai choisi de tout perdre et passer a wordpress largement mieux meme niveau mise a jour prestashop devien du n importe quoi

 

  • Haha 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More