Jump to content
sorinsxtj

aviz de insotire si factura

Recommended Posts

Buna ziua , folosesc versiunea 1.7.4.2 . Toate bune si frumoase. De facturat nu folosesc autofactura din Prestashop. doar avizul de insotire. Dintr-o data, fara nici o modificare, am vazut ca nu se mai genereaza automat avizele. Am activat facturile si am plasat o comanda . Nici facturile nu mai sunt generate. 

AM incercat sa clear cash  , nimic. am activat modul de depanare sa vad ceva erori . nimic. probabil vreun fisier  a luat-o razna. Dar care?

  Ma poate ajuta careva?

Share this post


Link to post
Share on other sites

salut ,

Mergi pentru inceput BO > Parametri magazin > setari comanda > stadii . Verifica acolo pentru stadiul in care se afla comanda daca ai activat sau nu generarea la ceea ce ai nevoie ( factura , aviz , etc ) 

 

Share this post


Link to post
Share on other sites

Adrian salut ,

am verificat este la fel ca la inceput. tot pare OK. ( 1.jpg)

ce pot zice este ca , factura si delivery note sunt gri dar pot accesa butonul tiparire unde arata ca in 2.jpg. 

am copiat dintr-un backup mai vechi directorul PDF , si PDF.php.  Nimic nu s-a schimbat.  Mai incerc sa copii din nou  /Classes sau in utlima instanta ultimul backup facut (ceeea ce inseamna sa reiau de la capat o gramada de munca)

am mai citit undeva despre o problema similara  in versiune 1.5 . era legat de sigla.png.  

habar nu am unde sa ma indrept. totul functiona si nu a fost instalat nimic nou. acum nope. :(1.thumb.jpg.08602bcd9649693d1783d0bc9f7c296b.jpg2.thumb.jpg.cd27ef3d7de65564f255b0ba19668205.jpg

Share this post


Link to post
Share on other sites

Salut, ai incercat sa schimbi stadiul ( statusul comenzii ) din comanda sa vexi daca se genereaza ? 

Din "In procesare " in " Expediat " sau sa activezi si dezactivezi bifa din stadii , si sau sa creezi un alt stadiu cu bifa activata la aviz de livrare ? 

Nu stiu , o sa ma uit sa vad poate imi vine vre-o idee dar cred totusi ca este ceva banal , din setari ... 

 

Share this post


Link to post
Share on other sites

:( nimic.  nu se genereaza nici un  PDF.

ce am mai incercat pana acuma: am recopiat Invoice .TPL din tema ,  directorul TCPDF din Vendors ,  si directoul pdf din Classes. 

am schimbat statusul comenzii  in diferite stadii , am creat un nou stadiu.

 sa incerc sa actualizez oare la versiunea 1.7.5 ?

 

Edited by sorinsxtj (see edit history)

Share this post


Link to post
Share on other sites

Victorie oarecum. Am incercat sa fac update la versiunea 1.7.5.0 ( 1 click nu a mers de la inceput, a trebuit sa schimb ceva permisiuni la fisiere bla bla). Dar am facut un backup la fisiere si baza de date inainte . Dupa update , site-ul crapa la orice click, in BO aveam acces doar la cateva meniuri restu;l eroare 500. DIn disperare si neputinta doar am copiat  inapoi fisierele din backup .

Totul a revenit la versiunea 1.7.4.2 si surpiza:  PDF-urile se genereaza acum normal parca nimic nu s-a intamplat.

Imi pare rau , ca nu am gasit  problema , dar is bucuros ca merge.

Cred ca vreun fisier o fi fost corupt sau modificat fara  stirea mea. care , nu pot sa fa zic. Deci morala , backup permanent.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More