Jump to content
purepixels

1.7.5 - Product position within category not working

Recommended Posts

Hello all,

I've tried to find a solution on this forum everywhere, but I can't find anyone with the same problem or clearly described as the same problem. If others have written about is, perhaps we can merge the topics.. 

I have a Prestashop 1.7.5 (updated from 1.6 few months back), in which my client is working. All fine, until we decided to change "Pagination - Default order by" from 'Alphabetical' to 'Position within category' (Shop parameters > Product Settings). We want to reorder the products within their category, but somehow that gives problems with saving the new order. After filtering a category, the option to Reorder appears in the product table column 'Position'. When activating that, the button changes to a grey version Save & Refresh and drag-n-drop ordering of products is possible. After dragging one or a few products, the button is activated in blue color, indicating it can be clicked, but with doing this the new order is not being saved. And also, the option to Save & Refresh keeps being active and doesn't disappear anymore. Even logging in with a different browser (with no history to that website ever) this option is still activated and I can't get it deactivated anymore. 

The strange thing is, it did work for 1 category yesterday. But now, somehow, it stopped working and I can't figure out why. Error logs are not present. Debug mode doesn't give me directions. Nothing obviously wrong. 

Is there any solution for this problem? While searching for the correct English text in the demo.prestashop.com, I noticed that the feature is also not working and the same problem occurs there. 

A solution would be highly appreciated by me and my client. 🙂

Thanks for any help! 

Bas

PrestaShop Demo.png

Edited by purepixels (see edit history)

Share this post


Link to post
Share on other sites

Up i have the same problem

 

The reorder is working on the Home Category with all products (http://mysite.com/2-xxx) but when i go on a specific category (example http://mysite.com/10-my-category) the products that I put on the top is at the bottom

I tried to clear the cache /var/cache/*
I restarted memcached, apache but nothing helps

Share this post


Link to post
Share on other sites

This problem solved itself for me somehow. I think it had to do with multiple users were logged in and trying the same thing at the same time. But I'm not sure about that. Is that something which is possible in your case? Than I would suggest to log out at all locations and start from one location, reset the ordering function or start using it - depending on what the buttons are telling you. 

Share this post


Link to post
Share on other sites

ok. after few minutes of trying to do the same think with the same results i have seen that i have this problem when the checkbox of products isnt selected. when i select it all is fine.

im not a coder to explain what does it mean but it will solve your problem :)

reorder > select box of all the products u wanna move on next step > move > save&refresh > next step :)

Edited by soniqro (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More