Jump to content
Sarrah

Impossible d'afficher le bannière haute de page

Recommended Posts

Bonjour,

je suis sur Prestashop 1.6.1.21, je viens d'installer un nouveau thème.

lors de l'installation de ce thème ce dernier a désactivé le module "Bloc Bannière" .

je l'ai activé manuellement mais cette bannière ne s'affiche pas

avez vous une idée ? merci

ban.thumb.png.19c682a209cae88856675a10151f92e3.png

 

mod.thumb.png.60df15b6c27c1602acf2adaf7e6de041.png

 

Share this post


Link to post
Share on other sites

Bonjour,

 

Il est possible que votre nouveau thème n'ait pas le hook nécessaire dans son code pour que la bannière s'affiche. Certains développeurs de thèmes font cela pour n'utiliser que leurs propres modules.

 

Cordialement,

 

AM

  • Thanks 1

Share this post


Link to post
Share on other sites
il y a une heure, alama a dit :

Bonjour,

Il est possible que votre nouveau thème n'ait pas le hook nécessaire dans son code pour que la bannière s'affiche. Certains développeurs de thèmes font cela pour n'utiliser que leurs propres modules.

Cordialement,

AM

merci pour votre réponse, bon je voudrais savoir si c'est possible d'ajouter le hook manquant ? si oui comment ?

j'ai remarqué que le theme que j'ai acheté contient 5 Option lorsque je choisis la 3ème option le block bannière s'affiche.

est ce que cela peut m'aider à trouver le hook manquant, car je voudrais utiliser l'option 1 ?

opt.thumb.png.66e22c8b50ae286a3ed96b3a84b0114c.png

 

optio4.thumb.png.44f157909ee41182d6f96e97171047df.png

Share this post


Link to post
Share on other sites

Bonjour,

 

Il faut comparer les fichiers du thème  par défaut de Prestashop avec ceux de votre thème actif. Cela devrait se trouver dans le fichier header et voir s'il manque un hook du header dans votre thème installé. Dans mes souvenirs c'est un hook displayBanner. A vérifier dans la partie Position de l'admin qui liste tous les hooks prestashop pour voir où la bannière est greffée.

 

Cdt,

 

AM

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Il y a 1 heure, alama a dit :

Bonjour,

Il faut comparer les fichiers du thème  par défaut de Prestashop avec ceux de votre thème actif. Cela devrait se trouver dans le fichier header et voir s'il manque un hook du header dans votre thème installé. Dans mes souvenirs c'est un hook displayBanner. A vérifier dans la partie Position de l'admin qui liste tous les hooks prestashop pour voir où la bannière est greffée.

Cdt,

AM

 

 

Merciii infiniment  ..

c'est vrai, dans le fichier header l'admin traduit le code de la bannière en commentaire le voici :

header.png.1c35ac3df0304a7cc9ca4c9ed7caefc3.png

j'ai enlevé <!--  --> et ça fonctionne bien, merciiiiiiiiiiiiiiiiiiiiiii ❤️

/*après 10 minutes s’essaye*/

j'ai constaté que l'admin a enlevé ce hook car il cause des problèmes, je pense qu'il a un conflis avec le module popup de newslettre, bon je vais chercher comment le résoudre si non c'est pas grave ça ne mérite pas tout ce perte de temps :)

merciiiiii de tt façon ❤️

Edited by Sarrah (see edit history)

Share this post


Link to post
Share on other sites

Ok, c'est peut-être un problème de conflit javascript avec le popup.

Quoiqu'il en soit, bonne continuation.

AM

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More