Jump to content

Recommended Posts

Bonjour, 

Je possède deux boutiques sur la même installation Prestashop 1.6.1.14 (multi-boutique): un B2C et un B2B. L'url principale est celle du B2C (de la forme: https://my-shop.com/

Lorsque je souhaite accéder à l'API cela fonctionne pour le B2C cependant lorsque je fais de même pour mon site B2B, l'APi ne semble pas fonctionner. Une redirection a lieu car il faut obligatoirement s'authentifier afin de parcourir le site. J'utilise le module suivant: https://addons.prestashop.com/en/b2b/17359-private-shop-module-for-b2b-business.html 

J'ai essayé de le désactiver mais rien n'y fait, lorsque j'entre l'url suivante: par exemple: https://b2b-my-shop.com/api/ et bien le site ne me demande pas de clé, n'affiche rien et se redirige vers la page d'accueil contrairement à l'adresse du B2C.

Edited by Mako35 (see edit history)

Share this post


Link to post
Share on other sites

Il faut apprendre à configurer les protections correctement et mettre les règles adaptées

Share this post


Link to post
Share on other sites

ce serait plutot coté .htaccess, mais ne connaissant pas le code de ton addons ...

Mais tu as bien créer une clé API dans le contexte multishop?

Share this post


Link to post
Share on other sites

Dans le .htaccess à la racine du site, les règles de redirection sont exactement les mêmes pour mes deux shops. 

Oui, la clé API est cochée pour les deux sites et bien activée. 

J'ai contacté le développeur du module en attendant de trouver une solution.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More