Jump to content
Dan

[Résolu] Installation de Prestashop 1.6.1 impossible

Recommended Posts

Bonsoir à tous,

Depuis hier matin je suis bloqué sur une problématique bien relou ^^.

J'ai essayé d'installer une quinzaine de fois Prestashop 1.6.1 (de la .4 à la .18), j'ai toujours la même erreur.

Ça bloque à 23% et c'est écrit

23%
  1. Création du fichier settings.inc
  2. Création des tables de la base
  3. Création de la boutique par défaut et des langues

Une erreur est survenue durant l'installation...

Vous pouvez utiliser les liens à gauche pour revenir aux étapes précédentes, ou redémarrer l'installation en cliquant ici.

Je ne comprends pas ce qu'il se passe, j'ai déjà installé plusieurs Prestas, je n'ai jamais eu ce soucis.

Pour info j'ai pris, comme souvent, un serveur mutualisé chez OVH avec une version de PHP 7.2 et une version de MySQL 5.6.

Si quelqu'un peut me venir en aide ce serait sympa.

À très vite :)

Share this post


Link to post
Share on other sites
7 hours ago, Dan said:

Pour info j'ai pris, comme souvent, un serveur mutualisé chez OVH avec une version de PHP 7.2 et une version de MySQL 5.6

Pas dans cet univers alors

Share this post


Link to post
Share on other sites

@Eolia

Oui, tu as proclamé ce mantra assez de fois maintenant. C'est vrai ce que tu dis. C'est aussi embarrassant pour Prestashop. Donc, tu peux nous épargner les lettres géantes, aussi bien que je le comprends.  Il serait peut-être plus utile d'apporter tes connaissances sous forme de suggestions positives. 

Voici les modifications d'un Prestashop standard 1.6 : Prestashop 1.6 adapté à PHP 7.2.zip
Cette adaptation fait toujours défaut pour les personnes qui utilisent la fonction de webservice : https://www.prestashop.com/forums/topic/954013-erreur-class-rijndael-not-found-et-passage-à-php72/?do=findComment&comment=3051696

Share this post


Link to post
Share on other sites

@eleazar  Apparemment ils ne lisent pas le forum alors...

A ce que je lis il veut installer une nouvelle boutique. La 1.6.1.23 est compatible PHP 7.1, il lui suffit donc de modifier sa version PHP chez OVH.

PHP 7.2 est beaucoup trop restrictif et les anciens warnings / notices deviennent des fatals. Certaines fonctions deprecated deviennent interdites également. Nombreux modules sont complètement incompatibles alors mettre des bouts de scotch en attendant n'est pas vraiment une solution.

Edited by Eolia (see edit history)

Share this post


Link to post
Share on other sites
9 minutes ago, eleazar  said:

C'est aussi embarrassant pour Prestashop.

Oui bien sûr, PHP8 est annoncé pour Septembre 2021, comment ça le code n'est pas compatible ?

  • Like 1

Share this post


Link to post
Share on other sites
vor 8 Minuten schrieb Eolia:

A ce que je lis il veut installer une nouvelle boutique. La 1.6.1.23 est compatible PHP 7.1, il lui suffit donc de modifier sa version PHP chez OVH.

Je ne suis pas en faveur de telles recommandations à court terme. Parce que le support de sécurité pour la version 7.1 se termine également en décembre de cette année.

Share this post


Link to post
Share on other sites

Je ne comprends pas cette philosophie spécifique à l'univers informatique.

Pourquoi un ouvrage construit selon un cahier des charges serait-il le plus susceptible de s'écrouler:

  - dans l'industrie/la construction: Si on sort du domaine prévu

 - dans l'informatique: Si la cimenterie après construction change son procédé de fabrication

Share this post


Link to post
Share on other sites
il y a 6 minutes, eleazar  a dit :

Je ne suis pas en faveur de telles recommandations à court terme. Parce que le support de sécurité pour la version 7.1 se termine également en décembre de cette année.

Peux-tu me citer une faille exploitée sur un Prestashop avec une version PHP 5.6 stp ? 

Share this post


Link to post
Share on other sites
il y a 48 minutes, doekia a dit :

Pas dans cet univers alors

Je me suis mal exprimé, j'utilise souvent des hébergements mutualisés chez OVH.

En ce qui concerne la version PHP, je n'y touchais pas ^^ Navré.

Share this post


Link to post
Share on other sites
9 hours ago, Eolia said:

AUCUNE VERSION PRESTASHOP N'EST COMPATIBLE PHP 7.2 ! (Même pas la 1.7)

Prestashop 1.6 accepte PHP7 (Maxi 7.1) à partir de la 1.6.1.18 uniquement

Navré de ne l'avoir pas su plus tôt, j'ai cherché sur le forum pourtant mais je n'ai pas trouvé.

J'ai du mal chercher.

Merci encore à vous tous pour vos réponses, ÇA MARCHE !

Share this post


Link to post
Share on other sites

Bon, il va falloir le crier haut et fort sans pour autant le mettre en gros:

Quote

PrestaShop 1.7.5.0 est compatible PHP 7.2.

Les développeurs travaillent sur PHP 7.2 pour la 1.7.5.x et la branche develop

Merci de bien vouloir faire attention à ne pas mettre en erreur les utilisateurs.

Pour la précision:

  • PrestaShop 1.6 est compatible PHP 7.1 à partir de la 1.6.1.18 d'après la release note.
  • Une réflexion est en cours pour voir comment supporter PHP 7.3 à terme, cela implique de mettre à jour beaucoup de librairies.
Edited by ttoine
typo (see edit history)

Share this post


Link to post
Share on other sites

Et pour ton problème, sur les mutualisés d'OVH il est possible de choisir sa version de PHP, soit depuis l'espace de configuration, soit en éditant un fichier de config sur le serveur.

Share this post


Link to post
Share on other sites
il y a 42 minutes, ttoine a dit :

Bon, il va falloir le crier haut et fort sans pour autant le mettre en gros:

Merci de bien vouloir faire attention à ne pas mettre en erreur les utilisateurs.

Pour la précision:

  • PrestaShop 1.6 est compatible PHP 7.1 à partir de la 1.6.1.18 d'après la release note.
  • Une réflexion est en cours pour voir comment supporter PHP 7.3 à terme, cela implique de mettre à jour beaucoup de librairies.

C'est bien, amusez-vous à mettre des points d'avertissement plutôt que d’être honnêtes et dire que mes propos sont mensongers.

Prestashop avait déjà annoncé la compatibilité PHP 1.7 depuis la 1.6.1.4 (c'est dans le changelog) ce qui était loin d'être le cas.

Pour php 7.2 c'est également faux et même si les fonctions principales passent il en reste encore.

Vous pouvez donc jouer la censure ça ne changera rien à mon expérience de tests.

C'est comme annoncer la 1.7 comme stable depuis 2 ans et supérieure à la 1.6 (lancement en janvier 2017 quand même) alors que vous avez fini par reconnaitre qu'elle ne devrait l'être véritablement qu'à partir de juin 2019.

Vous êtes dans la théorie, je suis dans la pratique, ce sont 2 mondes complètement différents.

Je n'ai ni injurié, ni insulté qui que ce soit mais dire la vérité pour éviter les plantages vous déplait et vous sanctionnez. Parfait, continuez comme ça, rien ne change chez Prestashop en fait...

Edited by Eolia
typo (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, Eolia said:

Peux-tu me citer une faille exploitée sur un Prestashop avec une version PHP 5.6 stp ? 

Encore cet argument ... je suis désolé mais je ne peux pas m'empêcher de penser à quelqu'un qui conduirait sans ceinture de sécurité pendant des années, et dirait autour de lui "je n'ai jamais eu d'accident, par conséquent il est inutile d'avoir une ceinture de sécurité". Je sais que vous n'aimez pas cette métaphore mais je la trouve justifiée.

Voici quelques articles qui expliquent pourquoi est important de ne pas rester sur php5.6, sur prestashop comme sur n'importe quel CMS ou n'importe quelle application php en fait:
https://dev.to/david_j_eddy/php-5-end-of-life-is-upon-us-why-you-should-care-3gpk
https://kinsta.com/blog/php-versions/
https://www.liquidweb.com/kb/upgrade_php/
https://www.wordfence.com/blog/2018/10/php5-dangerous/

Et même wordpress, qui pourtant a toujours supporté des versions trèèèèès vieilles de php, va arrêter de supporter php5 d'ici la fin 2019: 


S'il vous plait, il y a des gens qui vous lisent, et vous êtes clairement compétent: vous allez pas rester sourd devant tous ces warnings rouges qui clignotent, si ;) ?

Share this post


Link to post
Share on other sites

Je ne suis pas contre l'évolution et je migre des clients 1.6 vers php 7 mais j'adapte chaque version, pas le choix parce que Prestashop n'a pas proposé d'outil de migration. La seule réponse est de mettre à jour sa version Prestashop, et là on entre dans un débat houleux donc je préfère m'abstenir.

D'autre part, métaphore ou pas, agiter des drapeaux rouges devant les néophytes n'est pas forcément la bonne solution non plus.

A chacun de trouver le juste milieu suivant ses besoins/fonctionnalités métier.

Share this post


Link to post
Share on other sites

@Eolia Le warning que tu as reçu est pour l'usage des très grands caractères et pour avoir dit qu'aucune version de PrestaShop ne fonctionne avec PHP 7.2, ce qui est une erreur, et n'est donc pas la vérité.

Quote

mes propos sont mensongers

Ils le sont, donc, on est bien d'accord, puisque PHP 7.2 est supporté par PrestaShop 1.7.5. L'as tu seulement installé et essayée, sans à priori ni mauvaise foi ?

Quote

Prestashop avait déjà annoncé la compatibilité PHP 1.7 depuis la 1.6.1.4 (c'est dans le changelog) ce qui était loin d'être le cas.

C'est pour ça que je parlebien de la 1.6.1.18, qui fixe justement plusieurs problèmes de compatibilité, comme indiqué dans son changelog et dans la release note.

Quote

C'est comme annoncer la 1.7 comme stable depuis 2 ans et supérieure à la 1.6 (lancement en janvier 2017 quand même) alors que vous avez fini par reconnaitre qu'elle ne devrait l'être véritablement qu'à partir de juin 2019.

Tu mélanges tout. Le support de la 1.6.1.x est prolongé en mode maintenance jusqu'à mi 2019, parce que beaucoup de marchand l"utilisent encore.

En revanche, la version 1.7.x est effectivement une version de transition vers une autre technologie, qui supporte pour autant une grosse partie de legacy (dont la techno des modules). C'est entre autre pour cette raison que les débuts de la 1.7 ont été un peu hasardeux.  Cependant, la performance et la stabilité est très bonne depuis la 1.7.4 et la 1.7.5. De nombreux marchands et agences sont en production avec des 1.7, y compris en mode performance avec multi serveurs et autoscaling sur le cloud en fonction de la charge, et sont très content de ces versions.

Pour rappel:

  • Le passage de Drupal 7 à Drupal 8 s'est fait en faisant table rase des technos passées, et la communauté a jugé ça encore plus sévèrement. Drupal a du récemment demander aux devs de Drupal 7 de bien vouloir commencer à assurer le support pour PHP 7.x, y compris pour les thèmes et les modules. Et ils ont annoncé que pour Drupal 9, ils allaient faire une migration progressive, comme PrestaShop le fait actuellement.
  • Le passage de Magento 1 à 2 c'est aussi en faisant table rase du passé, beaucoup de marchands vont devoir entièrement refaire leur boutique en ligne.
  • Dans PrestaShop, entre la 1.6 et la 1.7, la structure des données ne change presque pas, et les webservices sont les mêmes. Il n'y a pas besoin de savoir utiliser Symfony pour utiliser la 1.7.x, y compris pour développer des fonctionnalités.

 

 

Share this post


Link to post
Share on other sites

Désolé, @ttoine, mais si tu lis le forum, tu verras le nombre de soucis que les marchands ont avec la 1.7

Share this post


Link to post
Share on other sites
il y a une heure, ttoine a dit :

Tu mélanges tout. Le support de la 1.6.1.x est prolongé en mode maintenance jusqu'à mi 2019, parce que beaucoup de marchand l"utilisent encore.

Bel exemple de langue de bois en fait, tu ne disais pas cela sur le blog:

Citation

image.png.4553a541012356409c9db0a8621ae4d5.png

Source: https://www.prestashop.com/fr/blog/extension-de-la-maintenance-de-prestashop-1-6

Je ne mélange rien, mais je constate en effet que quelle que soit l'équipe le discours reste toujours aussi flou et aléatoire.

Share this post


Link to post
Share on other sites
Quote

mes propos sont mensongers

Quote

 

Ils le sont, donc, on est bien d'accord, puisque PHP 7.2 est supporté par PrestaShop 1.7.5. L'as tu seulement installé et essayée, sans à priori ni

 

 

___

Je peux faire exactement la même chose avec tes propos @ttoine regarde

1 hour ago, ttoine said:

mauvaise foi

Tu admets donc que tu es de mauvaise foi

____

Jusque la 1.7.5, nous ne passions même pas Controller.php  maintenant, avec le plus grand mépris envers un contributeur de 1er ordre tu l'insulte de menteur.

Je comprends donc que non seulement @eolia est un menteur à tes yeux, mais les ordinateurs, https://github.com/grabelle et plein d'autres personnes y compris dans ta propre équipe. https://github.com/PrestaShop/PrestaShop/issues/11840

____

 

@Eolia écrit en gros, gras car justement l'auteur de ce topic semble peu faire cas de sa version de php alors que c'est le coeur du problème et que ce problème est récurrent et remonté à répétition. D'autant que tu sembles "oublier" que l'auteur du topic cible très exactement les version 1.6, et max 1.6.1.18

 

 

Donc @ttoine, offre toi des points de d'avertissement, banni toi également pendant plusieurs semaines car tes propos sont insultants, ton abus de pouvoir est pathétique, et tes attaques sont purement gratuite.

 

 

 

 

Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites
1 hour ago, ksaan said:

Encore cet argument ... je suis désolé mais je ne peux pas m'empêcher de penser à quelqu'un qui conduirait sans ceinture de sécurité pendant des années, et dirait autour de lui "je n'ai jamais eu d'accident, par conséquent il est inutile d'avoir une ceinture de sécurité". Je sais que vous n'aimez pas cette métaphore mais je la trouve justifiée.

Mais tu as conduit pendant des années sans cette ceinture et tu es en train de dire...

Je dois risquer de ne plus savoir conduire cette nouvelle voiture et d'avoir une grave accident car si jamais ils y ont installé de nouvelles ceintures de sécurité je veux être protégé.

Lorsqu'une faille est découverte, tu évalue si tu es impacté et seulement si c'est le cas tu envisages ... ce que tu dois faire

A moins que tu ne veuilles supposer qu'une nouvelle version n'a jamais de nouveaux bugs, ni de problème de régression, ni de patch qu'il faille quelque fois annuler car présentant un nouveau vecteur

Share this post


Link to post
Share on other sites
2 hours ago, doekia said:

Lorsqu'une faille est découverte, tu évalue si tu es impacté et seulement si c'est le cas tu envisages ... ce que tu dois faire

Lorsqu'une faille est découverte sur une version maintenue d'un langage informatique ou d'une application, la solution est généralement simple: appliquer le patch conçu par l'équipe derrière ce langage / cette app.
Lorsqu'une faille est découverte sur une version non maintenue, ben ... y'a pas de patch ^^. Ou peut-être que si: certaines distributions linux vont essayer d'en faire elles-même pour les langages par exemple. Mais bon un "peut-être" c'est pas ce qu'on a de plus robuste et on parle sécurité là, un domaine où 1 erreur peut suffire à compromettre toute l'application.
Et si y'a pas de patch et qu'on est exposé, il va peut-être falloir à ce moment faire ce fameux passage de sa version à une plus récente et maintenue, qui coûte temps, énergie et argent. Choses qu'on a peut-être pas là tout de suite mais qu'il va bien falloir mobiliser parce qu'on est au pied du mur.

Et tout ceci demande du temps pendant lequel vous êtes vulnérable.

En fait upgrade sur une version maintenue = s'éviter de se retrouver au pied du mur.

En plus c'est pas comme si on avait pas été prévenus longtemps à l'avance :) : php7.0 c'est là depuis 2016. php7.1 est released depuis 2017. Si y'a un chevauchement des versions, c'est justement pour fournir une période de transition permettant la migration dans un cadre posé et organisé, et pas en urgence au pied du mur. Perso moi je suis sur php7 depuis mi 2017. Pas trop à l'avance, pas trop en retard. En plein milieu de la période de chevauchement. Je pense pas être un parano de la sécurité, juste suivre les recommandations et les évolutions du langage.

Share this post


Link to post
Share on other sites

On est d'accord ou pas pour admettre que les première versions de 7.0 était de grosses blague coté stabilité et que c'est encore très surfait même sur les dernières releases

http://php.net/ChangeLog-7.php

Et comme une version d'un middleware dépend tant de la couche bas niveau (os) que des extensions (modules). Le plus important est d'avoir un ensemble cohérent.

Donc si tu te cantonnes à debian8 LTS (du 17 juin 2018 jusqu'au 30 juin 2020)

Tu as les paquets intégré/supportés/natifs suivant:

https://packages.debian.org/fr/jessie/php5

 

Sous debian9 LTS  c'est:

https://packages.debian.org/fr/source/stretch/php7.0

 

Il n'existe pas de version debian utilisant 7.2

Il faut passer en testing (buster) pour avoir https://packages.debian.org/fr/source/buster/php7.3

 

 

 

Share this post


Link to post
Share on other sites
15 hours ago, doekia said:

On est d'accord ou pas pour admettre que les première versions de 7.0 était de grosses blague coté stabilité et que c'est encore très surfait même sur les dernières releases

On est d'accord ^^ php7.0 c'était ... mitigé comme résultat. Mais bon je comprends que sur quelque chose de si complexe qu'un langage informatique, la .0 aie des soucis. Il a toujours été clair que la 7.1 serait la première version stable de php7.

N'oublions pas que les mainteneurs php ils sont pas si nombreux ;) leur job est pas facile, aidons-les autant que possible par exemple en participant aux beta.

Share this post


Link to post
Share on other sites
16 hours ago, doekia said:

Donc si tu te cantonnes à debian8 LTS (du 17 juin 2018 jusqu'au 30 juin 2020)

Tu as les paquets intégré/supportés/natifs suivant:

https://packages.debian.org/fr/jessie/php5

Sous debian9 LTS  c'est:

https://packages.debian.org/fr/source/stretch/php7.0

 

Merci pour ces infos, pour ma part je suis chez gandi.net où sont disponibles php7.0, php7.1 et php7.2 (et php7.3 aussi je crois depuis peu)

Share this post


Link to post
Share on other sites
1 hour ago, ksaan said:

N'oublions pas que les mainteneurs php ils sont pas si nombreux ;) leur job est pas facile, aidons-les autant que possible par exemple en participant aux beta.

C'est sûrement là que nos points de vues divergent. Je propose des solutions stable pour mes clients. Je ne suis pas en train de leur faire prendre des risques pour le bien des mainteneurs de tel ou tel solution.

C'est exactement la même raison qui me fait déconseiller PS 1.7

Share this post


Link to post
Share on other sites

Quelle est votre définition d'une solution stable ?

Share this post


Link to post
Share on other sites

Qui tient sur sa base, même en cas de vent important

Share this post


Link to post
Share on other sites

@yama merci de rappeler que les problèmes ont aussi plein d'autres raisons

Share this post


Link to post
Share on other sites

doekia, eolia, en fait, personne ne cherche à remettre en question votre expertise sur les vieilles version de PrestaShop. Le temps que vous passez sur le forum à aider les autres utilisateurs est remarquable, et j'aimerais bien à terme pouvoir vous proposer d'être modérateur. Pour le moment, ça n'est pas possible: vous êtes trop agressifs quand on est pas d'accord avec vous, et il faut aussi accepter d'aider les personnes qui installent des 1.7.5, qui utilisent PHP 7.2, etc., car ils va y en avoir de plus en plus.

Je respecte tout à fait vos positions, mais je ne peux pas non plus vous laisser écrire sur le forum des choses qui ne sont pas vraies. Et même Eleazar, plus haut, fait remarquer que le message en grosses lettres, c'était abusé, et pour rappel elle est modératrice.

Bref. J'aimerais bien qu'on trouve une solution pour calmer le jeu et avoir des débats constructifs. S'il faut pour cela que je vienne vous rencontrer chez vous pour discuter "in real life" c'est avec plaisir que je ferai les déplacements nécessaires.

Share this post


Link to post
Share on other sites

:D pirouette, cacahuète

En effet les raison peuvent venir d'autre chose que Prestashop, ici c'est PHP7.2, mais ... on le dire fort c'est se faire traiter de menteur.

 

Share this post


Link to post
Share on other sites

Agressif? qui a traité qui de menteur, alors que gratter 2 bug report démontrent que c'est une pure vérité ?

A moins que chez toi le qualificatif agressif s'applique a toute personne qui n'est pas de ton avis... et dans ce cas, attention, le monde est plein de gens agressif. Tu va avoir une vie bien triste

Share this post


Link to post
Share on other sites

PHP 7.2 + PrestaShop 1.6 ça ne marche pas.

mais dire qu'aucune version de PrestaShop ne fonctionne avec PHP 7.2 comme Eolia l'a fait, c'est une erreur: la 1.7.5 est conçue pour. Au besoin je peux te mettre en privé une copie du message modéré.

Share this post


Link to post
Share on other sites

Vu que le sujet est résolu, et pour éviter que ça reparte dans une longue discussion stérile, le topic est clos.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More