Jump to content
Manu18

PROBLEMA IMPOSTAZIONE IVA SU TUTTI I PRODOTTI

Recommended Posts

Salve, sono nuovo sul forum e ho cominciato da poco ad utilizzare prestashop, utilizzo la versione 1.7.4.4 è ho riscontrato un problema riguardo l'impostazione dell'iva sui prodotti, impostando nella sezione "tasse" e nella sezione "aliquota iva" IVA IT (22%) e salvando le modifiche con la voce "abilita tasse" attiva quando vado a verificare sui singoli prodotti mi viene riconosciuto il prezzo senza iva e perche rimane selezionato su "nessuna tassa", l'unico modo per cambiarla e farlo manualmente quindi cambiare "nessuna tassa" con "IVA IT (22%)" il problema è che i prodotti sono troppi visto che sono stati caricati da file csv quindi cambiarli manualmente non è la miglior cosa, perche abilitando in ""tasse" e "aliquota iva" la voce  "IVA IT (22%)" l'iva sui prodotti non cambia? sbaglio qualcosa io o vanno per forza messi manualmente?

Share this post


Link to post
Share on other sites

Ciao, credo ci siano 2 soluzioni in merito:

1) Eseguire una query sul database. 

2) Acquistare un modulo per l'aggiornamento massimo dei prezzi

hai accesso al db?

Share this post


Link to post
Share on other sites

Ciao, si, posso accedere al dB con mysql, come posso fare per risolvere il problema? 

Share this post


Link to post
Share on other sites

Queste le 2 query da eseguire:

  • UPDATE `ps_product_shop` SET `id_tax_rules_group` = '1' ;
  • UPDATE `ps_product` SET `id_tax_rules_group` = '1' ;

Devi sostituire il valore 1 con l'id che identifica la tua Aliquota Iva (Tasse/Aliquote Iva)

 

NB Prima di procedere esegui un backup delle 2 tabelle.

Share this post


Link to post
Share on other sites

Ho provato ad eseguire entrambe le query sostituendo il valore 1 con l'id dell'aliquota Iva al 22% che ho importato con il pacchetto localizzazione Italia di prestashop ma non ha funzionato rimane impostato su "nessuna tassa" allora ho provato ad eliminare il pacchetto scaricato da prestashop e a creare una nuova tassa e una nuova aliquota manualmente a cui è stato assegnato da prestashop un altro ID ma anche provando a sostituire questo nuovo valore il risultato è sempre lo stesso, il messaggio restituito dal db dopo aver eseguito le query è

"UPDATE`ps_product_shop` SET `id_tax_rules_group` = '77' ;# 14888 righe modificate.

 

UPDATE `ps_product` SET `id_tax_rules_group` = '77'# 14888 righe modificate. " 

 

Ma il problema non viene risolto, sbaglio qualcosa o c'è un altro modo? 

 

Edited by Manu18 (see edit history)

Share this post


Link to post
Share on other sites

Ho provato ad eseguire entrambe le query sostituendo il valore 1 con l'id dell'aliquota Iva al 22% che ho importato con il pacchetto localizzazione Italia di prestashop ma non ha funzionato rimane impostato su "nessuna tassa" allora ho provato ad eliminare il pacchetto scaricato da prestashop e a creare una nuova tassa e una nuova aliquota manualmente a cui è stato assegnato da prestashop un altro ID ma anche provando a sostituire questo nuovo valore il risultato è sempre lo stesso, il messaggio restituito dal db dopo aver eseguito le query è

"UPDATE`ps_product_shop` SET `id_tax_rules_group` = '77' ;# 14888 righe modificate.

 

UPDATE `ps_product` SET `id_tax_rules_group` = '77'# 14888 righe modificate. " 

 

Ma il problema non viene risolto, sbaglio qualcosa o c'è un altro modo? 

Share this post


Link to post
Share on other sites

Hai detto che manualmente, su modifica singolo prodotto, funziona. Prova a modificare manualmente un prodotto e poi controlla su db quale valore è assegnato a 'id_tax_rules_group'

Share this post


Link to post
Share on other sites

ho provato adesso a modificare un singolo prodotto ma il risultato è peggio di prima, quando cambio manualmente la tassa e salvo, le modifiche non vengono aggiornate e rimane su "nessuna tassa" ho notato però che non viene salvata neanche qualsiasi altra modifica al prodotto ad esempio provando a cambiare oltre alla tassa anche la categoria di appartenenza e salvando il tutto all'aggiornamento della pagina le modifiche non vengono salvate, allego lo stesso sue immagini del valore assegnato in questo momento a 'id_tax_rules_group'

ps_product :

ps_product.thumb.JPG.7e7fcef9537b2a6e6b3169d409df6e31.JPG 

 

ps_product_shop:ps_product_shop.thumb.JPG.f61be685ccd38e6da0b30212b3ee900a.JPG

Share this post


Link to post
Share on other sites

Ciao Manu, le immagini riguardano la struttura della tabella... quelle richieste sono relative ai dati presenti nella tabella con filtro id_product relativo al prodotto modificato.In questo modo vediamo quale id_tax_rules_group viene applicato.

Es.

qhs5dc.jpg

 

Cmq se adesso non funziona il salvataggio prova a ripristinare il backup (come consigliato di fare) delle tabelle modificate. Hai effettuato qualche aggiornamento di Prestashop?

Share this post


Link to post
Share on other sites

Ciao, si hai ragione adesso allego l'immagine corretta, per entrambe le tabelle ps_product e ps_product_shop i valori di id_tax_rules_group sono gli stessi cioè '82' che corrisponde all'ID impostato da prestashop per l'aliquota iva,allego immagine sia del db che della sezione "aliquote iva" di prestashop.

PS_PRODUCT

ps_product_valori.thumb.JPG.6c6a040de5b46eab0df56f60ac8abdaa.JPG

 

prestashop

aliquote_ps_screen.JPG.4896c42ce1f775c066c29080911ffdca.JPG

 

 

per quanto riguarda l'aggiornamento non ne ho mai fatti, ho iniziato direttamente dalla 1.7.4.4 anche perchè ci sarebbe disponibile la versione 1.7.5.0 ma scaricando il modulo "1-click upgrade" quando cerco di configurarlo non si apre nemmeno continua a caricare e rimane bloccato quindi ho lasciato stare l'aggiornamento e sto continuando con questo ma il modulo non apre proprio la schermata di configurazione quindi non è proprio iniziato,dubito che sia questo il problema anche se non mi spiego come mai non funzioni neanche quello.

Share this post


Link to post
Share on other sites

Buongiorno,

riprendo questo post perchè anche io ho lo stesso problema in relazione alla fatturazione elettronica che non mi rileva l'aliquota iva applicata.

Nel singolo prodotto è impostata iva al 22% ma nella fattura emessa dal sistema non compare e nemmeno in quella elettronica, dove invece è necessaria, altrimenti il sistema non la riconosce.

Qualche suggerimento?
Grazie anticipatamente

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More