Jump to content
JoernSchmidt

Leo Theme despacito

Recommended Posts

Hallo

Ich habe Prestashop 1.7.5 bei 1&1 installiert und das normale Theme in Leo Depacito Theme geändert. Jetzt sehe ich nur noch einen weißen Bildschirm anstelle des bisherigen Demo-Shops. Was muss ich tun, um die Installation des neuen Themas abzuschließen? Muss ich eine IP Adresse oder ID für das Theme hinzufügen?

Danke für eure Hilfe

Jörn

Share this post


Link to post
Share on other sites

Ich schätze, man muss einfach warten, bis dieses Template von den Theme-Entwicklern an 1.7.5 angepasst wurde. Bei einer Software wie Prestashop 1.7, die sich noch in der Entwicklung befindet, ist das Risiko, dass Module oder Templates nicht vollständig mit der neuesten Version kompatibel sind, sehr hoch. Wahrscheinlich ist es nur eine kleine Sache - aber das Problem ist, sie zu finden!

Wechsele mal in den Debug-Modus, damit anstelle der weißen Seite eine Fehlermeldung angezeigt wird.

Share this post


Link to post
Share on other sites

Wunder dich nicht, dass jetzt alles auf Deutsch ist. Wir haben den Topic aus dem amerikanischen Forum hierher verschoben.

Die Fehlermeldungen kommen allesamt aus dem PrestaShop-Core, weil das Template aktuell nicht mit 1.7.5 kompatibel ist, sondern aus gutem Grund nur bis max. 1.7.4.2 freigegeben ist. Das kannst du hier nachlesen: https://addons.prestashop.com/de/themen-getranke-tabak/29562-leo-despacito.html

Wie ich schon oben sagte, muss man so eine Einschränkung bei einer Neuentwicklung wie PrestaShop 1.7, an der immer noch gebastelt wird, sehr ernst nehmen. Es ist sogar gut möglich, dass schon die nächste Version 1.8, die zum Jahresende geplant, aber vermutlich erst 2020 rauskommen wird, ganz auf die zusätzliche Programmiersprache Smarty verzichtet. Denn das sind noch Teile aus dem alten PrestaShop bis Version 1.6.1.23. Mittelfristig wird das ganz sicher der Fall sein. Spätestens dann kannst du, wenn du weiterhin updatest, mit diesem Template nichts mehr anfangen. Es nutzt bereits jetzt Smarty-Aufrufe, die eigentlich schon in 1.7.4.2 als veraltet angesehen wurden.

Share this post


Link to post
Share on other sites

Herzlichen Dank, dann werde ich mir wohl ein neues Template suchen. Was ist Deine Empfehlung, auf was muss ich achten? Gern würde ich ein Template nehmen, welches erst einmal eine Weile den Updates standhält.

Viele Grüsse

Jörn

Share this post


Link to post
Share on other sites

Tut mir leid, aber bei 1.7 werde ich mich hüten, irgendwelche diesbezüglichen Empfehlungen auszusprechen. Für Prestashop 1.6 gibt es da auch nach wie vor mehr Auswahl - und die  eisten funktionieren auch und bringen z.T. eine Menge nützlicher Module mit wie z.B. Panda oder Transformer von Sunnytoo! Zwar erwecken die meisten Entwickler den Eindruck, ihre Templates seien auch unter 1.7 lauffähig, aber du hast ja jetzt selbst gemerkt, dass man darauf nicht vertrauen kann, solange bei 1.7 noch alles im Fluss ist und man gar nicht so recht weiß,  wohin die Reise noch geht. Du kannst im Moment wirklich nicht sicher sein, dass es nach dem nächsten Upgrade noch kompatibel ist, musst aber andererseits wegen der vielen unerledigten Bugs oder Entwicklungen jedes Upgrade mitmachen. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More