Jump to content

How to resolve and disable "Check the IP address on the cookie"?


fun_9990
 Share

Recommended Posts

I would like to go to  [ Administration > Preferences > and disable the option "Check the IP address on the cookie" ]


because I have to disable "Check the IP address on the cookie" 


but unfortunately, I'm throwen out from admin panel over and over when I want to do that


How can I change this Setting from "enable" to "disable"? 


I think I can do this from the database within the terminal or change PHP file to do that

please say me How can I do this?

Edited by fun_9990 (see edit history)

Share this post


Link to post
Share on other sites

  • 4 months later...
  • 8 months later...
  • 7 months later...
  • 6 months later...
  • 2 months later...
On 3/10/2021 at 10:12 AM, Lalaru said:

UPDATE ps_configuration SET value = 0 WHERE name='PS_COOKIE_CHECKIP'

I do not have PREFIX_COOKIE_CHECKIP in my prefix_configuration phpmyadmin database file. and I deleted !Configuration::get('PS_COOKIE_CHECKIP')) in classes/cookies.php file and still I am getting logged out of my back office. I did notice when I checked my browsers cookie log my domain with and without www is showing up with numerous cookies. this problem just started when I obtained and linked a cloudflare ssl certificate. I installed prestashop 1.7 via godaddy's  1-click installation cpanel option. I am really stuck, I need some help!

 

Edited by DouglasB16 (see edit history)

Share this post


Link to post
Share on other sites

  • 2 months later...
On 5/23/2021 at 8:22 AM, DouglasB16 said:

I do not have PREFIX_COOKIE_CHECKIP in my prefix_configuration phpmyadmin database file. and I deleted !Configuration::get('PS_COOKIE_CHECKIP')) in classes/cookies.php file and still I am getting logged out of my back office. I did notice when I checked my browsers cookie log my domain with and without www is showing up with numerous cookies. this problem just started when I obtained and linked a cloudflare ssl certificate. I installed prestashop 1.7 via godaddy's  1-click installation cpanel option. I am really stuck, I need some help!

 

Yes, absolutely. This problem is caused by Cloudflare. After I applied this solution the problem disappeared immediately!

Quote

UPDATE ps_configuration SET value = 0 WHERE name='PS_COOKIE_CHECKIP'

So it appears that you cannot use the "Check the IP address on the cookie" feature if you are using Cloudflare in "Full SSL" mode.

 

Full SSL mode.jpg

Edited by Alexander Firsov (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More