Jump to content
piske1964

Prestashop 1.6.0.9 and PHP 7.+

Recommended Posts

Hi,

my hostinh company send me a mail that I have to upgrade from PHP 5.6 to PHP7.2.  After changing PHP version on server I received this Errors:

Notice: tempnam(): file created in the system's temporary directory in /srv/www/vhosts/orbithandels.ch/httpdocs/classes/PrestaShopAutoload.php on line 151

Fatal error: Uncaught Error: [] operator not supported for strings in /srv/www/vhosts/orbithandels.ch/httpdocs/classes/db/DbQuery.php:70 Stack trace: #0 /srv/www/vhosts/orbithandels.ch/httpdocs/classes/ObjectModel.php(203): DbQueryCore->from('shop', 'a') #1 /srv/www/vhosts/orbithandels.ch/httpdocs/classes/shop/Shop.php(131): ObjectModelCore->__construct('1', NULL, NULL) #2 /srv/www/vhosts/orbithandels.ch/httpdocs/classes/shop/Shop.php(392): ShopCore->__construct('1') #3 /srv/www/vhosts/orbithandels.ch/httpdocs/config/config.inc.php(97): ShopCore::initialize() #4 /srv/www/vhosts/orbithandels.ch/httpdocs/index.php(27): require('/srv/www/vhosts...') #5 {main} thrown in /srv/www/vhosts/orbithandels.ch/httpdocs/classes/db/DbQuery.php on line 70

 

Is it possible to fix this and keep Prestashop version 1.6.0.9?

Share this post


Link to post
Share on other sites

As for 1.6.0.x  I cannot say much but 1.6.1.x runs without any changes on php 7.0 with some modifications that can be found in the forum (take a look into the German sector) it runs also with php 7.1 and I have heard that it runs with php 7.2 also but not without causing some trouble.

Depending on the modifications of your current shop, third party modules, your programming skills and time you might consider to update to 1.6.1.x and try to get it run on php 7.2 (third party modules are more likely to cause trouble), give PrestaShop 1.7 a chance or take the easiest way and change your hosting. There are many hosting companies that still support php 5.6 and have no aim to stop it soon (Take a look at A2 hosting for example. The have a server location in the Netherlands)

Share this post


Link to post
Share on other sites

I have upgraded from 1.6.0.9 to 1.6.1.23 without any issues and also just upgraded from PHP 5.6 to PHP 7.2 and so far it's all working well.

I suggest that you setup a testing domain that is an exact copy of your existing Prestashop environment and upgrade it to see what issues, if any, you have.

 

Good luck.

Cheers

Greg

 

Share this post


Link to post
Share on other sites
On 1/22/2019 at 7:20 PM, lateral said:

I have upgraded from 1.6.0.9 to 1.6.1.23 without any issues and also just upgraded from PHP 5.6 to PHP 7.2 and so far it's all working well.

I suggest that you setup a testing domain that is an exact copy of your existing Prestashop environment and upgrade it to see what issues, if any, you have.

how do you do that ? did you use 1 click upgrade module ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More