Jump to content

HTTP ERROR 500


Aslak
 Share

Recommended Posts

Salve a tutti da un paio di giorni la back-end del mio sito mi da errore 500 invece la front-end viene visualizzata correttamente.

Mi spiego meglio: 

la mia versione di prestashop è molto vecchia e con 1and1 c'è stato l'aggiornamento del php dal 5.6 al 7.

Già a novembre ho provato a fare l'aggiornamento di prestashop ma anche in qual caso mi dava errore 500 che ho risolto poi con il backup tramite ftp del sito (e comunque l'aggiornamento non me lo ha fatto fare), ora ho provato la stessa procedura ma il problema non si risolve 

un altra cosa che ho provato e a creare un nuovo database e a collegare la vecchia versione con il nuovo database (con php aggiornato) a questo punto mi mostrava finalmente il login della back-end ma non mi faceva accedere dicendomi "account dipendente inesistente o password errata". 

Ho provato a cambiare password sia con la procedura guidata sia direttamente da ps_emplye ma comunque niente 

ho anche fatto la pulizia dei cache del browser come consigliato in diversi articoli e ho cambiato i permessi dei file e delle cartelle in 644 e 755 ma niente

per ora la mia versione on line è quella con solo la front-end funzionante e back-end non funzionante (quindi sito vecchio database vecchio).

Spero sappiate aiutarmi perché altrimenti ho perso il lavoro degli ultimi 4 anni...

Edited by Aslak (see edit history)

Share this post


Link to post
Share on other sites

17 minuti fa, Gipielle dice:

Chiedi se ti mettono php 5.6, o passi ad un server dedicato in cui puoi scegliere la versione di php

oppure metti mano a tutto il codice per renderlo compatibile, ma credo sia un lavoro eterno.

ok il problema sembra essersi risolto ora se faccio gli aggiornamenti dal back-end(che stavolta dovrebbero funzionare visto che ho anche aggiornato i permessi) si aggiorna anche il php? quindi poi non ho problemi a passare alla versione 7? 

la mia versione è 1.6.18 Grazie mille 

Edited by Aslak (see edit history)

Share this post


Link to post
Share on other sites

2 ore fa, Gipielle dice:

No, non si aggiorna php, la versione 1.6.1.18 è compatibile con php 7.1, devi però verificare la compatibilità dei moduli

Ok ma come faccio a verificare la compatibilità dei moduli? A parte aggiornarli tutti esiste un altro metodo? 

Grazie mille

Share this post


Link to post
Share on other sites

Am 21.1.2019 um 12:07 PM schrieb Gipielle:

Le vecchie versioni non sono compatibili con php 7, testato la 1.5.6 

Esatto, ma è possibile personalizzarlo, anche per PHP 7.2.

Un manuale e il download di tutti i file necessari che ho pubblicato qui:

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More