Jump to content
iwebu

Problème sur certains produits Prestashop 1.7

Recommended Posts

Bonjour

Depuis quelques jours, certains produits sont impossible à commander alors que je n'ai rien modifier sur le site.

Très étrange, sur les produits impossible à commander, un bouton "rafraichir" est apparu et ne sert apparemment à rien ! Quelqu'un a-t-il déjà eu ce problème sur un prestashop 1.7 ?!!

image.png.ab892538d57ab2dc5399c9af73f9b192.png

Juste avant ce problème certaines photos secondaires ne s'affichaient plus également, elles ne s'affichent toujours plus, mais le plus important reste quand même de pouvoir ajouter les produits au panier.

 

Merci pour votre aide !

Share this post


Link to post
Share on other sites

Up !

Il s'agit d'un prestashop 1.7.4 qui fonctionnait très bien jusqu'à il y a 4 jours environ. Il est désormais impossible de commander sur le site. Je perds plus de 500€ de commande tous les jours...

Please help !

 

Share this post


Link to post
Share on other sites

Bonjour,

Si vous perdez 500€ par jour, je vous conseille de vite vous diriger vers un pro de prestashop il vous corrigera le problème pour moins de 500€

Il y a plein de freelance sur le forum qui pourront vous faire une prestation. 

Bonne journée.

Share this post


Link to post
Share on other sites

Bonjour

Merci pour cette réponse très constructive ;)

A vrai dire j'essaie de régler le problème sur le site d'un client qui lui perd de l'argent tous les jours ... et je suis moi même freelance mais ne facture pas cette prestation !

Si vous avez des infos je suis preneur, sinon je vous souhaites une bonne journée et encore beaucoup d'excellentes réponses comme celle ci ;)

Merci

Share this post


Link to post
Share on other sites

Donc, si vous êtes un freelance vous devriez avoir un minimum de connaissance, comme par exemple donner l'url d'un produit concerné histoire que l'on puisse comprendre sur pièce le sujet qui est très énigmatique pour le moment.

Et comme le forum n'est là que pour apporter des réponses lorsque les gens compétents pour le faire son disponible, évitez de perdre du temps à ne communiquant pas le minimum vital pour aider.

La version php n'aurait pas changée sur le serveur ?

Share this post


Link to post
Share on other sites

Bonjour,

Désactivez le module commentaire et faites un test.
Vous avez  un probleme de JS lié à un module que vous avez installé ou activé.

PS : si je vous fais gagner 1 jour, je veux bien 10%  de cette journée pour me payer une mousse à moi et mes potes du forum ;)

V++

Atch

 

Edited by Atch (see edit history)
  • Like 3

Share this post


Link to post
Share on other sites

Bonjour

Non aucun changement sur le serveur. Le problème est très étrange et aléatoire selon les produits.

L'url du site est https://poele-pas-cher.com.

Voici un exemple de produit sur lequel l'erreur est visible : https://poele-pas-cher.com/pieces-edilkamin/41-resitance-allumage-edilkamin-264050.html

Impossible de zoomer sur l'image, impossible d'ajouter au panier ... et présence d'un bouton "Rafraichir" qui n'apparaissait pas avant. Et un clic sur ce bouton renvois l'utilisateur sur le panier qui reste vide...

image.png.5ffb49a54fd1233ed13ab752cdbf3f70.png

J'ai un minimum de connaissance mais je ne suis pas un grand utilisateur de Prestashop, du coup je ne m'en occupe pas beaucoup et ne connais pas les bugs éventuels. Je venais surtout ici en espérant que quelqu'un ait déjà rencontré le même problème.

 

Share this post


Link to post
Share on other sites

Le bouton refresh qui apparaît par magie ça pue l'erreur js de loin .... F12

Ce n'est pas moi qui ment dans mes messages, d'un coup ce n'est plus vous donc qui vous dit qu'il y a pas eu de modification ?

 

Share this post


Link to post
Share on other sites
1 minute ago, Atch said:

Bonjour,

Désactivez le module commentaire et faites un test.

PS : si je vous fais gagner 1 jour, je vuex bien 10%  de cette journée pour me payer une mousse à moi et mes potes du forum ;)

V++

Atch

 

Je vais tester ! Avec plaisir pour les 10%, mon client ne serait sans doute pas contre ;)

Share this post


Link to post
Share on other sites
2 minutes ago, P i l o u said:

Ca marche chez moi (ajout au panier et zoom )...

UNWpIeB.jpg

Sur Chrome oui mais pas Firefox :(

Share this post


Link to post
Share on other sites
1 minute ago, P i l o u said:

Ca marche chez moi (ajout au panier et zoom )...

UNWpIeB.jpg

Oui j'ai remarqué que ça marche ... mais une fois seulement. Si vous videz votre panier pour aller acheter le même produit une seconde fois vous devriez constater la même erreur.

Du coup ça viendrait d'un bug du thème ?!!

Share this post


Link to post
Share on other sites

les erreurs sont :

TypeError: $(...).mPageScroll2id is not a function
TypeError: owl.owlCarousel is not a function

plus qu'a chercher et isolé le module qui provoque cela !

Je vois le js commentaire

Atch> TypeError: $(...).mPageScroll2id is not a function
<Atch> TypeError: owl.owlCarousel is not a function

// productcomments
	$(document).on('click','#product_comments_block_extra ul.comments_advices a', function(e){
		$('*[class^="tab-pane"]').removeClass('active');
		$('*[class^="tab-pane"]').removeClass('in');
		$('div#idTab5').addClass('active');
		$('div#idTab5').addClass('in');

		$('ul.nav-tabs a[href^="#"]').removeClass('active');
		$('a[href="#idTab5"]').addClass('active');
	});
	(function(){
		$(window).on("load",function(){
			
			/* Page Scroll to id fn call */
			$("#product_comments_block_extra ul.comments_advices a.reviews ").mPageScroll2id({
				highlightSelector:"#product_comments_block_extra ul.comments_advices a.reviews ",
				offset:100,
			});
		});
	})(jQuery);

bon courage

Share this post


Link to post
Share on other sites
2 minutes ago, okom3pom said:

F12 

Merci

J'ai bien vu les erreurs sur le owlCarousel mais je ne sais pas vraiment comment résoudre cette erreur.

Share this post


Link to post
Share on other sites

En 1.7 on ne s'amuse plus à balancer des script directement dans le code source, donc utilisez des modules compatible 1.7 ou expliquez aux dev comment faire leur boulot.

Share this post


Link to post
Share on other sites

Profitez en pour désactiver le module dans la même catégorie pour voir aussi ;) ( c'est lui qui utilise Owl ) .
1°/ Désactivez Commentaire

2°/ Désactivez "same category"

Edited by Atch (see edit history)

Share this post


Link to post
Share on other sites
1 minute ago, Mediacom87 said:

En 1.7 on ne s'amuse plus à balancer des script directement dans le code source, donc utilisez des modules compatible 1.7 ou expliquez aux dev comment faire leur boulot.

Moi je n'ai rien touché :D

Juste le thème qui ne doit pas être très bien réalisé à mon avis ...

Share this post


Link to post
Share on other sites

Je ne m'adressez pas spécialement à vous en particulier, mais juste que vous avez sur ce prestashop des modules qui ne sont pas compatible 1.7. comme le conseil Atch, désactivez les et vous devriez corriger le soucis et donc devoir mettre à jour ces modules si se sont des modules tiers.

Share this post


Link to post
Share on other sites

Le module commentaire ne respectant plus la loi en France il vaut mieux ne pas le réactiver. 

D'ailleurs ce put1 de module est dans ma TODO ligne 1548 🤔 

Share this post


Link to post
Share on other sites
4 minutes ago, Mediacom87 said:

Je ne m'adressez pas spécialement à vous en particulier, mais juste que vous avez sur ce prestashop des modules qui ne sont pas compatible 1.7. comme le conseil Atch, désactivez les et vous devriez corriger le soucis et donc devoir mettre à jour ces modules si se sont des modules tiers.

Ca y est ! J'ai trouvé le module qui foutait la m...

image.thumb.png.2d25a0da0fe70d2170e4ccd975bcadef.png

Bizarre quand même puisqu'il s'agit d'un module développé par prestashop et intégré à la version installée.

J'en ai profité pour désactiver le module des commentaires / avis mais je ne savais pas que cela ne respectait plus la loi Française @okom3pom !

Merci pour vos aides !

 

Dernière question, comment passer le post en "Résolu" ?

 

 

Share this post


Link to post
Share on other sites

bah voilà, sans les modules qui merdent, ça fonctionne mieux lol

Purée, 10 mois sans poster sur le forum, ça fait du bien de revenir :)
Qui va payer sa tournée ?

 

Share this post


Link to post
Share on other sites
Just now, okom3pom said:

En envoyant 50€ à @Atch sur son paypal.

LOL
Ouai je mettrai le "résolu" après une bonne binouse !

Share this post


Link to post
Share on other sites

Pour les avis vous devez maintenant ajouter des informations sur la manière dont vous collectez les avis, la modération et le classement des avis.

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour j'ai attéri sur votre topic car j'avais le même soucis et je recherchais donc des solutions...

J'ai donc été dans les modules pour tenter de résoudre le problème en désactivant les avis que je venais d'installer (donc le problème ne pouvait venir que de là)

Et là je m'apperçois qu'il faut le mettre à jour...je clic donc sur mise à jour, je vide la cache, je retourne sur mon site et problème résolu :)

Voilà je voulais juste partager ça avec vous au cas où ça pourrait aider quelqu'un.

Bon aprem 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More