Jump to content
Arno78

PS 1.6.1.7 - Duplicate entry ERROR

Recommended Posts

Hallo

Ich hoffe jemand kann uns helfen.

Bekomme wenn ich in den Eigenschaften eines bereits vorhandenen Artikels etwas ändern will folgende Fehlermeldung (Screenshot ist auch nochmal dabei als Anhang)

 

Duplicate entry
INSERT INTO `ps_specific_price`

 

hat evtl. jemand einen Tipp woran das liegen könnte?

 

Vielen Dank

PS Fehler.png

Share this post


Link to post
Share on other sites

Hallo!

Der Screenshot ist winzig und völlig unleserlich.

Tritt das Problem nur bei einem Artikel auf oder bei allen? Wie ist es bei einem neu erstellten Artikel?

Welche PHP-Version verwendest du, wurde diese evtl. vom Provider geändert?

Edited by rictools

Share this post


Link to post
Share on other sites

Hallo.

Seitdem PS läuft haben wir Artikel immer nur per Duplizieren angelegt.

Bei einigen habe ich diesen Fehler nicht bemerkt - aber bei den meisten.

Diese Fehler sind erst aufgetreten, seit dem wir unseren Server zu einem anderen Provider umgezogen haben.

Um welche PHP Version es sich handelt - muss ich erst noch nachfragen, sobald ich Antwort habe werde ich es hier Posten.

 

Anbei noch einmal der Screenshot.

 

 

Fehler.png

Share this post


Link to post
Share on other sites

Dann spricht einiges dafür, daß mit den Serverrechten etwas nicht stimmt. Oder eben die PHP-Version nicht paßt.

Wurde vielleicht einmal direkt in der Datenbank gearbeitet. Wurden - evtl. auch per Modul - Produkte gelöscht?

Teste mal, ob das Problem auch bei komplett neu erstellten Artikeln auftritt. Und versuche auch mal einen anderen Browser.

Share this post


Link to post
Share on other sites

Hallo

Vielen Dank für Deine Antwort.

also die PHP Version ist 5.4.16 – damit ist kein Update des PHP gewesen. (die neuste Version ist 7.02)

In der Datenbank selbst wurde nichts geschrieben nur exportier und importiert.

Ich habe es eben noch inmal mit dem Edge Browser ausprobiert.

Seltsamerweise kommt da keine Fehlermeldung, aber es werden auch keine Änderungen abgespeichert / übernommen.

Mit einem ganz neuen Artikel anlegen versuche ich es später auch noch.

Gruß

Share this post


Link to post
Share on other sites

Ich würde auf PHP 5.6  oder 7.0 wechseln (nicht 7.1 oder 7.2).

Wie hattest du denn importiert, vielleicht ist da etwas falsch geschrieben worden ... Es sieht halt so aus, als ob da mit den ID-Zuordnungen etwas nicht stimmt und es deshalb Dopplungen gibt.

Share this post


Link to post
Share on other sites

Hallo rictools

Ersteinmal vielen Dank für Deine Hilfe (Du scheinst "der Retter in der Not" zu sein).

Wie genau importiert worden ist, kläre ich noch mit unserer IT Firma ab, die das gemacht hat.

Ich habe eben einen Artikel manuel angelegt und konnte alles machen ohne Fehlermeldung.

Also (so ist es auch logisch für mich) scheint etwas mit den ID´s beim Import nach dem Serverumzug falsch gelaufen zu sein.

Die Frage ist nun wie kann das am einfachsten "repariert" werden?

 

Gruß

Share this post


Link to post
Share on other sites

Ich fürchte, dazu benötigt man tiefergehende Kenntnisse der Datenbankstruktur. Oder man müßte die vorhandenen Artikel löschen und neu importieren.

Du kannst natürlich auch anhand der Fehlermeldung die Datenbank gezielt durchforsten und nach falschen ID-Zuordnungen suchen.

Wie lange ist der Import denn her? Vielleicht existiert auch noch eine alte Version der Datenbank.

Bevor du an der Datenbank rumbastelst, sichere aber den derzeitigen Zustand für den Fall, daß du dir die Datenbank komplett zerschießst!

Share this post


Link to post
Share on other sites

Hallo kurzes Update.

Unsere IT Firma hat jetzt auf PHP 7.2 aktuallisiert.

Und ein Update auf PS 7.5 (neuste Version) durchhgeführt.

Fehler sind behoben. Es mus jetzut nur die "Forntpage" "nachgebaut werden.

Aber Datenbank technisch und vom  Bearbeiten der Artikel läuft jetzt erst mal alles.

Wenn die Seite wieder zu 100% Online ist gebe ich noch einmal kurz Rückmeldung.

Gruß

Share this post


Link to post
Share on other sites

Hallo

 

Wir haben jetzt ein Update auf Version 1.7.5 duchgeführt.

Leider selber Fehler:

Duplicate entry '41-0-0-0-0000-00-00 00:00:00-0000-00-00 00:00:00-1-0-0-0-0-20-3' for key 'id_product_2'

INSERT INTO `ps_specific_price` (`id_shop_group`, `id_shop`, `id_cart`, `id_product`, `id_product_attribute`, `id_currency`, `id_specific_price_rule`, `id_country`, `id_group`, `id_customer`, `price`, `from_quantity`, `reduction`, `reduction_tax`, `reduction_type`, `from`, `to`) VALUES ('0', '1', '0', '41', '0', '0', '3', '0', '0', '0', '-1', '20', '0.1', '0', 'percentage', '0000-00-00 00:00:00', '0000-00-00 00:00:00')

 

Was können wit jetzt noch tun?

Fehler kam jetzt wieder als ich bei einem bestehenden Artikel unter den Eigenschaften etwas änder wollte.
Hatte das gleich nach dem Update nicht ausprobiert

Bin schon etwas verzweifelt.

 

Gruß

Edited by Arno78

Share this post


Link to post
Share on other sites

Hallo

auch hier kurz zur Info:

Fehler konnten jetzt nur duch ein Prestashop Ticket (durch den Support) gelöst werden.

Gruß

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More