Jump to content
thokawa75

Neuen Shop parallel zum alten erstellen

Recommended Posts

Hallo Leute,

ich benutze seit Jahren den Prestashop und meine aktuelle Version ist die 1.6.0.9.
Updates wurden länger nicht mehr gemacht, da mir einfach auch die nötige Zeit dazu fehlt immer alles auf dem neuesten Stand zu halten...
Habe eine kleine Schreinerei und biete über diesen Shop unter anderem meine Produkte an - von dem her viel Arbeit und wenig Zeit ;-)

Nun gibts immer mehr Probleme mit dem Shop - die Sicherheitseinstellungen sind sicher veraltet, die Emailfunktion spinnt immer wieder, diverse andere kleine Dinge die nicht mehr passen - vor allem im Backoffice...
Ich denke, das es sinnvoller ist gleich einen Shop zu installieren, der auf dem aktuellsten Stand ist, bevor ich mich jetzt hier abmühe und zeitaufwändig Stückwerk betreibe...

Ist die neue Version 1.7 zu empfehlen?
Und kann ich neben meinem bestehenden Shop erstmal den neuen Shop installieren, die Produkte soweit einpflegen und einrichten - wenn JA, wie würde das funktionieren?
Entschuldigt bitte die evtl. dumme Frage, aber ich kenne mich da nicht so gut aus und möchte nicht unbedingt den Shop deaktivieren, während der neue über Tage oder Wochen neu erstellt wird....

Danke euch schon mal.

LG

Share this post


Link to post
Share on other sites
vor 2 Stunden schrieb thokawa75:

Ist die neue Version 1.7 zu empfehlen?
 

Da du keine Zeit hast, kann ich dir nur raten Hände weg von 1.7 mehr dazu hier 

Die meisten Profis hier im Forum raten zu 1.6.1.10 

Lg

Share this post


Link to post
Share on other sites

Danke.
Das 1.7 etwas problematisch ist wusste ich schon. Wurde ja am Anfang schon abgeraten.
Nun gibts diese Version ja doch schon etwas länger und ich dachte das dies nun doch schon etwas ausgereifter wäre und empfehlenswert dies zu installieren....

Nun gut, dann lieber nicht...
Dann doch lieber Deine empfohlene 1.6.1.10 - ist diese Version auch aufs deutsche Recht angepasst?
Weiss nur das ich damals bei meiner Version teils wochenlang dran gearbeitet habe bis alles soweit gepasst hat.

Share this post


Link to post
Share on other sites

Und noch eine Frage - wie würdest Du es machen den neuen Shop parallel aufzuziehen, während der alte Shop noch online ist?
Damals hatte ich mir die Domain und den Speicherplatz besorgt, Shopsystem installiert und angepasst - während der Shop im Wartungsmodus war.
Diesmal gehts so leider nicht, da der Shop online sein muss...

Share this post


Link to post
Share on other sites
vor 4 Stunden schrieb thokawa75:

Weiss nur das ich damals bei meiner Version teils wochenlang dran gearbeitet habe bis alles soweit gepasst hat.

Heißt das, daß du Produkte verkaufst, die besondere Anforderungen bzgl der Rechtsverträglichkeit an den Shop stellen, denn auch beim 1.6.0.9 ging das im Normalfall eigentlich in wenigen Minuten zum Einrichten wie auch bei den aktuellen Versionen?

Meine Empfehlung wäre, wenn man momentan einen neuen Shop aufbaut, die aktuelle 1.6er Shopversion, das wäre die 1.6.1.23 zu verwenden, auch wenn sie bei den downloads etwas versteckt angeboten wird. Die Umstellarbeiten um den Shop unter php 7.2 betreiben zu können sind überschaubar.

vor 4 Stunden schrieb thokawa75:

wie würdest Du es machen den neuen Shop parallel aufzuziehen,

Da gibt es ja nun viele Möglichkeiten, entweder zuerst lokal installieren oder auf einem 2. Server installieren oder in einem Unterverzeichnis deines jetzigen Servers installieren und dann wenn alles läuft umkopieren. Vorher Backup machen, das du jederzeit auf die lauffähige Version zurück kannst falls etwas schief läuft.

Grüsse
Whiley

Share this post


Link to post
Share on other sites

Hallo nochmal,

nochmal zur Thema Rechtssicherheit... habe gelesen das ab der Version 1.6.1 das Modul "EU Legal" nicht mehr nötig ist, da schon integriert.
Habe mir die empfohlene Version 1.6.1.23 installiert.
Gibt es sonst noch Module die nicht fehlen sollten? Irgendwelche Empfehlungen?

Share this post


Link to post
Share on other sites
vor 12 Minuten schrieb thokawa75:

. habe gelesen das ab der Version 1.6.1 das Modul "EU Legal" nicht mehr nötig ist, da schon integriert.

Das ist so leider nicht ganz richtig, das damalige Modul "EU Lagal" wurde durch ein sog. Nativ Modul "Europäische Rechtssicherheit" oder auch AEUC ersetzt, das solltest du unbedingt als erstes installieren und im BO richtig einrichten.

Grüsse
Whiley

Share this post


Link to post
Share on other sites

ah, ok... danke.
ist das beide das gleiche, also das modul "europäische rechtssicherheit" und "aeuc" oder gibts da unterschiede?
da ich schon länger hier nichts mehr gemacht habe müsste ich mich erst mal wieder ein wenig reinarbeiten hier bezügl. wo ich die ganzen passenden module herbekomme...
kannst du mir da vielleicht noch nen tipp geben wo ich dieses modul, passend für meine 1.6.1.23 version herbekomme?
was ich sonst noch so an wichtigen modulen brauche werd ich hier mal im forum nachforschen... gibts ja sicher die ein oder anderen beiträge dazu...

danke schon mal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More