Jump to content
Prestatest

Sélection transporteur impossible (MAJ 1.4 à 1.6.1)

Recommended Posts

Posted (edited)

Bonjour,

J'était en version 1.4 et j'ai migré en 1.6.1.

Mais je rencontre un problème au niveau du transport.

Sur l'article, onglet "livraison"

Il y a deux box, celle de gauche "transporteurs disponibles" et à droite "transporteurs sélectionnés"

Quand je prend un transporteur disponible, et le met dans sélectionnés, il s'affiche bien dans la box de droite, mais quand j'enregistre, il disparaît.

Et la box droite est de retour vide (transporteurs sélectionnés)

Je n'ai pas de haute connaissance en prestashop, mais j'ai l'impression que cela pourrait venir d'un module transporteur que j'avais sur la version 1.4 (qui est bien sur depuis désactivé et désinstaller) mais il a peut être mis un code dans "override" et de ce fait avoir conservé ses codes malgré la mise à jour, rendant ainsi le transport de la 1.6.1 inutilisable ?

Après ce n'est qu'une théorie sans grand fondement, j'essaye juste de comprendre ce qui pourrait causer cela.

Quelqu'un aurait-il une idée ou chercher ?

 

Edited by Prestatest (see edit history)

Share this post


Link to post
Share on other sites

Effectivement, cela m'affiche les erreurs suivantes :

 

Notice: Use of undefined constant _RIJNDAEL_KEY_ - assumed '_RIJNDAEL_KEY_' in /home/site/www/dossier site/classes/Cookie.php on line 79

Notice: Use of undefined constant _RIJNDAEL_IV_ - assumed '_RIJNDAEL_IV_' in /home/site/www/dossier site/classes/Cookie.php on line 79

Warning: openssl_decrypt(): IV passed is only 7 bytes long, cipher expects an IV of precisely 16 bytes, padding with \0 in /home/site/www/dossier site/classes/Rijndael.php on line 91

 

Et quand je suis en define('_PS_MODE_DEV_', true)  et que je vais donc sur l'onglet livraison dans un produit, cela tourne en rond

(en affichant les flèches en cercle avec "chargement" mais cela ne charge jamais) 

Alors qu'en false, ça m'affiche bien le contenu de l'onglet livraison (transporteur disponible et sélectionné) mais ne prend rien en compte quand je souhaite enregistrer mes choix

 

 

Share this post


Link to post
Share on other sites

Dans le cas ou aucune solution ne pourrait être trouvé, pourriez-vous m'indiquer si on peut "migrer" une boutique vers une nouvelle installation ?

Donc au lieu ici d'avoir fait une maj, qui crée du conflit partout, j'installe une nouvelle boutique où j'y insert tout les produits/catégories ? (6000 références)

 

Pour information, non je ne peux pas repasser en 1.4, car en 1.4 il m'était impossible d'avoir le certificat SSL (alors qu'en 1.6.1 cela a directement été faisable) et donc sans cela, les payement en ligne n'était plus possible. Donc j'ai "l'obligation" de rester sur une v1.6 et ne pas retourner en 1.4 (ce qui serait pourtant le plus simple)

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More