Jump to content
Imaginis

L'installation de Prestashop 1.7.4.4 bloque à 12% sur OVH

Recommended Posts

Bonjour !

J'installe Prestashop 1.7.4.4 sur l'hébergement OVH (Mutualisée Perso 2014) d'un client.

L'installation bloque à 12% (capture ci-joint) lors de l'étape "1 : Updating database schema..."

Le support OVH me répond à côté de la plaque : "Visiblement votre module essaie de mettre à jour des "SCHEMA" sur votre base de donnée. A savoir que cette fonction de base n'est pas autorisé sur notre infrastructure, ce pourquoi votre mise à jour n'aboutit pas. Je vous invite à vérifier ce qui provoque justement cette tentative (plugin, thème, module)."
Je leur ai pourtant expliqué que je n'installais pas un module mais Prestashop en lui même... Et que si leur infrastructure n'autorisait pas un processus entrant dans l'installation de Prestashop, il y avait comme un problème... Bref, dialogue de sourd. Non seulement ils lisent mes demandes en diagonale, mais en plus ils ont mis 2 semaines à me répondre (j'ai dû les relancer sur Twitter).

Je tente donc de trouver une réponse parmi la communauté. L'hébergement OVH m'est imposé par le client, j'ai cru lire ça et là que ce n'était pas l'idéal pour Prestashop, mais je n'ai pas le choix. Toutefois ce n'est pas la 1ère fois que j'installe Prestashop 1.7 sur ce type de formule d'hébergement mutualisé d'OVH, mais c'est la 1ère fois que je suis confronté au problème.

Le client a un blog WordPress déjà installé sur cet hébergement. Il n'a pas voulu que je créé une nouvelle base de donnée pour Prestashop car OVH facture toute base de donnée supplémentaire... J'essaie donc d'installer Prestashop sur une base de donnée contenant déjà des tables WordPress et je me demande au final si ce n'est pas la présence de ces tables WP qui me bloque l'installation ?

Est-ce qu'installer Prestashop 1.7 sur une base de donnée qui n'est pas vierge peut poser ce type de problème ?

Merci par avance pour vos retours !

Damien.

 

prestashop-12pourcent.jpg

Edited by Imaginis
Fautes + Précisions (see edit history)

Share this post


Link to post
Share on other sites

La réponse la plus WTF de l'univers de la part du support OVH.

Mise à jour du schéma, veux dire créer des tables et des colonnes dans la bdd.

Si c'est pas supporté par l'infrastructure OVH alors ça veux dire qu'il est impossible d'utiliser une base de données

ça donne ça comme réponse quand ils prennent des stagiaires de laponie

  • Like 1

Share this post


Link to post
Share on other sites

Et vous pensez qu'installer des tables Prestashop sur une base de donnée contenant déjà des tables Wordpress pourrait causer ce type de problème ? 

Share this post


Link to post
Share on other sites
On 2/2/2019 at 1:38 PM, david1200 said:

Bonjour, avez vous solutionné ce problème ? J'ai le même soucis... Merci

Oui, j'ai du créer une base de donnée indépendante pour y installer exclusivement Prestashop.

Share this post


Link to post
Share on other sites

Même problème ! En plus leur installation en "Un Clic" bugue en ce moment. Ils m'invitent donc à faire une installation manuelle.... et ça bugue aussi.

Pas d'autres solutions depuis février ?

 

Share this post


Link to post
Share on other sites

Renseignements pris auprès de la Hotline d'OVH c'est bien un conflit entre BDD. 

J'ai donc installé PS 1,7 sur une autre BDD et ça fonctionne.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More