Jump to content
SiT-Media

Mein erster Prestashop

Recommended Posts

Schönen guten Tag,

ich bin neu hier und möchte meinen ersten kleinen Shop mit Prestashop erstellen. Bitte gebt mir ein paar Hinweise, welche Tutorials und Anleitungen ich mindestens gelesen / angeschaut haben sollte, bevor ich loslege.

Herzlichen Dank
Stefan

Share this post


Link to post
Share on other sites

Hallo Stefan,

willkommen im Forum.

Imo ist es vernünftig erstmal einen Testshop aufzusetzten, ein paar Artikel einzustellen, eine Kategorie anzulegen, Rechtssicherheit zu installieren, Versand- und Zahlungsmodule einzurichten - das alles läßt sich zunächst intuitiv abarbeiten.

Wenn du auf Probleme stößt findest du hier die wichtigsten Anleitungen:

https://www.prestashop.com/forums/forum/275-benutzerleitfäden/

oder stellst hier im Forum gezielt deine Fragen.

Danach machst du den Test-Shop platt und erstellst mit deinem neu gewonnenem Wissen deinen echten Shop.

Ganz wichtig, bevor du anfängst, mach dir Gedanken welche PS-Version du verwenden willst. Momentan gibt es ja die Version 1.6.xxx und 1.7.xxxx.

Grüsse
Whiley

Share this post


Link to post
Share on other sites
3 hours ago, Whiley said:

Ganz wichtig, bevor du anfängst, mach dir Gedanken welche PS-Version du verwenden willst. Momentan gibt es ja die Version 1.6.xxx und 1.7.xxxx.

Herzlichen Dank Whiley! Der Testshop ist eine gute Idee. Dann kann ich einfach kopieren, was ich schon aufgebaut habe.

Sind die Unterschiede zw. 1.6 und 1.7 denn so groß? Normalerweise würde ich immer mit der neuesten Version anfangen, damit ich später einmal weniger updaten muss. Es sei denn es gibt gute Gründe dagegen. Deutsche Rechtssicherheit gibt es ja für beide. In den jeweiligen Manuals habe ich keinen Hinweis auf die Unterschiede gefunden.

Viele Grüße
Stefan

Share this post


Link to post
Share on other sites

Die Unterschiede zwischen 1.6 und 1.7 sind sehr groß. Die Dateistruktur ist eine ganz andere und wie es scheint (also was ich so beim lesen des Forums mitbekommen habe) sind einige Funktionen welche 1.6 standardmäßig dabei waren bei 1.7 nicht mehr enthalten und müssen teils Kostenpflichtig nachgerüstet werden.

Da ich mit 1.6 und dessen Dateistruktur vertraut bin habe ich mit 1.7 so meine Schwierigkeiten und konnte mich bis heute nicht damit anfreunden. Wenn man jedoch neu bei PrestaShop ist und man dementsprechend weder die Struktur von 1.6 und 1.7 kennt dürfte es keinen Unterschied machen welche das man lernt. In dem Fall würde ich, entgegen der weitläufigen Meinung hier im Forum, eher mit 1.7 starten. Das einzige Problem ist halt dass die meisten im Forum 1.6 einsetzen und dementsprechend bei 1.7 nur bedingt Hilfe geben können. Im englischsprachigen Teil des Forums gibts aber auch genügend User welche bei 1.7 helfen können.

Zum Thema "Deutsche Rechtssicherheit" kann ich nicht viel sagen, aber die dürfte seit 1.7.5 mit dem dementsprechenden Modul auch gegeben sein. Da müsste aber Whiley mehr dazu wissen.

Share this post


Link to post
Share on other sites

Hallo Stefan,

Infos zum Thema findest du zu Hauf hier im Forum, z.B.

Es kommt halt drauf an ob du aus dem Thema Shoperstellung ein Hobby machen willst und entsprechend viel Zeit hast, oder ob du mit deinem Shop Geld verdienen möchtest und zeitnah zum Ziel kommen willst.

Zwar hat Prestashop vor kurzem erkärt, einige der fehlenden Funktionen nun doch in den 1.7er einzubauen (" We understand that many of you in our community are anxiously waiting for certain features included in 1.6 to be added to 1.7 before making the switch. We are currently focusing our efforts on making such changes in the upcoming 1.7.5 and 1.7.6 versions. ").

Es bleibt aber abzuwarten ob das unter dem Gesichtspunkt einer vernünftigen Performance überhaupt möglich sein wird.

Share this post


Link to post
Share on other sites

Boah, und ich hatte gedacht, ich finde hier ein mulitfunktionales, verlässliches Shopping-System, das die Kinderkrankheiten längst hinter sich hat 🙂

Herzlichen Dank für die Antworten. Wenn ich nun auch ein bisschen verunsichert bin, so ist es doch gut das Für und Wider zu kennen.

Wenn ich mit einem kleinen Shop neu anfange, wäre 1.7 durchaus eine Option.  Wenn ich viele Add-ons brauche, wiederum nur, wenn ich bereit bin zu bezahlen. Fehlen essentielle Funktionen in 1.7?
Ein Knackpunkt dürften die Anpassungen sein. Ich bin kein Programmierer und möchte entsprechend wenig Code, CSS usw. ändern. Was spricht sonst noch gegen 1.6?

PRO 1.7

  • späterer Wechsel nicht nötig
  • längerer Support /Aktualisierungen
  • kaum kostenpflichtige Add-ons nötig
  • manche Add-ons werden zukünftig eher für 1.7 in einer aktuellen Version zu erhalten sein (außer vielleicht Bezahlsysteme)

CONTRA 1.7

  • Performance / Speicherverbrauch
  • größerer Aufwand (ich bin kein Programierer)
  • weniger kostenlose Add-ons (oder überhaupt weniger Add-ons?)
  • Deutsche Rechtssicherheit???

PRO 1.6

  • Deutsches Forum mit viel Erfahrung in 1.6 und deutsches Benutzerhandbuch (E ist okay, aber ich bin in D deutlich präziser)
  • viele kostenlose Add-ons
  • weniger Anpassungen nötig (???)
  • erprobt und verlässlich ???

CONTRA 1.6

  • begrenzte Aktualisierungen

Share this post


Link to post
Share on other sites

Egal ob 1.6 oder 1.7, bei beiden Shops ist es unerlässlich dass man sich mit der Materie beschäftigt und zumindest keine Angst davor hat mal etwas am Code zu ändern wenns nötig sein sollte. (Man muss kein Programmierer sein, es reicht wenn man Anweisungen genau liest)

Wenn du das ausgereifte suchst das läuft nimm 1.6
Es gibt noch Support von PrestaShop bis irgendwann 2019 und wenn man ehrlich ist, man muss nicht immer alles updaten.
Sollte der Support für 1.6 auslaufen und es sicherheitsrelevante Gründe für einen wechsel geben gibt es vielleicht schon eine Version 1.8 von PrestaShop und ansonsten kann man ja schauen wie sich das "30 Bienen" Projekt bis dahin entwickelt hat welches ja von Presta 1.6 geforkt wurde und somit weitgehend kompatibel sein sollte.

Wenn du was suchst ständig up to date ist und in der Basisversion etwas moderner aussieht dann nimm 1.7

Bedenke dass jedes Update, egal ob für 1.6 oder 1.7, einen Bug mitbringen kann und gerade bei 1.7 vielleicht auch größere Probleme wenn neue Features implementiert werden.

Du kannst ja einfach mal beider Versionen testweise installieren und dann schauen welche Grundfunktionen dabei sind und ob du irgendwas vermisst oder welches dir besser liegt.
Kommt auch drauf an was du für ein Hosting hast. Einige Hoster haben den Support von php 7.0 eingestellt und bieten nur mehr php 7.2 womit 1.6 nicht so weiters arbeitet.

Share this post


Link to post
Share on other sites

Ich würde auch beide installieren und mal schauen, womit ich besser arbeiten kann. Irgendeinen Grund muss es ja geben, warum fer eine oder andere Nutzer das eine oder andere System bevorzugt.

PHP 7.2 wäre natürlich für den unbedarften User der primäre Grund, den 1.6 nicht zu verwenden, da es hier definitiv noch unklar ist, wo die Inkompatibilitäten überall lauern. Es kann einerseits direkt im Core des Systems sein, aber eben auch in der einen oder anderen essentiell wichtigen Erweiterung. Man kann zwar vieles umcoden, aber das macht die Sache dann nicht besser, wenn man irgendwann den halben Code verändert hat und keine Updates ohne weiteres laufen.

Share this post


Link to post
Share on other sites

Die Core-Änderungen, um Prestashop 1.5 oder 1.6 lauffähig zu machen unter PHP 7.2 sind nicht sonderlich umfangreich. Und ja: Das mag auch für das eine oder andere Modul erforderlich sein. Wer es nicht selbst kann, findet bestimmt einen Programmierer, der das für einen überschaubaren Betrag erledigt. Umgekehrt wird ein Schuh draus: Wer sich für Prestashop 1.7 entscheidet, sollte wissen, dass es sich zur Zeit noch um einen Hybrid handelt, der z.T.noch mit PHP und Smarty arbeitet, z.T. aber schon in Symfony (mit einer gänzlich anderen Dateistruktur und einer geänderten Syntax und Softwarearchitektur) umgeschrieben ist. Auf lange Sicht werden die alten Teile völlig verschwinden. Symfony wiederum läuft aber nur richtig rund unter PHP 7.2. Sonst gibt es unweigerlich Probleme. Und die hat 1.7 auch so noch reichlich, wie die zahlreichen Bugfixes mit jeder neuen Version eindrucksvoll belegen. Und auch in Sachen Sicherheit könnte man sich hier unter Umständen eine weitere Baustelle einhandeln. Denn auch Symfony ist nicht frei von Sicherheutslücken: https://www.cvedetails.com/vulnerability-list/vendor_id-11981/product_id-22402/Sensiolabs-Symfony.html

Share this post


Link to post
Share on other sites

Hi,

wir sind auch erst vor kurzem mit einem von unseren beiden Shops zu Presta gewechselt und haben uns für 1.6.1.10 entschieden. Aus gutem Grund: Unseren Laden gibt es bereits länger und läuft sehr gut, da haben wir nicht die Zeit uns ewig mit Kinderkrankheiten rum zu schlagen, von daher kam für uns nur die 1.6 in Frage. Updaten werden wir vermutlich erst in 2 Jahren auf die 1.8 und auch nur dann wenn diese stabil läuft. 

Baut man aber den Shop neu auf, würde ich die 1.7 empfehlen.

Lg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More