Jump to content
magicball

[SOLVED]The jbx_menu drop down menu goes under slide images in IE.

Recommended Posts

Hi,

i just installed the jbx_menu module, everything works fine but on IE when you open the dropdown it is displayed under the slide images below.

This is the script of my slide


{if $page_name== 'index'}

cc1.jpg
cc2.jpg
cc3.jpg

{/if}

obviously this is just a piece of the code, i tired to put z-index:something in the img style as the div it self works fine if i remove the images, but when i put back my jquery slide in IE the dropdown menu goes under the slide. Ufff!!! :)

Thanks

Share this post


Link to post
Share on other sites

Thanks for the advice. I'll try. I have to tell you that on my IE7 your site about stickers shows the exact same problem as mine, maybe it is my browser, the second dropdown "sticker objets" menu goes under the slide images and both "stickers muraux" and "stickers objets" aren't displayed correctly like the other items in the menu but lower a few pixels, when you sort it out let me know how you did that..

Thanks.

Talk to you soon.

Share this post


Link to post
Share on other sites

Sorry i thought you was talking about a flash slider...

On stickersmania, to get the images displayed over the slider, i did this :

1) In the module parameters, set "Position index" to 10000

2) In the superfish-modified.css, to fix it in IE7 (thanks to you)

add "z-index: 10000;" to this style ==> (around line 114-115)

.sf-menu li:hover, .sf-menu li.sfHover, .sf-menu li.sfHoverForce,
.sf-menu a:focus, .sf-menu a:hover, .sf-menu a:active {

3) To fix the "Stickers muraux" and "Stickers objets" bug
In the module paramaters set "Alignement vertical" to 0

Share this post


Link to post
Share on other sites

Hi!

I've got the same problem, dropdown menu under slides, I tried what you said Patanock but it doesn't work... Any other solution? Did you fixed it Magicball?

PS 1.3.2.3. Jbx 2.6.4

Thanks in advance!

Share this post


Link to post
Share on other sites

Hi, I have the JMS slider, where do i add wmode="transparent"  to?

 

Thank You

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More