Jump to content
ttoine

PrestaShop 1.7.5.0 is available

Recommended Posts

After a Beta and a Release Candidate, the long awaited PrestaShop 1.7.5.0 has been released and is available for download. As usual, you can upgrade with the Auto upgrade module. However, considering that the current period is usually critical for merchants sales, for sure, some might prefer to wait for a more appropriate time 🙂

1.7.5.jpg

Read the release note on the Build blog:
http://build.prestashop.com/news/prestashop-1-7-5-0-available/

 

  • Like 6

Share this post


Link to post
Share on other sites

Thanks for the news, saw that on Twitter some 18 hours ago, already upgraded a few shops with no issues.

But, no Buy Button module yet (the Lite version) yet?

  • Like 1

Share this post


Link to post
Share on other sites

So currently, you can't find it in the module manager of the BO, after an upgrade to 1.7.5 right ?

Did you try when you do a fresh install ?

Share this post


Link to post
Share on other sites

No, I didn't try on a new install yet but I will.

For the moment I have upgraded some shops I delayed the upgrade for some time now because I was waiting for the 1.7.5 to come out.

I guess by your reply that in a new shop this module should be available?

Do you happen to have a link to it, github or else for these cases, where it doesn't appear on upgrades?

Share this post


Link to post
Share on other sites

This is great news.  I plan on upgrading four in-house clients to 1.7.5.0 in January...perfect timing for us.

Share this post


Link to post
Share on other sites

@razaro thanks! so it happens that currently I am working on something else that uses vue (which I am currently studying) so this module can shed a light on what PS intends to deal with that.

People seem to be quite interested in such a by button, I have to study it to see how it works and how can it be included on other platforms.

  • Like 1

Share this post


Link to post
Share on other sites

I just tried to upgrade to from 1.7.4.4 to 1.7.5 by using the 1-click-upgrade function.
It worked well and no error was shown, but I lost a lot of modules (not found):

Modul « Product Page »
Modul  « Payment »
Modul « Shipping & Logistics »

and so on...

Should I better wait for a next update version ?

BR Gerald

Share this post


Link to post
Share on other sites
3 hours ago, G.S said:

I just tried to upgrade to from 1.7.4.4 to 1.7.5 by using the 1-click-upgrade function.
It worked well and no error was shown, but I lost a lot of modules (not found):

Modul « Product Page »
Modul  « Payment »
Modul « Shipping & Logistics »

and so on...

Should I better wait for a next update version ?

BR Gerald

 

PS during upgrade will (i think optionally) disabled all 3rd party modules and overrides.  go to your performance  page and set to No 'disabled non PrestaShop Modules' and 'overrides'.

maybe this helps

el

Share this post


Link to post
Share on other sites

I am still using 1.6.1.x branch, is it now possible to migrate to 1.7.x using the 1-click upgrade? Is it even advisable at this point? It has been some time now that 1.7 is out and I would like to get some of the new features, what do you guys think?

Thanks!

Share this post


Link to post
Share on other sites
1 hour ago, bcarron said:

I am still using 1.6.1.x branch, is it now possible to migrate to 1.7.x using the 1-click upgrade? Is it even advisable at this point? It has been some time now that 1.7 is out and I would like to get some of the new features, what do you guys think?

Thanks!

We have been long time fans of 1.7 and yes autoupgrade has basically been rewritten/refactored for 1.7 upgrades.  Before starting an upgrade you should first create a test copy of your shop to test your upgrade.  We advise 1.7 upgrades when done responsibility, i.e. test copy first.

Share this post


Link to post
Share on other sites

Yes, always backup and test first.

It seems that some modules have a bad impact on the update, so if you have issues with your tests, try to identify them and disable them. When you test is working well, then, migrate your production (and backup again before).

Share this post


Link to post
Share on other sites
6 minutes ago, ttoine said:

Yes, always backup and test first.

It seems that some modules have a bad impact on the update, so if you have issues with your tests, try to identify them and disable them. When you test is working well, then, migrate your production (and backup again before).

we have 'very strict process' for upgrades it concerns modules/overrides.  This is a section of one of a client upgrade

1) identify 'must have' modules

2) find their replacement 1.7 versions

3) on test copy, uninstall 'all' 3rd party modules 

4) on test copy remove all overrides that were not removed by module uninstalls

5) we then checkpoint, back up this test copy (in-case we need to restore and try upgrade again)

6) perform native PS upgrade

7) install/configure 1.7 modules

-----

if one follows these basic steps the upgrade process will go 'much' smoother.  Note: PS will disable 3rd party modules/overrides at upgrade but it's best not to have them installed at upgrade time.

Happy upgrading, we are in process of upgrading two 1.6 default theme shops to 1750 with kick butt themes....I love the smell of new upgrades.

el

 

  • Like 2

Share this post


Link to post
Share on other sites

Question: I try to install a Fresh version on my hosting plateforme, i get an error 500 during installation. Also tried in English, samething.

I was building my e-commerce store with 1.7.4.4; i had no issue, but Installatron from my Hosting provider no longer have 1.7.4.4 version.

Here are the Server Log reported during install

 

[Tue Jan 15 09:15:04.936157 2019] [fcgid:warn] [pid 30646:tid 2416909200] [client 204.101.134.2:45255] mod_fcgid: stderr: PHP Fatal error:  Cannot redeclare class IOStruct in /home/copiscan/domains/copiscan.com/public_html/livezilla/_lib/objects.global.inc.php on line 15, referer: http://copiscan.com/
[Tue Jan 15 09:55:20.717779 2019] [fcgid:warn] [pid 30646:tid 2658175888] [client 209.44.113.108:54212] mod_fcgid: stderr: PHP Notice:  Undefined index: HTTP_ACCEPT_LANGUAGE in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 178
[Tue Jan 15 09:55:20.717824 2019] [fcgid:warn] [pid 30646:tid 2658175888] [client 209.44.113.108:54212] mod_fcgid: stderr: PHP Notice:  Undefined index:  in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 126
[Tue Jan 15 09:55:20.717832 2019] [fcgid:warn] [pid 30646:tid 2658175888] [client 209.44.113.108:54212] mod_fcgid: stderr: PHP Notice:  Trying to get property of non-object in /home/copiscan/domains/copiscan.com/public_html/store/classes/Context.php on line 351
[Tue Jan 15 09:55:20.717860 2019] [fcgid:warn] [pid 30646:tid 2658175888] [client 209.44.113.108:54212] mod_fcgid: stderr: PHP Notice:  Trying to get property of non-object in /home/copiscan/domains/copiscan.com/public_html/store/classes/Context.php on line 353
[Tue Jan 15 09:55:20.717867 2019] [fcgid:warn] [pid 30646:tid 2658175888] [client 209.44.113.108:54212] mod_fcgid: stderr: PHP Notice:  Undefined index: HTTP_ACCEPT_LANGUAGE in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 178
[Tue Jan 15 09:55:22.767713 2019] [fcgid:warn] [pid 30646:tid 2752584592] [client 209.44.113.108:54293] mod_fcgid: stderr: PHP Notice:  Undefined index: HTTP_ACCEPT_LANGUAGE in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 178
[Tue Jan 15 09:55:22.767750 2019] [fcgid:warn] [pid 30646:tid 2752584592] [client 209.44.113.108:54293] mod_fcgid: stderr: PHP Notice:  Undefined index:  in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 126
[Tue Jan 15 09:55:22.767757 2019] [fcgid:warn] [pid 30646:tid 2752584592] [client 209.44.113.108:54293] mod_fcgid: stderr: PHP Notice:  Trying to get property of non-object in /home/copiscan/domains/copiscan.com/public_html/store/classes/Context.php on line 351
[Tue Jan 15 09:55:22.767764 2019] [fcgid:warn] [pid 30646:tid 2752584592] [client 209.44.113.108:54293] mod_fcgid: stderr: PHP Notice:  Trying to get property of non-object in /home/copiscan/domains/copiscan.com/public_html/store/classes/Context.php on line 353
[Tue Jan 15 09:55:22.767770 2019] [fcgid:warn] [pid 30646:tid 2752584592] [client 209.44.113.108:54293] mod_fcgid: stderr: PHP Notice:  Undefined index: HTTP_ACCEPT_LANGUAGE in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 178
[Tue Jan 15 09:55:22.767777 2019] [fcgid:warn] [pid 30646:tid 2752584592] [client 209.44.113.108:54293] mod_fcgid: stderr: PHP Notice:  Undefined index: HTTP_ACCEPT_LANGUAGE in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 178
[Tue Jan 15 09:55:24.304720 2019] [fcgid:warn] [pid 30646:tid 2836503440] [client 209.44.113.108:54298] mod_fcgid: stderr: PHP Notice:  Undefined index: HTTP_ACCEPT_LANGUAGE in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 178
[Tue Jan 15 09:55:24.304751 2019] [fcgid:warn] [pid 30646:tid 2836503440] [client 209.44.113.108:54298] mod_fcgid: stderr: PHP Notice:  Undefined index:  in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 126
[Tue Jan 15 09:55:24.304758 2019] [fcgid:warn] [pid 30646:tid 2836503440] [client 209.44.113.108:54298] mod_fcgid: stderr: PHP Notice:  Trying to get property of non-object in /home/copiscan/domains/copiscan.com/public_html/store/classes/Context.php on line 351
[Tue Jan 15 09:55:24.304765 2019] [fcgid:warn] [pid 30646:tid 2836503440] [client 209.44.113.108:54298] mod_fcgid: stderr: PHP Notice:  Trying to get property of non-object in /home/copiscan/domains/copiscan.com/public_html/store/classes/Context.php on line 353
[Tue Jan 15 09:55:24.304771 2019] [fcgid:warn] [pid 30646:tid 2836503440] [client 209.44.113.108:54298] mod_fcgid: stderr: PHP Notice:  Undefined index: HTTP_ACCEPT_LANGUAGE in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 178
[Tue Jan 15 09:55:24.304777 2019] [fcgid:warn] [pid 30646:tid 2836503440] [client 209.44.113.108:54298] mod_fcgid: stderr: PHP Notice:  Undefined index: HTTP_ACCEPT_LANGUAGE in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 178
[Tue Jan 15 09:55:24.304784 2019] [fcgid:warn] [pid 30646:tid 2836503440] [client 209.44.113.108:54298] mod_fcgid: stderr: PHP Notice:  Undefined index: HTTP_ACCEPT_LANGUAGE in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 178
[Tue Jan 15 09:55:25.604791 2019] [fcgid:warn] [pid 30646:tid 2700135312] [client 209.44.113.108:54303] mod_fcgid: stderr: PHP Notice:  Undefined index: HTTP_ACCEPT_LANGUAGE in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 178
[Tue Jan 15 09:55:25.604828 2019] [fcgid:warn] [pid 30646:tid 2700135312] [client 209.44.113.108:54303] mod_fcgid: stderr: PHP Notice:  Undefined index:  in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 126
[Tue Jan 15 09:55:25.604835 2019] [fcgid:warn] [pid 30646:tid 2700135312] [client 209.44.113.108:54303] mod_fcgid: stderr: PHP Notice:  Trying to get property of non-object in /home/copiscan/domains/copiscan.com/public_html/store/classes/Context.php on line 351
[Tue Jan 15 09:55:25.604842 2019] [fcgid:warn] [pid 30646:tid 2700135312] [client 209.44.113.108:54303] mod_fcgid: stderr: PHP Notice:  Trying to get property of non-object in /home/copiscan/domains/copiscan.com/public_html/store/classes/Context.php on line 353
[Tue Jan 15 09:55:25.604848 2019] [fcgid:warn] [pid 30646:tid 2700135312] [client 209.44.113.108:54303] mod_fcgid: stderr: PHP Notice:  Undefined index: HTTP_ACCEPT_LANGUAGE in /home/copiscan/domains/copiscan.com/public_html/store/src/PrestaShopBundle/Install/LanguageList.php on line 178



 

 

 

Share this post


Link to post
Share on other sites

could you please open a separate topic for that problem?

Share this post


Link to post
Share on other sites

Good morning, I'm completing our company website with prestashop 1.7.4.3 with a premium theme purchased a few months ago.
I read a few comments on version 1.7.5.0 and I wanted to know if it's better to update now or wait for more positive reviews.
Thank you

Share this post


Link to post
Share on other sites

Hi Roby,

for me it worked fine. 🖕  Be aware, that the listing of the modules has been changed.
BR

Share this post


Link to post
Share on other sites

Hi,

prestashop version 1.7.5.0 or 1.7.5.1 works with a PHP version 7.3?

Thanks in advance!

BR

Venty

Share this post


Link to post
Share on other sites
On 2/23/2019 at 12:14 PM, venty said:

Hi,

prestashop version 1.7.5.0 or 1.7.5.1 works with a PHP version 7.3?

Thanks in advance!

BR

Venty

Yes. I use PHP version 7.0.22 works. 

Share this post


Link to post
Share on other sites

I use PHP 7.2 with FastCGI + opcache, and it works fine.

  • Like 1

Share this post


Link to post
Share on other sites

PHP 7.3 will be a major step for most CMS project in PHP, because most libraries that support PHP 7.3 are dropping PHP 5.6.

The dev team has started to list the libraries for the PrestaShop open source project:

https://github.com/PrestaShop/PrestaShop/issues/12461

You help is welcome if you have the skills to identify librairies, dependencies or part of the codes in the core and native modules that could have an issue.

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, ttoine said:

PHP 7.3 ще бъде важна стъпка за повечето проекти за CMS в PHP, тъй като повечето библиотеки, които поддържат PHP 7.3, отхвърлят PHP 5.6.

Екипът на Dev е започнал да изброява библиотеките за проекта с отворен код PrestaShop:

https://github.com/PrestaShop/PrestaShop/issues/12461

Вие помагате е добре дошъл, ако имате уменията да идентифицирате изявления, зависимости или част от кодовете в ядрото и родните модули, които биха могли да имат проблем.

prestashop works with PHP 7.2, it would be logical to work with 7.3 ...
Are the libraries of 7.2 not the same as 7.3?

Share this post


Link to post
Share on other sites

iI's not about PHP 7.2 compatibility with PHP 7.3.

It's about some third party librairies and dependencies that are used in PrestaShop. Many are working with PHP 5.6 to 7.2. However, most of them announced that in order to support PHP 7.3, they will drop support of PHP 5.6 and 7.0, as those versions are not supported anymore by PHP. 

When those librairies and dependencies will be updated in the core of PrestaShop, it means that part of the code will support officially only PHP 7.1 to 7.3 (it might still work with earlier version but not officially). That's something important to keep in mind, and that must be prepared very well 🙂

  • Like 1

Share this post


Link to post
Share on other sites

Whats is new in PS 1.7.5.1 from PS 1.7.5.0?

I also have problems with no buy button, in a new install of PS 1.7.5.0
Is that fixed in PS 1.7.5.1?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More