Jump to content
Sign in to follow this  
Monsieur Lapin

Connections impossible au back et front office

Recommended Posts

Bonjour,

Je rencontre un problème depuis hier soir, je n'arrive plus à me connecter au front et au back office.

J'ai le message d'erreur suivant

Quote

[PrestaShopDatabaseException]

Max connect timeout reached while reaching hostgroup 0 after 10001ms
 


SELECT s.id_shop, CONCAT(su.physical_uri, su.virtual_uri) AS uri, su.domain, su.main
					FROM ps_shop_url su
					LEFT JOIN ps_shop s ON (s.id_shop = su.id_shop)
					WHERE (su.domain = 'usagikun.net' OR su.domain_ssl = 'usagikun.net')
						AND s.active = 1
						AND s.deleted = 0
					ORDER BY LENGTH(CONCAT(su.physical_uri, su.virtual_uri)) DESC


at line 791 in file classes/db/Db.php

 


786.         if ($webservice_call && $errno) {
787.             $dbg = debug_backtrace();
788.             WebserviceRequest::getInstance()->setError(500, '[SQL Error] '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97);
789.         } elseif (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS')) {
790.             if ($sql) {
791.                 throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>');
792.             }
793. 
794.             throw new PrestaShopDatabaseException($this->getMsgError());
795.         }
796.     }

En général c'est ce message qui vient s'afficher mais de temps en temps le contenu du premier encadré change comme par exemple

Quote

SELECT COUNT(*) n
			FROM `ps_module_shop`
			WHERE id_module=88 AND id_shop IN (1)
			GROUP BY id_module
			HAVING n=1 LIMIT 1

Pour information, le site est hébergé chez OVH et la version Prestashop est 1.6.1.18 

Ce problème est survenu simplement en passant d'une commande à une autre en cliquant sur la flèche pour passer à la commande suivante

Ne connaissant pas grand chose à tout ça, je demande votre aide

Merci d'avance

Share this post


Link to post
Share on other sites

depuis aujourd'hui ces messages ne s'affiches plus.

Quand je clique sur "se connecter", l'encadré disparaît au bout de quelques secondes laissant seul le logo de Prestashop et 2 messages d'erreurs s'affichent au haut à gauche de la page.


Warning: PDO::query(): MySQL server has gone away in /home/****/****/classes/db/DbPDO.php on line 134

Warning: PDO::query(): Error reading result set's header in /home/*****/*****/classes/db/DbPDO.php on line 134

Quelqu'un à une idée du problème et de comment le résoudre ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More