Jump to content
Sign in to follow this  
lephot

[Résolu] Erreur 500 après installation d'une template

Recommended Posts

Bonjour a tous,

 

J'ai acheté une template chez template monster. J'effectue une première installation sans problème de la template sur mon site principal. jusque là tout va bien.

Pour les besoins de développement de mon site je crée une site "fake" qui ne servira que pour les tests.

Installation de prestashop Ok,  intallation de la nouvelle template (sur le même serveur que la première instal) avec un autre domaine et la je recois une erreur 500 lorsque je souhaite afficher le site alors que le backoffice fonctionne parfaitement.

L'installation s'est faite sur un prestashop 1.7.2.4 car les data de démos sont pour cette version. Je ferais l'upgrade lorsque je serais sur que tout fonctionne. J'ai d'ailleur fait de même pour le site principal sans soucis.

Je vous mets ci-dessous les infos du mode debug :

in FrontController.php line 1203
at ErrorHandler->handleError('8', 'Array to string conversion', '/var/www/vhosts/xxxxxx.fr/httpdocs/classes/controller/FrontController.php', '1203', array('libraries' => array('font-awesome'), 'library' => 'font-awesome', 'assets' => array(array('id' => 'font-awesome-css', 'type' => 'registerStylesheet', 'path' => '/themes/_libraries/font-awesome/css/font-awesome.min.css', 'params' => array('media' => 'all', 'priority' => '10'))), 'asset' => array('id' => 'font-awesome-css', 'type' => 'registerStylesheet', 'path' => '/themes/_libraries/font-awesome/css/font-awesome.min.css', 'params' => array('media' => 'all', 'priority' => '10')))) in FrontController.php line 1203
at FrontControllerCore->requireAssets(array('font-awesome')) in jxheaderaccount.php line 766
at Jxheaderaccount->hookDisplayHeader(array('cookie' => object(Cookie), 'cart' => object(Cart), 'altern' => '7')) in Hook.php line 895
at HookCore::coreCallHook(object(Jxheaderaccount), 'hookdisplayHeader', array('cookie' => object(Cookie), 'cart' => object(Cart), 'altern' => '7')) in Hook.php line 327
at HookCore::callHookOn(object(Jxheaderaccount), 'displayHeader', array('cookie' => object(Cookie), 'cart' => object(Cart), 'altern' => '7')) in Hook.php line 843
at HookCore::exec('displayHeader') in FrontController.php line 544
at FrontControllerCore->initContent() in IndexController.php line 37
at IndexControllerCore->initContent() in Controller.php line 205
at ControllerCore->run() in Dispatcher.php line 379
at DispatcherCore->dispatch() in index.php line 28

 

Voila si vous une idée du problème je suis grandement preneur !

Merci d'avance

Edited by lephot (see edit history)

Share this post


Link to post
Share on other sites

Bonsoir,

 

Problème réglé par template monster avec l'envoi d'un package adapté à la dernière version de prestahop.

J'ignore donc ce qui a été corrigé !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More